summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2005-08-07 19:30:18 +0000
committerCarsten Lohrke <carlo@gentoo.org>2005-08-07 19:30:18 +0000
commit3f745733be9a7771b59520b02bea30a661c67170 (patch)
treeea5243e43450a3cbaaeadb7508da994e13452157 /media-sound
parentExport the MACOSX_DEPLOYMENT_TARGET variable so it is inherited by (diff)
downloadgentoo-2-3f745733be9a7771b59520b02bea30a661c67170.tar.gz
gentoo-2-3f745733be9a7771b59520b02bea30a661c67170.tar.bz2
gentoo-2-3f745733be9a7771b59520b02bea30a661c67170.zip
fix build with postgres
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog5
-rw-r--r--media-sound/amarok/amarok-1.3_beta3.ebuild7
2 files changed, 10 insertions, 2 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index e409e7cbbe05..4ac8273d4d8d 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.65 2005/08/01 17:07:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.66 2005/08/07 19:30:18 carlo Exp $
+
+ 07 Aug 2005; Carsten Lohrke <carlo@gentoo.org> amarok-1.3_beta3.ebuild:
+ fix build with postgres
*amarok-1.3_beta3 (01 Aug 2005)
diff --git a/media-sound/amarok/amarok-1.3_beta3.ebuild b/media-sound/amarok/amarok-1.3_beta3.ebuild
index 630aa8bcb724..3b8d9ff2e4e2 100644
--- a/media-sound/amarok/amarok-1.3_beta3.ebuild
+++ b/media-sound/amarok/amarok-1.3_beta3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.3_beta3.ebuild,v 1.1 2005/08/01 17:07:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.3_beta3.ebuild,v 1.2 2005/08/07 19:30:18 carlo Exp $
inherit kde eutils
@@ -63,6 +63,11 @@ pkg_setup() {
kde_pkg_setup
}
+src_unpack() {
+ kde_src_unpack
+ sed -i -e "s:postgresql/pgsql/libpq-fe.h:libpq-fe.h:" amarok/src/collectiondb.cpp
+}
+
src_compile() {
# amarok does not respect kde coding standards, and makes a lot of
# assuptions regarding its installation directory. For this reason,