summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-06-27 07:09:40 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-06-27 07:09:40 +0000
commit2af62f31dd9aec8d5143749850591184dcd74f13 (patch)
tree746ffd06ec331472b489d54d4678bf5ec9d5cc29 /media-sound
parentVersion bump. (diff)
downloadgentoo-2-2af62f31dd9aec8d5143749850591184dcd74f13.tar.gz
gentoo-2-2af62f31dd9aec8d5143749850591184dcd74f13.tar.bz2
gentoo-2-2af62f31dd9aec8d5143749850591184dcd74f13.zip
Revision bump: EAPI 5, epatch_user, add ~amd64 keyword, respect LDFLAGS, wrt bug #333731
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audicle/ChangeLog8
-rw-r--r--media-sound/audicle/audicle-1.0.0.7-r1.ebuild94
2 files changed, 101 insertions, 1 deletions
diff --git a/media-sound/audicle/ChangeLog b/media-sound/audicle/ChangeLog
index 58eaf4363cc3..3b12179dff10 100644
--- a/media-sound/audicle/ChangeLog
+++ b/media-sound/audicle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audicle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audicle/ChangeLog,v 1.10 2013/06/01 12:16:15 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audicle/ChangeLog,v 1.11 2013/06/27 07:09:40 pinkbyte Exp $
+
+*audicle-1.0.0.7-r1 (27 Jun 2013)
+
+ 27 Jun 2013; Sergey Popov <pinkbyte@gentoo.org> +audicle-1.0.0.7-r1.ebuild:
+ Revision bump: EAPI 5, epatch_user, add ~amd64 keyword, respect LDFLAGS, wrt
+ bug #333731
01 Jun 2013; Pacho Ramos <pacho@gentoo.org> -audicle-1.0.0.6-r1.ebuild,
metadata.xml:
diff --git a/media-sound/audicle/audicle-1.0.0.7-r1.ebuild b/media-sound/audicle/audicle-1.0.0.7-r1.ebuild
new file mode 100644
index 000000000000..d908fefdd7d3
--- /dev/null
+++ b/media-sound/audicle/audicle-1.0.0.7-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audicle/audicle-1.0.0.7-r1.ebuild,v 1.1 2013/06/27 07:09:40 pinkbyte Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A Context-sensitive, On-the-fly Audio Programming Environ/mentality"
+HOMEPAGE="http://audicle.cs.princeton.edu/"
+SRC_URI="http://audicle.cs.princeton.edu/release/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa jack oss truetype"
+
+RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ media-libs/libsndfile
+ media-libs/freeglut
+ virtual/opengl
+ virtual/glu
+ x11-libs/gtk+:2
+ truetype? ( media-libs/ftgl
+ media-fonts/corefonts )
+ app-admin/eselect-audicle"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( alsa jack oss )"
+
+DOCS=( AUTHORS PROGRAMMER README THANKS TODO VERSIONS )
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0.6-font.patch"
+ "${FILESDIR}/${P}-hid-smc.patch"
+ "${FILESDIR}/${P}-gcc43.patch"
+ "${FILESDIR}/${P}-const.patch"
+)
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+
+ sed -i \
+ -e 's@../ftgl_lib/FTGL/include@/usr/include/FTGL@' \
+ -e 's@../ftgl_lib/FTGL/mac/build@/usr/lib@' \
+ -e 's/gcc -o/$(CC) -o/' \
+ -e 's/-O3 -c/-c $(CFLAGS)/' \
+ -e 's/$(LIBS)/$(LDFLAGS) $(LIBS)/' \
+ src/makefile.{alsa,jack,oss} || die "sed failed"
+
+ epatch_user
+}
+
+compile_backend() {
+ local backend="$1"
+ local config
+ use truetype && config="USE_FREETYPE_LIBS=1"
+ einfo "Compiling against ${backend}"
+ cd "${S}/src"
+ emake -f "makefile.${backend}" CC="$(tc-getCC)" CXX="$(tc-getCXX)" LEX=flex \
+ YACC=bison ${config}
+ mv audicle{,-${backend}}
+ emake -f makefile clean
+}
+
+src_compile() {
+ # when compile with athlon or athlon-xp flags
+ # audicle crashes on removing a shred with a double free or corruption
+ # it happens in Chuck_VM_Stack::shutdown() on the line
+ # SAFE_DELETE_ARRAY( stack );
+ replace-cpu-flags athlon athlon-xp i686
+
+ use jack && compile_backend jack
+ use alsa && compile_backend alsa
+ use oss && compile_backend oss
+}
+
+src_install() {
+ use jack && dobin src/audicle-jack
+ use alsa && dobin src/audicle-alsa
+ use oss && dobin src/audicle-oss
+ dodoc ${DOCS[@]}
+}
+
+pkg_postinst() {
+ elog "Audicle now can use many audio engines, so you can specify audio engine"
+ elog "with audicle-{jack,alsa,oss}"
+ elog "Or you can use 'eselect audicle' to set the audio engine"
+
+ einfo "Calling eselect audicle update..."
+ eselect audicle update --if-unset
+}