summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 12:15:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 12:15:58 +0000
commit21b3d9bf38c0910efe70f508e9a033e4ff0586a7 (patch)
tree05db4f34ca2fbef193696b56fc1480d0aa3b3a1e /media-sound
parentAdd patch to fix build with --as-needed by Kevin Pyle, closes bug #247937. (diff)
downloadgentoo-2-21b3d9bf38c0910efe70f508e9a033e4ff0586a7.tar.gz
gentoo-2-21b3d9bf38c0910efe70f508e9a033e4ff0586a7.tar.bz2
gentoo-2-21b3d9bf38c0910efe70f508e9a033e4ff0586a7.zip
Add patch to build with --as-needed, closes bug #247834.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/dvda-author/ChangeLog8
-rw-r--r--media-sound/dvda-author/dvda-author-20050703.ebuild5
-rw-r--r--media-sound/dvda-author/files/dvda-author-20050703-asneeded.patch22
3 files changed, 31 insertions, 4 deletions
diff --git a/media-sound/dvda-author/ChangeLog b/media-sound/dvda-author/ChangeLog
index a62dc7f16110..03b5883328f6 100644
--- a/media-sound/dvda-author/ChangeLog
+++ b/media-sound/dvda-author/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/dvda-author
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/dvda-author/ChangeLog,v 1.1 2008/01/06 02:46:01 sbriesen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/dvda-author/ChangeLog,v 1.2 2009/06/02 12:15:58 flameeyes Exp $
+
+ 02 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ dvda-author-20050703.ebuild, +files/dvda-author-20050703-asneeded.patch:
+ Add patch to build with --as-needed, closes bug #247834.
*dvda-author-20050703 (06 Jan 2008)
diff --git a/media-sound/dvda-author/dvda-author-20050703.ebuild b/media-sound/dvda-author/dvda-author-20050703.ebuild
index 36df43c74728..215b2762508d 100644
--- a/media-sound/dvda-author/dvda-author-20050703.ebuild
+++ b/media-sound/dvda-author/dvda-author-20050703.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/dvda-author/dvda-author-20050703.ebuild,v 1.1 2008/01/06 02:46:01 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/dvda-author/dvda-author-20050703.ebuild,v 1.2 2009/06/02 12:15:58 flameeyes Exp $
inherit eutils toolchain-funcs
@@ -20,6 +20,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
epatch "${FILESDIR}/${P}-flac113.diff"
+ epatch "${FILESDIR}/${P}-asneeded.patch"
}
src_compile() {
diff --git a/media-sound/dvda-author/files/dvda-author-20050703-asneeded.patch b/media-sound/dvda-author/files/dvda-author-20050703-asneeded.patch
new file mode 100644
index 000000000000..c64fd32b8aaa
--- /dev/null
+++ b/media-sound/dvda-author/files/dvda-author-20050703-asneeded.patch
@@ -0,0 +1,22 @@
+Index: dvda-author-20050703/src/Makefile
+===================================================================
+--- dvda-author-20050703.orig/src/Makefile
++++ dvda-author-20050703/src/Makefile
+@@ -8,7 +8,7 @@ endif
+ CC=$(CROSS)gcc
+ AR=$(CROSS)ar
+ CFLAGS+=-Wall
+-LIBS=`pkg-config --libs flac`
++LDLIBS=`pkg-config --libs flac` -lm
+ TARGETS=dvda-author$(EXT)
+ OBJS=dvda-author.o audio.o ats.o atsi.o amg.o samg.o
+
+@@ -16,7 +16,7 @@ OBJS=dvda-author.o audio.o ats.o atsi.o
+ all: $(TARGETS)
+
+ dvda-author$(EXT): $(OBJS)
+- $(CC) $(LIBS) $(LDFLAGS) -o $@ $^
++ $(CC) $(LDFLAGS) -o $@ $^ $(LDLIBS)
+
+ dvda-author.o: dvda-author.c version.h audio.h ats.h atsi.h
+ ats.o: ats.c ats.h audio.h