summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-16 16:06:18 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-16 16:06:18 +0000
commit1f445d89d537daab471cb33443bd675622ecc35e (patch)
tree4fdf0dc00e9dcc73b1401b98d7d62ea655a928e4 /media-sound
parentVersion bump (bug #190702) (diff)
downloadgentoo-2-1f445d89d537daab471cb33443bd675622ecc35e.tar.gz
gentoo-2-1f445d89d537daab471cb33443bd675622ecc35e.tar.bz2
gentoo-2-1f445d89d537daab471cb33443bd675622ecc35e.zip
Version bump wrt #227459, thanks to timofonic AT gmail.com for reporting.
(Portage version: 2.1.5.5)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/streamripper/ChangeLog10
-rw-r--r--media-sound/streamripper/streamripper-1.63.5.ebuild30
2 files changed, 38 insertions, 2 deletions
diff --git a/media-sound/streamripper/ChangeLog b/media-sound/streamripper/ChangeLog
index d1d355f88b89..30fe633a0e4d 100644
--- a/media-sound/streamripper/ChangeLog
+++ b/media-sound/streamripper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/streamripper
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/ChangeLog,v 1.58 2007/08/15 02:52:26 jer Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/ChangeLog,v 1.59 2008/06/16 16:06:18 drac Exp $
+
+*streamripper-1.63.5 (16 Jun 2008)
+
+ 16 Jun 2008; Samuli Suominen <drac@gentoo.org>
+ +streamripper-1.63.5.ebuild:
+ Version bump wrt #227459, thanks to timofonic AT gmail.com for reporting.
15 Aug 2007; Jeroen Roovers <jer@gentoo.org> streamripper-1.62.2.ebuild:
Stable for HPPA (bug #188698).
diff --git a/media-sound/streamripper/streamripper-1.63.5.ebuild b/media-sound/streamripper/streamripper-1.63.5.ebuild
new file mode 100644
index 000000000000..23a55a20f2bf
--- /dev/null
+++ b/media-sound/streamripper/streamripper-1.63.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/streamripper-1.63.5.ebuild,v 1.1 2008/06/16 16:06:18 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
+HOMEPAGE="http://streamripper.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="vorbis"
+
+DEPEND="media-libs/libmad
+ media-libs/faad2
+ vorbis? ( media-libs/libvorbis )
+ >=dev-libs/tre-0.7.2"
+
+src_compile() {
+ econf --disable-dependency-tracking $(use_with vorbis ogg) \
+ --without-included-libmad --without-included-tre
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc CHANGES README THANKS
+}