summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2005-07-17 16:15:17 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2005-07-17 16:15:17 +0000
commit1e8c236b97de612887cc2e1f3ee00fee7fe9ef05 (patch)
treee4fc6f27cf40ecdee81e07436acb298efc5683c4 /media-sound
parentFix depend (diff)
downloadgentoo-2-1e8c236b97de612887cc2e1f3ee00fee7fe9ef05.tar.gz
gentoo-2-1e8c236b97de612887cc2e1f3ee00fee7fe9ef05.tar.bz2
gentoo-2-1e8c236b97de612887cc2e1f3ee00fee7fe9ef05.zip
Added conditional compilation if ALSA is not available. Closes bug #56032.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amsynth/ChangeLog8
-rw-r--r--media-sound/amsynth/Manifest17
-rw-r--r--media-sound/amsynth/amsynth-1.0.0-r1.ebuild58
-rw-r--r--media-sound/amsynth/files/amsynth-1.0.0-ALSAMidiDriver.patch12
-rw-r--r--media-sound/amsynth/files/digest-amsynth-1.0.0-r11
5 files changed, 83 insertions, 13 deletions
diff --git a/media-sound/amsynth/ChangeLog b/media-sound/amsynth/ChangeLog
index bc354714bbcf..7d9f659e5a0f 100644
--- a/media-sound/amsynth/ChangeLog
+++ b/media-sound/amsynth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amsynth
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/ChangeLog,v 1.17 2005/04/03 04:38:00 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/ChangeLog,v 1.18 2005/07/17 16:15:17 fvdpol Exp $
+
+*amsynth-1.0.0-r1 (17 Jul 2005)
+
+ 17 Jul 2005; Frank van de Pol <fvdpol@gentoo.org>
+ +files/amsynth-1.0.0-ALSAMidiDriver.patch, +amsynth-1.0.0-r1.ebuild:
+ Added conditional compilation if ALSA is not available. Closes bug #56032.
03 Apr 2005; Jan Brinkmann <luckyduck@gentoo.org> metadata.xml:
updated metadata.xml. torbenh is retired.
diff --git a/media-sound/amsynth/Manifest b/media-sound/amsynth/Manifest
index f54b4feb5d4b..22ffe838a089 100644
--- a/media-sound/amsynth/Manifest
+++ b/media-sound/amsynth/Manifest
@@ -1,15 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 9db626f03c9644e6b28a1f12107035bc ChangeLog 2231
+MD5 96be8bcfe2ce3559a7d85cae67ebe94d amsynth-1.0.0-r1.ebuild 1581
MD5 a33d519eeaf9796c2c62ddca0e73b75a amsynth-1.0.0.ebuild 1532
+MD5 9db626f03c9644e6b28a1f12107035bc ChangeLog 2231
+MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
+MD5 4fb13c78eeda484932c012ef45935845 files/amsynth-1.0.0-ALSAMidiDriver.patch 269
MD5 2f7dc56770343abd47f6fcc7bca6938e files/amsynth-pthread.patch 256
MD5 d7a734ec324ae5b115669d858666fb58 files/digest-amsynth-1.0.0 65
-MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFC0CDuI1lqEGTUzyQRAk+aAKDIl7R/3+z0GGJlao7UasIqDSj/IACePwzl
-5SA2/UT98XpT15sIhpVUVGo=
-=BCyV
------END PGP SIGNATURE-----
+MD5 d7a734ec324ae5b115669d858666fb58 files/digest-amsynth-1.0.0-r1 65
diff --git a/media-sound/amsynth/amsynth-1.0.0-r1.ebuild b/media-sound/amsynth/amsynth-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..e37659b9416f
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.0.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.0.0-r1.ebuild,v 1.1 2005/07/17 16:15:17 fvdpol Exp $
+
+IUSE="oss alsa jack"
+
+inherit eutils
+
+MY_P=${P/_rc/-rc}
+MY_P=${MY_P/amsynth/amSynth}
+
+DESCRIPTION="A retro analogue - modelling softsynth"
+HOMEPAGE="http://amsynthe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/amsynthe/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+# libsndfile support is actually optional, but IMHO this package should have it
+DEPEND="=dev-cpp/gtkmm-1.2* \
+ media-libs/libsndfile \
+ alsa? ( media-libs/alsa-lib \
+ media-sound/alsa-utils ) \
+ jack? ( media-sound/jack-audio-connection-kit )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i "/#include <alsa\\/asoundlib.h>/i\\#define ALSA_PCM_OLD_HW_PARAMS_API 1\\" src/drivers/ALSAmmapAudioDriver.h
+ sed -i "/#include <alsa\\/asoundlib.h>/i\\#define ALSA_PCM_OLD_HW_PARAMS_API 1\\" src/drivers/ALSAAudioDriver.h
+
+ epatch ${FILESDIR}/${PN}-pthread.patch
+ epatch ${FILESDIR}/${P}-ALSAMidiDriver.patch
+}
+
+src_compile() {
+ econf `use_with oss` `use_with alsa` `use_with jack` || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "amSynth has been installed normally."
+ einfo "If you would like to use the virtual"
+ einfo "keyboard option, then do"
+ einfo "emerge vkeybd"
+ einfo "and make sure you emerged amSynth"
+ einfo "with alsa support (USE=alsa)"
+ einfo
+}
diff --git a/media-sound/amsynth/files/amsynth-1.0.0-ALSAMidiDriver.patch b/media-sound/amsynth/files/amsynth-1.0.0-ALSAMidiDriver.patch
new file mode 100644
index 000000000000..dc0ba35078ae
--- /dev/null
+++ b/media-sound/amsynth/files/amsynth-1.0.0-ALSAMidiDriver.patch
@@ -0,0 +1,12 @@
+--- src/drivers/ALSAMidiDriver.cc.old 2003-12-14 17:04:50.000000000 +0100
++++ src/drivers/ALSAMidiDriver.cc 2004-02-28 13:29:20.000000000 +0100
+@@ -26,7 +26,9 @@
+
+ int ALSAMidiDriver::close()
+ {
++#ifdef with_alsa
+ snd_seq_close (seq_handle);
++#endif
+ return 0;
+ }
+
diff --git a/media-sound/amsynth/files/digest-amsynth-1.0.0-r1 b/media-sound/amsynth/files/digest-amsynth-1.0.0-r1
new file mode 100644
index 000000000000..93a4cb0d4430
--- /dev/null
+++ b/media-sound/amsynth/files/digest-amsynth-1.0.0-r1
@@ -0,0 +1 @@
+MD5 9d212099735098ca39aee3789a52de62 amSynth-1.0.0.tar.gz 448974