summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-08-09 09:32:02 +0000
committerSamuli Suominen <drac@gentoo.org>2007-08-09 09:32:02 +0000
commit904f59d02857268ca0ce7b50b7aab1dc26d9dfcc (patch)
tree3838434a43be3ff8f15c370f5810f45958cd5b7f /media-sound/yconsole
parentnew upstream release. fixes bug #186075. (diff)
downloadgentoo-2-904f59d02857268ca0ce7b50b7aab1dc26d9dfcc.tar.gz
gentoo-2-904f59d02857268ca0ce7b50b7aab1dc26d9dfcc.tar.bz2
gentoo-2-904f59d02857268ca0ce7b50b7aab1dc26d9dfcc.zip
Version bump, also fixing bug 188176.
(Portage version: 2.1.3.3)
Diffstat (limited to 'media-sound/yconsole')
-rw-r--r--media-sound/yconsole/ChangeLog9
-rw-r--r--media-sound/yconsole/files/digest-yconsole-3.4.33
-rw-r--r--media-sound/yconsole/files/yconsole-3.4.3-Makefile.patch82
-rw-r--r--media-sound/yconsole/files/yconsole-3.4.3-implicit-declaration.patch17
-rw-r--r--media-sound/yconsole/yconsole-3.4.3.ebuild38
5 files changed, 148 insertions, 1 deletions
diff --git a/media-sound/yconsole/ChangeLog b/media-sound/yconsole/ChangeLog
index 6862f8d3881f..89acdb18701a 100644
--- a/media-sound/yconsole/ChangeLog
+++ b/media-sound/yconsole/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/yconsole
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/yconsole/ChangeLog,v 1.9 2007/03/16 19:01:29 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/yconsole/ChangeLog,v 1.10 2007/08/09 09:32:02 drac Exp $
+
+*yconsole-3.4.3 (09 Aug 2007)
+
+ 09 Aug 2007; Samuli Suominen <drac@gentoo.org>
+ +files/yconsole-3.4.3-Makefile.patch,
+ +files/yconsole-3.4.3-implicit-declaration.patch, +yconsole-3.4.3.ebuild:
+ Version bump, also fixing bug 188176.
16 Mar 2007; Gustavo Zacarias <gustavoz@gentoo.org> yconsole-3.0.8.ebuild:
Stable on sparc
diff --git a/media-sound/yconsole/files/digest-yconsole-3.4.3 b/media-sound/yconsole/files/digest-yconsole-3.4.3
new file mode 100644
index 000000000000..d8b09e620dc3
--- /dev/null
+++ b/media-sound/yconsole/files/digest-yconsole-3.4.3
@@ -0,0 +1,3 @@
+MD5 5977475b351509109c4937964ca5e9de yconsole-3.4.3.tar.bz2 510444
+RMD160 5fb9f8eb229d50d7f54a1bf7bce09d1b59762356 yconsole-3.4.3.tar.bz2 510444
+SHA256 c5235c29344fecc8e244ccab26b7461699a6ae95286cf223ebcd75490bf1c99c yconsole-3.4.3.tar.bz2 510444
diff --git a/media-sound/yconsole/files/yconsole-3.4.3-Makefile.patch b/media-sound/yconsole/files/yconsole-3.4.3-Makefile.patch
new file mode 100644
index 000000000000..e592d85d67ce
--- /dev/null
+++ b/media-sound/yconsole/files/yconsole-3.4.3-Makefile.patch
@@ -0,0 +1,82 @@
+diff -ur yconsole-3.4.3.orig/yconsole/Makefile yconsole-3.4.3/yconsole/Makefile
+--- yconsole-3.4.3.orig/yconsole/Makefile 2006-08-23 12:03:22.000000000 +0300
++++ yconsole-3.4.3/yconsole/Makefile 2007-08-09 12:23:48.000000000 +0300
+@@ -2,23 +2,26 @@
+ #
+ PREFIX = /usr
+
+-CFLAGS = -Wall -O2 -g \
+- `imlib-config --cflags` -DHAVE_IMLIB \
+- `gtk-config --cflags`
++BUILDC = $(CFLAGS) -fno-strict-aliasing -Wall \
++ `imlib-config --cflags` -DHAVE_IMLIB \
++ `gtk-config --cflags`
+
+ INC_DIRS =
+
+ LIBS = -lY2 `imlib-config --libs` `gtk-config --libs`
+ LIB_DIRS =
+
+-CC = cc
+-CPP = c++
++CC = gcc
++CXX = g++
+
+ # Appended stuff starts here
+ #
+
+ # C++ flags:
+-CPPFLAGS = -D__cplusplus -Dc_plusplus
++BUILDCXX = $(CXXFLAGS) -fno-strict-aliasing \
++ -Wall -D__cplusplus -Dc_plusplus \
++ `imlib-config --cflags` -DHAVE_IMLIB \
++ `gtk-config --cflags`
+
+ # Source files list:
+ include Makefile.srclist
+@@ -35,10 +38,10 @@
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+ @echo "Compiling module $*.o"
+- @+$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ @+$(CC) -c $*.c $(INC_DIRS) $(BUILDC)
+ .cpp.o:
+ @echo "Compiling module $*.o"
+- @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ @+$(CXX) -c $*.cpp $(INC_DIRS) $(BUILDCXX)
+
+ # Programs
+ LS = ls
+@@ -50,7 +53,7 @@
+ EXPORT_COMPILETIMEINFO_H = echo -n -e "\
+ \#ifndef COMPILETIMEINFO_H\n\
+ \#define COMPILETIMEINFO_H\n\
+-\#define COMPILE_COMPILER\t\"`$(CPP) --version | tr '\n' ' '`\"\n\
++\#define COMPILE_COMPILER\t\"`$(CXX) --version | tr '\n' ' '`\"\n\
+ \#define COMPILE_USER\t\t\"$(USER)\"\n\
+ \#define COMPILE_LOCATION\t\"`uname -n`\"\n\
+ \#define COMPILE_DATE\t\t`date +\"%s\"`\n\
+@@ -65,7 +68,7 @@
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+ @echo -n "Linking modules..."
+- @$(CPP) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
++ @$(CXX) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
+ @echo -n " "
+ @-$(LS) $(LSFLAGS) $(BIN)
+
+diff -ur yconsole-3.4.3.orig/yconsole/Makefile.install.UNIX yconsole-3.4.3/yconsole/Makefile.install.UNIX
+--- yconsole-3.4.3.orig/yconsole/Makefile.install.UNIX 2006-08-23 12:03:22.000000000 +0300
++++ yconsole-3.4.3/yconsole/Makefile.install.UNIX 2007-08-09 12:23:03.000000000 +0300
+@@ -9,9 +9,9 @@
+ #
+
+ INSTALL = install
+-INSTBINFLAGS = -m 0755 -s
++INSTBINFLAGS = -m 0755
+ INSTUIDFLAGS = -m 4755
+-INSTLIBFLAGS = -m 0755 -s
++INSTLIBFLAGS = -m 0755
+ INSTINCFLAGS = -m 0644
+ INSTMANFLAGS = -m 0644
+ INSTCFGFLAGS = -m 0644
diff --git a/media-sound/yconsole/files/yconsole-3.4.3-implicit-declaration.patch b/media-sound/yconsole/files/yconsole-3.4.3-implicit-declaration.patch
new file mode 100644
index 000000000000..e15b9ac0a417
--- /dev/null
+++ b/media-sound/yconsole/files/yconsole-3.4.3-implicit-declaration.patch
@@ -0,0 +1,17 @@
+diff -ur yconsole-3.4.3.orig/yconsole/conbar.c yconsole-3.4.3/yconsole/conbar.c
+--- yconsole-3.4.3.orig/yconsole/conbar.c 2006-08-23 12:03:24.000000000 +0300
++++ yconsole-3.4.3/yconsole/conbar.c 2007-08-09 12:19:19.000000000 +0300
+@@ -1,4 +1,5 @@
+ #include <time.h>
++#include <string.h>
+
+ #include <Y2/Y.h>
+ #include <Y2/Ylib.h>
+diff -ur yconsole-3.4.3.orig/yconsole/dspview.c yconsole-3.4.3/yconsole/dspview.c
+--- yconsole-3.4.3.orig/yconsole/dspview.c 2006-08-23 12:03:23.000000000 +0300
++++ yconsole-3.4.3/yconsole/dspview.c 2007-08-09 12:19:37.000000000 +0300
+@@ -1,3 +1,4 @@
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include "guiutils.h"
+ #include "dspview.h"
diff --git a/media-sound/yconsole/yconsole-3.4.3.ebuild b/media-sound/yconsole/yconsole-3.4.3.ebuild
new file mode 100644
index 000000000000..c1c7318c7824
--- /dev/null
+++ b/media-sound/yconsole/yconsole-3.4.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/yconsole/yconsole-3.4.3.ebuild,v 1.1 2007/08/09 09:32:02 drac Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="User interface to control and monitor the Y server"
+HOMEPAGE="http://wolfpack.twu.net/YIFF"
+SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="=x11-libs/gtk+-1*
+ media-libs/imlib
+ media-libs/yiff"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ epatch "${FILESDIR}"/${P}-implicit-declaration.patch
+}
+
+src_compile() {
+ cd ${PN}
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dodoc AUTHORS README
+
+ cd ${PN}
+ emake PREFIX="${D}"/usr install || die "emake install failed."
+}