summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-03-11 12:13:27 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-03-11 12:13:27 +0000
commit4c28c5edc750c41c10b7d2385801685f7938defb (patch)
tree6fd5d7a1be857dba874d3d38d147609a09957ab6 /media-sound/xmp
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-4c28c5edc750c41c10b7d2385801685f7938defb.tar.gz
gentoo-2-4c28c5edc750c41c10b7d2385801685f7938defb.tar.bz2
gentoo-2-4c28c5edc750c41c10b7d2385801685f7938defb.zip
Fixes gcc 3.3 compilation errors.
Diffstat (limited to 'media-sound/xmp')
-rw-r--r--media-sound/xmp/ChangeLog7
-rw-r--r--media-sound/xmp/files/digest-xmp-2.0.5_pre3-r11
-rw-r--r--media-sound/xmp/files/xmp-2.0.5_pre3-gcc3.3.diff62
-rw-r--r--media-sound/xmp/xmp-2.0.5_pre3-r1.ebuild67
4 files changed, 136 insertions, 1 deletions
diff --git a/media-sound/xmp/ChangeLog b/media-sound/xmp/ChangeLog
index 948f94380a77..aa098ef0d38e 100644
--- a/media-sound/xmp/ChangeLog
+++ b/media-sound/xmp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/xmp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmp/ChangeLog,v 1.3 2003/02/12 07:35:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmp/ChangeLog,v 1.4 2004/03/11 12:13:27 karltk Exp $
+
+*xmp-2.0.5_pre3-r1 (11 Mar 2004)
+
+ 11 Mar 2004; Karl Trygve Kalleberg <karltk@gentoo.org> xmp-2.0.5_pre3-r1.ebuild:
+ Fixes gcc 3.3 compilation errors.
*xmp-2.0.5_pre3 (17 Jun 2002)
diff --git a/media-sound/xmp/files/digest-xmp-2.0.5_pre3-r1 b/media-sound/xmp/files/digest-xmp-2.0.5_pre3-r1
new file mode 100644
index 000000000000..3198e4ee7d7a
--- /dev/null
+++ b/media-sound/xmp/files/digest-xmp-2.0.5_pre3-r1
@@ -0,0 +1 @@
+MD5 749db9c8da956b403a959b4c8b909447 xmp-2.0.5pre3.tar.bz2 318375
diff --git a/media-sound/xmp/files/xmp-2.0.5_pre3-gcc3.3.diff b/media-sound/xmp/files/xmp-2.0.5_pre3-gcc3.3.diff
new file mode 100644
index 000000000000..1f8b9c6472e2
--- /dev/null
+++ b/media-sound/xmp/files/xmp-2.0.5_pre3-gcc3.3.diff
@@ -0,0 +1,62 @@
+diff -x '*.h' -x '*.status' -x '*.log' -x '*.rules' -x '*.cache' -urN xmp-2.0.5-pre3/src/loaders/it_load.c xmp-2.0.5-pre3.fixed/src/loaders/it_load.c
+--- xmp-2.0.5-pre3/src/loaders/it_load.c 2000-12-29 19:08:28.000000000 +0100
++++ xmp-2.0.5-pre3.fixed/src/loaders/it_load.c 2004-03-11 12:38:20.459060960 +0100
+@@ -327,14 +327,14 @@
+
+ #define BUILD_ENV(X) { \
+ fread (&env, 1, sizeof (env), f); \
+- xxih[i].##X##ei.flg = env.flg & IT_ENV_ON ? XXM_ENV_ON : 0; \
+- xxih[i].##X##ei.flg |= env.flg & IT_ENV_LOOP ? XXM_ENV_LOOP : 0; \
+- xxih[i].##X##ei.flg |= env.flg & IT_ENV_SLOOP ? XXM_ENV_SUS : 0; \
+- xxih[i].##X##ei.npt = env.num; \
+- xxih[i].##X##ei.sus = env.slb; \
+- xxih[i].##X##ei.sue = env.sle; \
+- xxih[i].##X##ei.lps = env.lpb; \
+- xxih[i].##X##ei.lpe = env.lpe; \
++ xxih[i].X##ei.flg = env.flg & IT_ENV_ON ? XXM_ENV_ON : 0; \
++ xxih[i].X##ei.flg |= env.flg & IT_ENV_LOOP ? XXM_ENV_LOOP : 0; \
++ xxih[i].X##ei.flg |= env.flg & IT_ENV_SLOOP ? XXM_ENV_SUS : 0; \
++ xxih[i].X##ei.npt = env.num; \
++ xxih[i].X##ei.sus = env.slb; \
++ xxih[i].X##ei.sue = env.sle; \
++ xxih[i].X##ei.lps = env.lpb; \
++ xxih[i].X##ei.lpe = env.lpe; \
+ if (env.num) xx##X##e[i] = calloc (4, env.num); \
+ for (j = 0; j < env.num; j++) { \
+ L_ENDIAN16 (env.node[j].x); \
+diff -x '*.h' -x '*.status' -x '*.log' -x '*.rules' -x '*.cache' -urN xmp-2.0.5-pre3/src/xmms/plugin.c xmp-2.0.5-pre3.fixed/src/xmms/plugin.c
+--- xmp-2.0.5-pre3/src/xmms/plugin.c 2001-02-04 01:47:38.000000000 +0100
++++ xmp-2.0.5-pre3.fixed/src/xmms/plugin.c 2004-03-11 12:48:04.595258760 +0100
+@@ -284,7 +284,7 @@
+ xmp_cfg.filter = TRUE;
+ xmp_cfg.pan_amplitude = 80;
+
+-#define CFGREADINT(x) xmms_cfg_read_int (cfg, "XMP", #x, &xmp_cfg.##x)
++#define CFGREADINT(x) xmms_cfg_read_int (cfg, "XMP", #x, &xmp_cfg.x)
+
+ filename = g_strconcat(g_get_home_dir(), "/.xmms/config", NULL);
+ if ((cfg = xmms_cfg_open_file(filename))) {
+@@ -668,12 +668,12 @@
+
+ /* Options */
+
+-#define OPTCHECK(w,l,o) { \
++#define OPTCHECK(w,l,ox) { \
+ w = gtk_check_button_new_with_label(l); \
+ gtk_object_set_data(GTK_OBJECT(xmp_conf_window), #w, w); \
+ gtk_widget_show(w); \
+ gtk_box_pack_start(GTK_BOX(vbox6), w, TRUE, TRUE, 0); \
+- if (xmp_cfg.##o == 1) \
++ if (xmp_cfg.ox == 1) \
+ gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(w), TRUE); \
+ }
+
+@@ -773,7 +773,7 @@
+ if (!cfg)
+ cfg = xmms_cfg_new();
+
+-#define CFGWRITEINT(x) xmms_cfg_write_int (cfg, "XMP", #x, xmp_cfg.##x)
++#define CFGWRITEINT(x) xmms_cfg_write_int (cfg, "XMP", #x, xmp_cfg.x)
+
+ CFGWRITEINT (mixing_freq);
+ CFGWRITEINT (force8bit);
diff --git a/media-sound/xmp/xmp-2.0.5_pre3-r1.ebuild b/media-sound/xmp/xmp-2.0.5_pre3-r1.ebuild
new file mode 100644
index 000000000000..a2b5f2d1d246
--- /dev/null
+++ b/media-sound/xmp/xmp-2.0.5_pre3-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmp/xmp-2.0.5_pre3-r1.ebuild,v 1.1 2004/03/11 12:13:27 karltk Exp $
+
+IUSE="xmms arts esd nas X oss alsa"
+
+S="${WORKDIR}/${PN}-2.0.5-pre3"
+DESCRIPTION="Extended Module Player"
+SRC_URI="mirror://sourceforge/xmp/${PN}-2.0.5pre3.tar.bz2"
+HOMEPAGE="http://xmp.sf.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="X? ( virtual/x11 )
+ esd? ( media-sound/esound )
+ nas? ( media-libs/nas )
+ alsa? ( =media-libs/alsa-lib-0.5* )
+ arts? ( kde-base/arts )
+ xmms? ( media-sound/xmms )"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gcc3.3.diff
+}
+
+src_compile() {
+ local myconf
+
+ use alsa \
+ && myconf="${myconf} --enable-alsa" \
+ || myconf="${myconf} --disable-alsa"
+
+ use arts \
+ && myconf="${myconf} --enable-arts" \
+ || myconf="${myconf} --disable-arts"
+
+ use esd \
+ && myconf="${myconf} --enable-esd" \
+ || myconf="${myconf} --disable-esd"
+
+ use nas \
+ && myconf="${myconf} --enable-nas" \
+ || myconf="${myconf} --disable-nas"
+
+ use oss \
+ && myconf="${myconf} --enable-oss" \
+ || myconf="${myconf} --disable-oss"
+
+ use xmms \
+ && myconf="${myconf} --enable-xmms" \
+ || myconf="${myconf} --disable-xmms"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --with-x"
+
+ econf ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ make DEST_DIR=${D} MAN_DIR=${D}/usr/share/man/man1 install || die
+ dodoc INSTALL README
+}