summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-05-07 12:56:37 +0000
committerMichał Górny <mgorny@gentoo.org>2013-05-07 12:56:37 +0000
commit0c70349ab99b4e970c6ba21dff27e11a48005d28 (patch)
tree076c2012d9f3a6eea368a78c14e1b89f0dcbf5e7 /media-sound/twolame
parentConvert to multilib wrt bug #468326. (diff)
downloadgentoo-2-0c70349ab99b4e970c6ba21dff27e11a48005d28.tar.gz
gentoo-2-0c70349ab99b4e970c6ba21dff27e11a48005d28.tar.bz2
gentoo-2-0c70349ab99b4e970c6ba21dff27e11a48005d28.zip
Convert to multilib wrt bug #468330.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'media-sound/twolame')
-rw-r--r--media-sound/twolame/ChangeLog10
-rw-r--r--media-sound/twolame/twolame-0.3.13-r1.ebuild43
2 files changed, 50 insertions, 3 deletions
diff --git a/media-sound/twolame/ChangeLog b/media-sound/twolame/ChangeLog
index 02277a68d506..415128334f10 100644
--- a/media-sound/twolame/ChangeLog
+++ b/media-sound/twolame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/twolame
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/twolame/ChangeLog,v 1.46 2012/06/03 13:55:13 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/twolame/ChangeLog,v 1.47 2013/05/07 12:56:37 mgorny Exp $
+
+*twolame-0.3.13-r1 (07 May 2013)
+
+ 07 May 2013; Michał Górny <mgorny@gentoo.org> +twolame-0.3.13-r1.ebuild:
+ Convert to multilib wrt bug #468330.
03 Jun 2012; Anthony G. Basile <blueness@gentoo.org> twolame-0.3.13.ebuild:
Keyword ~mips
@@ -153,4 +158,3 @@
08 Oct 2006; MATSUU Takuto <matsuu@gentoo.org> +twolame-0.3.8.ebuild:
Initial import, bug 120469.
-
diff --git a/media-sound/twolame/twolame-0.3.13-r1.ebuild b/media-sound/twolame/twolame-0.3.13-r1.ebuild
new file mode 100644
index 000000000000..431b72c8cccc
--- /dev/null
+++ b/media-sound/twolame/twolame-0.3.13-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/twolame/twolame-0.3.13-r1.ebuild,v 1.1 2013/05/07 12:56:37 mgorny Exp $
+
+EAPI=5
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+inherit autotools-multilib
+
+DESCRIPTION="An optimised MPEG Audio Layer 2 (MP2) encoder"
+HOMEPAGE="http://www.twolame.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/libsndfile-1[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20121202 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-O3::' configure || die
+
+ if [[ ${CHOST} == *solaris* ]]; then
+ # libsndfile doesn't like -std=c99 on Solaris
+ sed -i -e '/CFLAGS/s:-std=c99::' configure || die
+ # configure isn't really bourne shell (comment 0) or dash (comment 6)
+ # compatible, bug #388885
+ export CONFIG_SHELL=${BASH}
+ fi
+
+ autotools-multilib_src_prepare
+}
+
+src_install() {
+ autotools-multilib_src_install \
+ pkgdocdir="${EPREFIX}/usr/share/doc/${PF}"
+}