summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-06-11 20:32:00 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-06-11 20:32:00 +0000
commite82325ec299d86e78fad46a9260caf7c9e722380 (patch)
treec58ba9a488518c148ec745a7f1de8fd9899ada93 /media-sound/streamripper
parentcommitting new version (diff)
downloadgentoo-2-e82325ec299d86e78fad46a9260caf7c9e722380.tar.gz
gentoo-2-e82325ec299d86e78fad46a9260caf7c9e722380.tar.bz2
gentoo-2-e82325ec299d86e78fad46a9260caf7c9e722380.zip
Version bump, bug #180969
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-sound/streamripper')
-rw-r--r--media-sound/streamripper/ChangeLog8
-rw-r--r--media-sound/streamripper/files/digest-streamripper-1.62.03
-rw-r--r--media-sound/streamripper/streamripper-1.61.26.ebuild4
-rw-r--r--media-sound/streamripper/streamripper-1.62.0.ebuild31
4 files changed, 43 insertions, 3 deletions
diff --git a/media-sound/streamripper/ChangeLog b/media-sound/streamripper/ChangeLog
index 2402b4784996..d36d99c32c89 100644
--- a/media-sound/streamripper/ChangeLog
+++ b/media-sound/streamripper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/streamripper
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/ChangeLog,v 1.44 2007/04/16 07:41:55 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/ChangeLog,v 1.45 2007/06/11 20:32:00 aballier Exp $
+
+*streamripper-1.62.0 (11 Jun 2007)
+
+ 11 Jun 2007; Alexis Ballier <aballier@gentoo.org>
+ +streamripper-1.62.0.ebuild:
+ Version bump, bug #180969
16 Apr 2007; Markus Rothe <corsair@gentoo.org>
streamripper-1.61.27.ebuild:
diff --git a/media-sound/streamripper/files/digest-streamripper-1.62.0 b/media-sound/streamripper/files/digest-streamripper-1.62.0
new file mode 100644
index 000000000000..f120c90290e5
--- /dev/null
+++ b/media-sound/streamripper/files/digest-streamripper-1.62.0
@@ -0,0 +1,3 @@
+MD5 1a8353af3c36d56f2d8ee8552f632071 streamripper-1.62.0.tar.gz 1237935
+RMD160 43294ffd84c88800e59f43070ae727b56ae18a3c streamripper-1.62.0.tar.gz 1237935
+SHA256 19db4c9b90e85419eaae4b685a1c27ee9de1eafc8e8dcf2a217cb2943bcbb3db streamripper-1.62.0.tar.gz 1237935
diff --git a/media-sound/streamripper/streamripper-1.61.26.ebuild b/media-sound/streamripper/streamripper-1.61.26.ebuild
index fede75f3bafd..47d0b3be32d3 100644
--- a/media-sound/streamripper/streamripper-1.61.26.ebuild
+++ b/media-sound/streamripper/streamripper-1.61.26.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/streamripper-1.61.26.ebuild,v 1.8 2007/02/28 22:17:11 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/streamripper-1.61.26.ebuild,v 1.9 2007/06/11 20:32:00 aballier Exp $
inherit eutils
diff --git a/media-sound/streamripper/streamripper-1.62.0.ebuild b/media-sound/streamripper/streamripper-1.62.0.ebuild
new file mode 100644
index 000000000000..1ae19f9699ec
--- /dev/null
+++ b/media-sound/streamripper/streamripper-1.62.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/streamripper-1.62.0.ebuild,v 1.1 2007/06/11 20:32:00 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
+HOMEPAGE="http://streamripper.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="vorbis"
+
+DEPEND="media-libs/libmad
+ vorbis? ( media-libs/libogg
+ media-libs/libvorbis )
+ >=dev-libs/tre-0.7.2"
+
+src_compile() {
+ econf $(use_with vorbis ogg) \
+ --without-included-libmad \
+ --without-included-tre || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CHANGES README THANKS readme_xfade.txt
+}