summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-07-28 02:07:08 +0000
committerMichael Weber <xmw@gentoo.org>2013-07-28 02:07:08 +0000
commitc34365ec8c3b44409840280481d6524a73a07b79 (patch)
tree17d0710ade1d61fe3326a942563035d21fe6b8df /media-sound/spek/spek-0.8.3.ebuild
parentVersion bump. (diff)
downloadgentoo-2-c34365ec8c3b44409840280481d6524a73a07b79.tar.gz
gentoo-2-c34365ec8c3b44409840280481d6524a73a07b79.tar.bz2
gentoo-2-c34365ec8c3b44409840280481d6524a73a07b79.zip
Version bump (requested by eternalfuzzy1@gmail.com, bug 478306), inherit wxwidgets eclass (reported by boxcars@gmx.net, bug 475372), drop old versions.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'media-sound/spek/spek-0.8.3.ebuild')
-rw-r--r--media-sound/spek/spek-0.8.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/spek/spek-0.8.3.ebuild b/media-sound/spek/spek-0.8.3.ebuild
new file mode 100644
index 000000000000..540e2cc7269e
--- /dev/null
+++ b/media-sound/spek/spek-0.8.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/spek/spek-0.8.3.ebuild,v 1.1 2013/07/28 02:07:08 xmw Exp $
+
+EAPI=5
+WX_GTK_VER="2.8"
+
+inherit autotools eutils wxwidgets
+
+DESCRIPTION="Analyse your audio files by showing their spectrogram"
+HOMEPAGE="http://www.spek-project.org/"
+SRC_URI="https://github.com/alexkay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="virtual/ffmpeg
+ x11-libs/wxGTK:2.8[X]"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.1-disable-updates.patch
+ eautoreconf
+}