summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-11-22 21:11:36 +0000
committerPeter Volkov <pva@gentoo.org>2008-11-22 21:11:36 +0000
commit8f5ad2f89af8908fa85871668d411726b99c5b1b (patch)
treec1800574530e869581dc1703ba95b839d8d76f69 /media-sound/sox
parentold (diff)
downloadgentoo-2-8f5ad2f89af8908fa85871668d411726b99c5b1b.tar.gz
gentoo-2-8f5ad2f89af8908fa85871668d411726b99c5b1b.tar.bz2
gentoo-2-8f5ad2f89af8908fa85871668d411726b99c5b1b.zip
Don't try to get distro name from /etc/issue, bug #246299 thank Albert W. Hopkins for report.
(Portage version: 2.2_rc15/cvs/Linux 2.6.26-openvz.git-35f41f1 i686)
Diffstat (limited to 'media-sound/sox')
-rw-r--r--media-sound/sox/ChangeLog7
-rw-r--r--media-sound/sox/files/sox-14.2.0-distro.patch36
-rw-r--r--media-sound/sox/sox-14.2.0.ebuild12
3 files changed, 52 insertions, 3 deletions
diff --git a/media-sound/sox/ChangeLog b/media-sound/sox/ChangeLog
index 8d1e58c2edc6..0091508409b2 100644
--- a/media-sound/sox/ChangeLog
+++ b/media-sound/sox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/sox
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.97 2008/11/14 09:35:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.98 2008/11/22 21:11:36 pva Exp $
+
+ 22 Nov 2008; Peter Volkov <pva@gentoo.org> +files/sox-14.2.0-distro.patch,
+ sox-14.2.0.ebuild:
+ Don't try to get distro name from /etc/issue, bug #246299 thank Albert W.
+ Hopkins for report.
14 Nov 2008; Alexis Ballier <aballier@gentoo.org>
+files/sox-14.1.0-runsox.patch, sox-14.1.0.ebuild:
diff --git a/media-sound/sox/files/sox-14.2.0-distro.patch b/media-sound/sox/files/sox-14.2.0-distro.patch
new file mode 100644
index 000000000000..2545934d3b9c
--- /dev/null
+++ b/media-sound/sox/files/sox-14.2.0-distro.patch
@@ -0,0 +1,36 @@
+=== modified file 'configure.ac'
+--- configure.ac 2008-11-11 12:27:08 +0000
++++ configure.ac 2008-11-11 12:28:01 +0000
+@@ -117,15 +117,23 @@
+ AC_SUBST(APP_LDFLAGS)
+ AC_SUBST(WARN_CFLAGS)
+
+-dnl Get distro name from /etc/issue
+-if test -r /etc/issue; then
+- AC_MSG_CHECKING([distro name])
+- DISTRO=`sed -e "s/.[0-9][0-9;]*[mJH]//g" < /etc/issue|tr "\n" " " | sed -e "s/(\\\\?\\\\\\\\.*//" -e "s/ */ /g" -e "s/^ //" -e "s/ $//"`
+- AC_MSG_RESULT("$DISTRO")
+- AC_SUBST(DISTRO)
+- AC_DEFINE(HAVE_DISTRO, 1, [1 if DISTRO is defined])
+- have_distro=yes
++AC_ARG_WITH(distro,
++ AC_HELP_STRING([--with-distro=distro],
++ [Provide distribution name, by default will try to grep /etc/issue]))
++
++if test "$with_distro" != "no"; then
++ DISTRO=$with_distro
++else
++ dnl Get distro name from /etc/issue
++ if test -r /etc/issue; then
++ AC_MSG_CHECKING([distro name])
++ DISTRO=`sed -e "s/.[0-9][0-9;]*[mJH]//g" < /etc/issue|tr "\n" " " | sed -e "s/(\\\\?\\\\\\\\.*//" -e "s/ */ /g" -e "s/^ //" -e "s/ $//"`
++ AC_MSG_RESULT("$DISTRO")
++ fi
+ fi
++AC_SUBST(DISTRO)
++AC_DEFINE(HAVE_DISTRO, 1, [1 if DISTRO is defined])
++have_distro=yes
+ AM_CONDITIONAL(HAVE_DISTRO, test x$have_distro = xyes)
+
+ dnl Check for system dependent features.
+
diff --git a/media-sound/sox/sox-14.2.0.ebuild b/media-sound/sox/sox-14.2.0.ebuild
index 0941f92a6d59..13f8b203747e 100644
--- a/media-sound/sox/sox-14.2.0.ebuild
+++ b/media-sound/sox/sox-14.2.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.2.0.ebuild,v 1.1 2008/11/10 12:11:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.2.0.ebuild,v 1.2 2008/11/22 21:11:36 pva Exp $
-inherit flag-o-matic
+inherit flag-o-matic autotools
DESCRIPTION="The swiss army knife of sound processing programs"
HOMEPAGE="http://sox.sourceforge.net"
@@ -30,6 +30,13 @@ DEPEND="alsa? ( media-libs/alsa-lib )
png? ( media-libs/libpng )
wavpack? ( media-sound/wavpack )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-distro.patch"
+ eautoreconf
+}
+
src_compile () {
# Fixes wav segfaults. See Bug #35745.
append-flags -fsigned-char
@@ -51,6 +58,7 @@ src_compile () {
$(use_with amrnb amr-nb) \
$(use_with png) \
$(use_with wavpack) \
+ --with-distro="Gentoo" \
--enable-fast-ulaw \
--enable-fast-alaw \
|| die "configure failed"