summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-12 18:53:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-12 18:53:36 +0000
commit0c15f0a6ab0846e60dc49adfb3d2db2acf44b3b6 (patch)
tree883c75e599fcc9df016ddea436c0130b06b15d7d /media-sound/rezound
parentVersion bump; bug #276498 (diff)
downloadgentoo-2-0c15f0a6ab0846e60dc49adfb3d2db2acf44b3b6.tar.gz
gentoo-2-0c15f0a6ab0846e60dc49adfb3d2db2acf44b3b6.tar.bz2
gentoo-2-0c15f0a6ab0846e60dc49adfb3d2db2acf44b3b6.zip
Replace -O[3-9] with -O2 wrt #275437. Include cstdio for printf function, thanks to Tommy[D].
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/rezound')
-rw-r--r--media-sound/rezound/ChangeLog7
-rw-r--r--media-sound/rezound/files/rezound-0.12.3_beta-gcc44.patch12
-rw-r--r--media-sound/rezound/rezound-0.12.3_beta-r2.ebuild23
3 files changed, 28 insertions, 14 deletions
diff --git a/media-sound/rezound/ChangeLog b/media-sound/rezound/ChangeLog
index 32036f08ad3a..4b19b1650fcb 100644
--- a/media-sound/rezound/ChangeLog
+++ b/media-sound/rezound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/rezound
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/ChangeLog,v 1.57 2009/06/07 21:21:56 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/ChangeLog,v 1.58 2009/07/12 18:53:36 ssuominen Exp $
+
+ 12 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ rezound-0.12.3_beta-r2.ebuild, +files/rezound-0.12.3_beta-gcc44.patch:
+ Replace -O[3-9] with -O2 wrt #275437. Include cstdio for printf function,
+ thanks to Tommy[D].
07 Jun 2009; Markus Meier <maekke@gentoo.org>
rezound-0.12.3_beta-r2.ebuild:
diff --git a/media-sound/rezound/files/rezound-0.12.3_beta-gcc44.patch b/media-sound/rezound/files/rezound-0.12.3_beta-gcc44.patch
new file mode 100644
index 000000000000..1aef0943b667
--- /dev/null
+++ b/media-sound/rezound/files/rezound-0.12.3_beta-gcc44.patch
@@ -0,0 +1,12 @@
+diff -ur rezound-0.12.3beta.orig/src/backend/Remaster/CAdaptiveNormalizeAction.cpp rezound-0.12.3beta/src/backend/Remaster/CAdaptiveNormalizeAction.cpp
+--- rezound-0.12.3beta.orig/src/backend/Remaster/CAdaptiveNormalizeAction.cpp 2005-02-15 04:54:44.000000000 +0200
++++ rezound-0.12.3beta/src/backend/Remaster/CAdaptiveNormalizeAction.cpp 2009-07-12 21:51:43.000000000 +0300
+@@ -18,6 +18,8 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
++#include <cstdio>
++
+ #include "CAdaptiveNormalizeAction.h"
+
+ #include <utility>
diff --git a/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild b/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild
index 521fed20c97e..5a4f3b4e3658 100644
--- a/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild
+++ b/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild,v 1.2 2009/06/07 21:21:56 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild,v 1.3 2009/07/12 18:53:36 ssuominen Exp $
EAPI=2
+MY_P=${P/_/}
+PATCHLEVEL=5
-inherit eutils autotools
+inherit autotools eutils flag-o-matic
-MY_P="${P/_/}"
-S="${WORKDIR}/${MY_P}"
-
-PATCHLEVEL="5"
DESCRIPTION="Sound editor and recorder"
HOMEPAGE="http://rezound.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
@@ -31,21 +29,17 @@ RDEPEND="=sci-libs/fftw-2*
portaudio? ( >=media-libs/portaudio-18 )
soundtouch? ( >=media-libs/libsoundtouch-1.2.1 )
vorbis? ( media-libs/libvorbis media-libs/libogg )"
-
-# optional packages (don't need to be installed during emerge):
-#
-# >=media-sound/lame-3.92
-# app-cdr/cdrdao
-
DEPEND="${RDEPEND}
sys-devel/bison
dev-util/pkgconfig
sys-devel/flex
dev-util/reswrap"
+S=${WORKDIR}/${MY_P}
+
src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
-
+ epatch "${FILESDIR}"/${P}-gcc44.patch
AT_M4DIR="config/m4" eautoreconf
}
@@ -59,6 +53,9 @@ src_configure() {
local sampletype="--enable-internal-sample-type=float"
use 16bittmp && sampletype="--enable-internal-sample-type=int16"
+ # -O3 isn't safe wrt #275437
+ replace-flags -O[3-9] -O2
+
econf \
$(use_enable alsa) \
$(use_enable jack) \