summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-06-15 06:04:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-06-15 06:04:20 +0000
commit712caece445594d5d40b46c076f96694811b9c24 (patch)
tree75a6c54a8ca26b04f39247240cf0b07009603751 /media-sound/quodlibet
parentUpdating ebuild (missing IUSE) (diff)
downloadgentoo-2-712caece445594d5d40b46c076f96694811b9c24.tar.gz
gentoo-2-712caece445594d5d40b46c076f96694811b9c24.tar.bz2
gentoo-2-712caece445594d5d40b46c076f96694811b9c24.zip
cleanup old versions
(Portage version: 2.1.3_rc1)
Diffstat (limited to 'media-sound/quodlibet')
-rw-r--r--media-sound/quodlibet/ChangeLog7
-rw-r--r--media-sound/quodlibet/files/digest-quodlibet-0.23.1-r13
-rw-r--r--media-sound/quodlibet/files/digest-quodlibet-0.243
-rw-r--r--media-sound/quodlibet/files/quodlibet-0.23.1-python25.patch307
-rw-r--r--media-sound/quodlibet/quodlibet-0.23.1-r1.ebuild124
-rw-r--r--media-sound/quodlibet/quodlibet-0.24.ebuild124
6 files changed, 6 insertions, 562 deletions
diff --git a/media-sound/quodlibet/ChangeLog b/media-sound/quodlibet/ChangeLog
index ef255af00af8..46a5ca45b6d8 100644
--- a/media-sound/quodlibet/ChangeLog
+++ b/media-sound/quodlibet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/quodlibet
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/quodlibet/ChangeLog,v 1.50 2007/05/13 20:23:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/quodlibet/ChangeLog,v 1.51 2007/06/15 06:04:20 aballier Exp $
+
+ 15 Jun 2007; Alexis Ballier <aballier@gentoo.org>
+ -files/quodlibet-0.23.1-python25.patch, -quodlibet-0.23.1-r1.ebuild,
+ -quodlibet-0.24.ebuild:
+ cleanup old versions
*quodlibet-1.0 (13 May 2007)
diff --git a/media-sound/quodlibet/files/digest-quodlibet-0.23.1-r1 b/media-sound/quodlibet/files/digest-quodlibet-0.23.1-r1
deleted file mode 100644
index 29562ab0a151..000000000000
--- a/media-sound/quodlibet/files/digest-quodlibet-0.23.1-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 8b9d4f4dc0850b48cfe9b4b390722ef4 quodlibet-0.23.1.tar.gz 542885
-RMD160 043ab4131a527932a57899875a343f468b7afd99 quodlibet-0.23.1.tar.gz 542885
-SHA256 639d6364798802ab50580e652abe53c72470ab04e7ecd06e66bee0542d2d01e8 quodlibet-0.23.1.tar.gz 542885
diff --git a/media-sound/quodlibet/files/digest-quodlibet-0.24 b/media-sound/quodlibet/files/digest-quodlibet-0.24
deleted file mode 100644
index c3ff4b385dc2..000000000000
--- a/media-sound/quodlibet/files/digest-quodlibet-0.24
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 39718994ee234d0c442d9db330d7445a quodlibet-0.24.tar.gz 615554
-RMD160 b4fec7495b081abc92faf74a746c4f43c66f1ead quodlibet-0.24.tar.gz 615554
-SHA256 758d726fa57b177d574dc01141609df3415287611db073415230f1ac4520fd5e quodlibet-0.24.tar.gz 615554
diff --git a/media-sound/quodlibet/files/quodlibet-0.23.1-python25.patch b/media-sound/quodlibet/files/quodlibet-0.23.1-python25.patch
deleted file mode 100644
index 3a6764e80a3d..000000000000
--- a/media-sound/quodlibet/files/quodlibet-0.23.1-python25.patch
+++ /dev/null
@@ -1,307 +0,0 @@
-Index: parse/_pattern.py
-===================================================================
---- parse/_pattern.py (revision 3816)
-+++ parse/_pattern.py (revision 3817)
-@@ -15,7 +15,7 @@
- # every time. The Song proxy might also get in the way.
-
- import os
--import sre
-+import re
-
- import util
-
-@@ -43,16 +43,16 @@
- str(self._reverse[self.type]) +
- "), lexeme=" + repr(self.lexeme) + ">")
-
--class PatternLexer(sre.Scanner):
-+class PatternLexer(re.Scanner):
- def __init__(self, s):
- self.string = s.strip()
-- sre.Scanner.__init__(self,
-+ re.Scanner.__init__(self,
- [(r"([^<>|\\]|\\.)+", self.text),
- (r"[<>|]", self.table),
- ])
-
- def text(self, scanner, string):
-- return PatternLexeme(TEXT, sre.sub(r"\\(.)", r"\1", string))
-+ return PatternLexeme(TEXT, re.sub(r"\\(.)", r"\1", string))
- def table(self, scanner, string):
- return PatternLexeme(
- {"|": COND, "<": OPEN, ">": CLOSE}[string], string)
-Index: parse/_query.py
-===================================================================
---- parse/_query.py (revision 3816)
-+++ parse/_query.py (revision 3817)
-@@ -10,7 +10,7 @@
- # but it could use some cleaning up. It builds the requisite match.*
- # objects as it goes, which is where the interesting stuff will happen.
-
--import sre
-+import re
-
- import parse._match as match
-
-@@ -22,10 +22,10 @@
- class ParseError(error): pass
- class LexerError(error): pass
-
--class QueryLexer(sre.Scanner):
-+class QueryLexer(re.Scanner):
- def __init__(self, s):
- self.string = s.strip()
-- sre.Scanner.__init__(self,
-+ re.Scanner.__init__(self,
- [(r"/([^/\\]|\\.)*/", self.regexp),
- (r'"([^"\\]|\\.)*"', self.str_to_re),
- (r"'([^'\\]|\\.)*'", self.str_to_re),
-@@ -42,7 +42,7 @@
- if isinstance(string, unicode): string = string.encode('utf-8')
- string = string[1:-1].decode('string_escape')
- string = string.decode('utf-8')
-- return QueryLexeme(RE, "^%s$" % sre.escape(string))
-+ return QueryLexeme(RE, "^%s$" % re.escape(string))
-
- def tag(self, scanner, string):
- return QueryLexeme(TAG, string.strip())
-@@ -190,24 +190,24 @@
- def MatchTag(self):
- tag = self.lookahead.lexeme
- self.match(TAG)
-- try: return sre.compile(sre.escape(tag), sre.IGNORECASE | sre.UNICODE)
-- except sre.error:
-+ try: return re.compile(re.escape(tag), re.IGNORECASE | re.UNICODE)
-+ except re.error:
- raise ParseError("The regular expression was invalid")
-
- def Regexp(self):
-- re = self.lookahead.lexeme
-+ regex = self.lookahead.lexeme
- self.match(RE)
-- mods = sre.MULTILINE | sre.UNICODE | sre.IGNORECASE
-+ mods = re.MULTILINE | re.UNICODE | re.IGNORECASE
- if self.lookahead.type == TAG:
- s = self.lookahead.lexeme.lower()
-- if "c" in s: mods &= ~sre.IGNORECASE
-- if "i" in s: mods |= sre.IGNORECASE
-- if "s" in s: mods |= sre.DOTALL
-- if "l" in s: mods = (mods & ~sre.UNICODE) | sre.LOCALE
-+ if "c" in s: mods &= ~re.IGNORECASE
-+ if "i" in s: mods |= re.IGNORECASE
-+ if "s" in s: mods |= re.DOTALL
-+ if "l" in s: mods = (mods & ~re.UNICODE) | re.LOCALE
- self.match(TAG)
-- try: return sre.compile(re, mods)
-- except sre.error:
-- raise ParseError("The regular expression /%s/ is invalid." % re)
-+ try: return re.compile(regex, mods)
-+ except re.error:
-+ raise ParseError("The regular expression /%s/ is invalid." % regex)
-
- def match(self, *tokens):
- if tokens == [EOF] and self.lookahead.type == EOF:
-@@ -227,7 +227,7 @@
- if not isinstance(string, unicode): string = string.decode('utf-8')
- if string == "": return match.Inter([])
- elif not set("#=").intersection(string):
-- parts = ["%s = /%s/" % (", ".join(star), sre.escape(p))
-+ parts = ["%s = /%s/" % (", ".join(star), re.escape(p))
- for p in string.split()]
- string = "&(" + ",".join(parts) + ")"
- return QueryParser(QueryLexer(string)).StartQuery()
-Index: qltk/remote.py
-===================================================================
---- qltk/remote.py (revision 3816)
-+++ qltk/remote.py (revision 3817)
-@@ -9,7 +9,7 @@
-
- import os
- import random
--import sre
-+import re
-
- import gobject
- import gtk
-@@ -162,7 +162,7 @@
- for added in library.scan([filename]): pass
- if window.browser.can_filter(None):
- window.browser.set_text(
-- "filename = /^%s/c" % sre.escape(filename))
-+ "filename = /^%s/c" % re.escape(filename))
- window.browser.activate()
- else:
- basepath = filename + "/"
-Index: qltk/cbes.py
-===================================================================
---- qltk/cbes.py (revision 3816)
-+++ qltk/cbes.py (revision 3817)
-@@ -241,8 +241,8 @@
- if not os.path.isdir(os.path.dirname(filename)):
- os.makedirs(os.path.dirname(filename))
-
-- saved = file(filename + ".saved", "wU")
-- memory = file(filename, "wU")
-+ saved = file(filename + ".saved", "w")
-+ memory = file(filename, "w")
- target = saved
- for row in self.get_model():
- if row[0] is None: target = memory
-Index: qltk/renamefiles.py
-===================================================================
---- qltk/renamefiles.py (revision 3816)
-+++ qltk/renamefiles.py (revision 3817)
-@@ -8,7 +8,7 @@
- # $Id: quodlibet-0.23.1-python25.patch,v 1.1 2006/09/25 02:05:35 tcort Exp $
-
- import os
--import sre
-+import re
- import unicodedata
-
- import gtk
-@@ -38,7 +38,7 @@
- new = u"".join(map(lambda s: (s in self.BAD and "_") or s, filename))
- parts = new.split(os.sep)
- def fix_end(string):
-- return sre.sub(r'[\. ]$', "_", string)
-+ return re.sub(r'[\. ]$', "_", string)
- return unicode(os.sep).join(map(fix_end, parts))
-
- class StripDiacriticals(FilterCheckButton):
-Index: qltk/tagsfrompath.py
-===================================================================
---- qltk/tagsfrompath.py (revision 3816)
-+++ qltk/tagsfrompath.py (revision 3817)
-@@ -8,7 +8,7 @@
- # $Id: quodlibet-0.23.1-python25.patch,v 1.1 2006/09/25 02:05:35 tcort Exp $
-
- import os
--import sre
-+import re
-
- import gtk
-
-@@ -29,7 +29,7 @@
- self.slashes = len(pattern) - len(pattern.replace(os.path.sep,'')) + 1
- self.pattern = None
- # patterns look like <tagname> non regexy stuff <tagname> ...
-- pieces = sre.split(r'(<[A-Za-z0-9_]+>)', pattern)
-+ pieces = re.split(r'(<[A-Za-z0-9_]+>)', pattern)
- override = { '<tracknumber>': r'\d\d?', '<discnumber>': r'\d\d??' }
- for i, piece in enumerate(pieces):
- if not piece: continue
-@@ -38,7 +38,7 @@
- pieces[i] = '(?P%s%s)' % (piece, override.get(piece, '.+?'))
- self.headers.append(piece[1:-1].encode("ascii", "replace"))
- else:
-- pieces[i] = sre.escape(piece)
-+ pieces[i] = re.escape(piece)
-
- # some slight magic to anchor searches "nicely"
- # nicely means if it starts with a <tag>, anchor with a /
-@@ -52,7 +52,7 @@
- and not pattern.endswith('<discnumber>'):
- pieces.append(r'(?:\.\w+)$')
-
-- self.pattern = sre.compile(''.join(pieces))
-+ self.pattern = re.compile(''.join(pieces))
-
- def match(self, song):
- if isinstance(song, dict):
-@@ -125,7 +125,7 @@
- if songs: pattern_text = self.combo.child.get_text().decode("utf-8")
- else: pattern_text = ""
- try: pattern = TagsFromPattern(pattern_text)
-- except sre.error:
-+ except re.error:
- qltk.ErrorMessage(
- self, _("Invalid pattern"),
- _("The pattern\n\t<b>%s</b>\nis invalid. "
-Index: util/__init__.py
-===================================================================
---- util/__init__.py (revision 3816)
-+++ util/__init__.py (revision 3817)
-@@ -9,7 +9,7 @@
- import gettext
- import locale
- import os
--import sre
-+import re
- import sys
-
- from const import FSCODING as fscoding, ENCODING
-@@ -26,7 +26,13 @@
- t.install()
-
- def python_init():
-- sre.escape = re_esc
-+ re.escape = re_esc
-+ # Python 2.4 has sre.Scanner but not re.Scanner. Python 2.5 has
-+ # deprecated sre and moved Scanner to re.
-+ try: re.Scanner
-+ except AttributeError:
-+ from sre import Scanner
-+ re.Scanner = Scanner
-
- def re_esc(str, BAD="/.^$*+?{,\\[]|()<>#=!:"):
- needs_escape = lambda c: (c in BAD and "\\" + c) or c
-@@ -237,7 +243,7 @@
- """Unescape a string in a manner suitable for XML/Pango."""
- return str.replace("&lt;", "<").replace("&gt;", ">").replace("&amp;", "&")
-
--def parse_time(timestr, err=(ValueError, sre.error)):
-+def parse_time(timestr, err=(ValueError, re.error)):
- """Parse a time string in hh:mm:ss, mm:ss, or ss format."""
- if timestr[0:1] == "-":
- m = -1
-@@ -246,7 +252,7 @@
-
- try:
- return m * reduce(lambda s, a: s * 60 + int(a),
-- sre.split(r":|\.", timestr), 0)
-+ re.split(r":|\.", timestr), 0)
- except err: return 0
-
- RATING_PRECISION = 0.25
-@@ -362,7 +368,7 @@
- if not splitters: return [s.strip()]
- values = s.split("\n")
- for spl in splitters:
-- spl = sre.compile(r"\b\s*%s\s*\b" % sre.escape(spl), sre.UNICODE)
-+ spl = re.compile(r"\b\s*%s\s*\b" % re.escape(spl), re.UNICODE)
- new_values = []
- for v in values:
- new_values.extend([st.strip() for st in spl.split(v)])
-Index: util/massagers.py
-===================================================================
---- util/massagers.py (revision 3816)
-+++ util/massagers.py (revision 3817)
-@@ -8,7 +8,7 @@
- # $Id: quodlibet-0.23.1-python25.patch,v 1.1 2006/09/25 02:05:35 tcort Exp $
-
- import locale
--import sre
-+import re
-
- class Massager(object):
- """Massage a tag value from various 'okay' formats to the
-@@ -23,7 +23,7 @@
- tags = ["date"]
- error = _("The date must be entered in 'YYYY', 'YYYY-MM-DD' or "
- "'YYYY-MM-DD HH:MM:SS' format.")
-- __match = sre.compile(r"^\d{4}([-.]\d{2}([-.]\d{2}([T ]\d{2}"
-+ __match = re.compile(r"^\d{4}([-.]\d{2}([-.]\d{2}([T ]\d{2}"
- "([:.]\d{2}([:.]\d{2})?)?)?)?)?$").match
- def validate(self, value):
- value = value.strip().replace(".", "-").replace("/", "-")
-@@ -32,7 +32,7 @@
- class GainMassager(Massager):
- tags = ["replaygain_album_gain", "replaygain_track_gain"]
- error = _("Replay Gain gains must be entered in 'x.yy dB' format.")
-- __match = sre.compile(r"^[+-]\d+\.?\d+?\s+dB$").match
-+ __match = re.compile(r"^[+-]\d+\.?\d+?\s+dB$").match
-
- def validate(self, value):
- if self.__match(value): return value
diff --git a/media-sound/quodlibet/quodlibet-0.23.1-r1.ebuild b/media-sound/quodlibet/quodlibet-0.23.1-r1.ebuild
deleted file mode 100644
index 67a6f02c086f..000000000000
--- a/media-sound/quodlibet/quodlibet-0.23.1-r1.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/quodlibet/quodlibet-0.23.1-r1.ebuild,v 1.2 2007/01/06 18:47:59 aballier Exp $
-
-inherit eutils python
-
-DESCRIPTION="Quod Libet is a GTK+-based audio player written in Python."
-HOMEPAGE="http://www.sacredchao.net/quodlibet/"
-SRC_URI="http://www.sacredchao.net/~piman/software/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="aac alsa dbus esd flac gnome mad mmkeys musepack oss trayicon vorbis"
-
-DEPEND=">=virtual/python-2.4.3-r1
- trayicon? ( >=dev-python/pygtk-2.8 )
- mmkeys? ( >=dev-python/pygtk-2.8 )"
-
-RDEPEND="${DEPEND}
- >=dev-python/pygtk-2.8
- >=media-libs/mutagen-1.6
- >=media-libs/gst-plugins-good-0.10.2
- >=dev-python/gst-python-0.10.2
- mad? ( >=media-plugins/gst-plugins-mad-0.10.2 )
- vorbis? ( >=media-plugins/gst-plugins-vorbis-0.10.2
- >=media-plugins/gst-plugins-ogg-0.10.2 )
- flac? ( >=media-plugins/gst-plugins-flac-0.10.2 )
- aac? ( >=media-plugins/gst-plugins-faad-0.10.1
- >=dev-python/ctypes-0.9.9.6 )
- musepack? ( >=media-plugins/gst-plugins-musepack-0.10.0
- >=dev-python/ctypes-0.9.9.6 )
- alsa? ( >=media-plugins/gst-plugins-alsa-0.10.2 )
- oss? ( >=media-plugins/gst-plugins-oss-0.10.2 )
- esd? ( >=media-plugins/gst-plugins-esd-0.10.2 )
- gnome? ( dev-python/gnome-python-extras
- >=media-plugins/gst-plugins-gconf-0.10.3
- >=media-plugins/gst-plugins-gnomevfs-0.10.2
- dev-python/feedparser )
- dbus? ( || ( >=dev-python/dbus-python-0.71
- ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.34 ) ) )"
-
-PDEPEND="trayicon? ( media-plugins/quodlibet-trayicon )"
-
-pkg_setup() {
- if use dbus && has_version '<sys-apps/dbus-0.90' && ! built_with_use sys-apps/dbus python ; then
- eerror "dbus is missing python support. Please add 'python'"
- eerror "to your USE flags, and re-emerge sys-apps/dbus"
- die "dbus needs python support"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # multilib fix
- sed -i -e "s,^TODEP = lib/quodlibet,TODEP = \$(libdir)/quodlibet," Makefile
-
- # no gst-plugins-gconf, attempt to guess the proper pipeline value. Bug #133043, #146728.
- if ! use gnome; then
- local sinktype="alsasink"
-
- use esd && sinktype="esdsink"
- use oss && sinktype="osssink"
- use alsa && sinktype="alsasink"
-
- elog "Setting the default pipeline to ${sinktype}"
-
- sed -i -e "s,^ \"pipeline\": \"\", \"pipeline\": \"${sinktype}\"," config.py
- fi
-
- epatch "${FILESDIR}"/quodlibet-0.23.1-python25.patch || die "epatch failed"
-}
-
-src_compile() {
- if use trayicon ; then
- emake _trayicon.so || die "emake _trayicon.so failed"
- fi
-
- if use mmkeys ; then
- emake _mmkeys.so || die "emake _mmkeys.so failed"
- fi
-}
-
-src_install() {
- emake PREFIX=/usr DESTDIR="${D}" libdir="$(get_libdir)" install || die "install failed"
- dodoc README NEWS
-}
-
-pkg_postinst() {
- python_mod_optimize /usr/share/${PN}
-
- if ! use mad; then
- elog ""
- elog "You do not have the 'mad' USE flag enabled."
- elog "gst-plugins-mad, which is required for mp3 playback, may"
- elog "not be installed. For mp3 support, enable the 'mad'"
- elog "USE flag and emerge =media-sound/${P}."
- fi
-
- if ! use gnome; then
- elog ""
- elog "You do not have the 'gnome' USE flag enabled."
- elog "media-plugins/gst-plugins-gnomevfs may not be installed,"
- elog "so the proper pipeline won't be automatically selected."
- elog "We've tried to select the proper pipeline based on your"
- elog "USE flags, but if we guessed wrong you may have to set"
- elog "'pipeline = ' in your ~/.quodlibet/config file to one"
- elog "of the following: alsasink, osssink, esdsink. To enable"
- elog "automatic selection of the proper pipeline, enable the"
- elog "'gnome' USE flag and emerge =media-sound/${P}."
- fi
-
- elog ""
- elog "Installing Quod Libet from an ebuild is not supported"
- elog "upstream. If you encounter any problems, file bugs on"
- elog "bugs.gentoo.org. DO NOT USE THE UPSTREAM BUG SYSTEM."
- elog ""
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/share/${PN}
-}
diff --git a/media-sound/quodlibet/quodlibet-0.24.ebuild b/media-sound/quodlibet/quodlibet-0.24.ebuild
deleted file mode 100644
index 39ecc40daf2e..000000000000
--- a/media-sound/quodlibet/quodlibet-0.24.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/quodlibet/quodlibet-0.24.ebuild,v 1.1 2007/01/06 20:17:15 aballier Exp $
-
-inherit eutils python
-
-DESCRIPTION="Quod Libet is a GTK+-based audio player written in Python."
-HOMEPAGE="http://www.sacredchao.net/quodlibet/"
-SRC_URI="http://www.sacredchao.net/~piman/software/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="aac alsa dbus esd flac gnome mad mmkeys musepack oss trayicon vorbis"
-
-DEPEND=">=virtual/python-2.4.3-r1
- trayicon? ( >=dev-python/pygtk-2.8 )
- mmkeys? ( >=dev-python/pygtk-2.8 )"
-
-RDEPEND="${DEPEND}
- >=dev-python/pygtk-2.8
- >=media-libs/mutagen-1.6
- >=media-libs/gst-plugins-good-0.10.2
- >=dev-python/gst-python-0.10.2
- mad? ( >=media-plugins/gst-plugins-mad-0.10.2 )
- vorbis? ( >=media-plugins/gst-plugins-vorbis-0.10.2
- >=media-plugins/gst-plugins-ogg-0.10.2 )
- flac? ( >=media-plugins/gst-plugins-flac-0.10.2 )
- aac? ( >=media-plugins/gst-plugins-faad-0.10.1
- >=dev-python/ctypes-0.9.9.6 )
- musepack? ( >=media-plugins/gst-plugins-musepack-0.10.0
- >=dev-python/ctypes-0.9.9.6 )
- alsa? ( >=media-plugins/gst-plugins-alsa-0.10.2 )
- oss? ( >=media-plugins/gst-plugins-oss-0.10.2 )
- esd? ( >=media-plugins/gst-plugins-esd-0.10.2 )
- gnome? ( dev-python/gnome-python-extras
- >=media-plugins/gst-plugins-gconf-0.10.3
- >=media-plugins/gst-plugins-gnomevfs-0.10.2
- dev-python/feedparser )
- dbus? ( || ( >=dev-python/dbus-python-0.71
- ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.34 ) ) )"
-
-PDEPEND="trayicon? ( media-plugins/quodlibet-trayicon )"
-
-pkg_setup() {
- if use dbus && has_version '<sys-apps/dbus-0.90' && ! built_with_use sys-apps/dbus python ; then
- eerror "dbus is missing python support. Please add 'python'"
- eerror "to your USE flags, and re-emerge sys-apps/dbus"
- die "dbus needs python support"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # multilib fix
- sed -i -e "s,^TODEP = lib/quodlibet,TODEP = \$(libdir)/quodlibet," Makefile
-
- # no gst-plugins-gconf, attempt to guess the proper pipeline value. Bug #133043, #146728.
- if ! use gnome; then
- local sinktype="alsasink"
-
- use esd && sinktype="esdsink"
- use oss && sinktype="osssink"
- use alsa && sinktype="alsasink"
-
- elog "Setting the default pipeline to ${sinktype}"
-
- sed -i -e "s,^ \"pipeline\": \"\", \"pipeline\": \"${sinktype}\"," config.py
- fi
-
- epatch "${FILESDIR}/${P}-makefile.patch" || die "epatch failed"
-}
-
-src_compile() {
- if use trayicon ; then
- emake _trayicon.so || die "emake _trayicon.so failed"
- fi
-
- if use mmkeys ; then
- emake _mmkeys.so || die "emake _mmkeys.so failed"
- fi
-}
-
-src_install() {
- emake PREFIX=/usr DESTDIR="${D}" libdir="$(get_libdir)" install || die "install failed"
- dodoc README NEWS
-}
-
-pkg_postinst() {
- python_mod_optimize /usr/share/${PN}
-
- if ! use mad; then
- elog ""
- elog "You do not have the 'mad' USE flag enabled."
- elog "gst-plugins-mad, which is required for mp3 playback, may"
- elog "not be installed. For mp3 support, enable the 'mad'"
- elog "USE flag and emerge =media-sound/${P}."
- fi
-
- if ! use gnome; then
- elog ""
- elog "You do not have the 'gnome' USE flag enabled."
- elog "media-plugins/gst-plugins-gnomevfs may not be installed,"
- elog "so the proper pipeline won't be automatically selected."
- elog "We've tried to select the proper pipeline based on your"
- elog "USE flags, but if we guessed wrong you may have to set"
- elog "'pipeline = ' in your ~/.quodlibet/config file to one"
- elog "of the following: alsasink, osssink, esdsink. To enable"
- elog "automatic selection of the proper pipeline, enable the"
- elog "'gnome' USE flag and emerge =media-sound/${P}."
- fi
-
- elog ""
- elog "Installing Quod Libet from an ebuild is not supported"
- elog "upstream. If you encounter any problems, file bugs on"
- elog "bugs.gentoo.org. DO NOT USE THE UPSTREAM BUG SYSTEM."
- elog ""
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/share/${PN}
-}