summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-12-20 12:14:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-12-20 12:14:43 +0000
commit91385186d8b78be6c21ef469de787c80cc7054d4 (patch)
tree83ccced1776a3289f8c5e8d9006651c1be600ff7 /media-sound/qsynth
parentAdded fix to enable proper arch detection for pentium M chips. (diff)
downloadgentoo-2-91385186d8b78be6c21ef469de787c80cc7054d4.tar.gz
gentoo-2-91385186d8b78be6c21ef469de787c80cc7054d4.tar.bz2
gentoo-2-91385186d8b78be6c21ef469de787c80cc7054d4.zip
Version bump.
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'media-sound/qsynth')
-rw-r--r--media-sound/qsynth/ChangeLog7
-rw-r--r--media-sound/qsynth/files/digest-qsynth-0.3.23
-rw-r--r--media-sound/qsynth/qsynth-0.3.2.ebuild77
3 files changed, 86 insertions, 1 deletions
diff --git a/media-sound/qsynth/ChangeLog b/media-sound/qsynth/ChangeLog
index 65b6345d85ee..8d1b4c9b91a5 100644
--- a/media-sound/qsynth/ChangeLog
+++ b/media-sound/qsynth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qsynth
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.35 2007/11/23 13:58:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.36 2007/12/20 12:14:43 flameeyes Exp $
+
+*qsynth-0.3.2 (20 Dec 2007)
+
+ 20 Dec 2007; Diego Pettenò <flameeyes@gentoo.org> +qsynth-0.3.2.ebuild:
+ Version bump.
23 Nov 2007; Diego Pettenò <flameeyes@gentoo.org> -qsynth-0.2.6.ebuild:
Remove old version.
diff --git a/media-sound/qsynth/files/digest-qsynth-0.3.2 b/media-sound/qsynth/files/digest-qsynth-0.3.2
new file mode 100644
index 000000000000..67d290ae067a
--- /dev/null
+++ b/media-sound/qsynth/files/digest-qsynth-0.3.2
@@ -0,0 +1,3 @@
+MD5 be744e4898d05d1b2db89875abac10ba qsynth-0.3.2.tar.gz 139129
+RMD160 982fec5db78bb6fce1bb13326b8ba4f414513a7d qsynth-0.3.2.tar.gz 139129
+SHA256 d747e6a3a1437580416a218df213624c2020a82bb261ac59d7bcfb821146d236 qsynth-0.3.2.tar.gz 139129
diff --git a/media-sound/qsynth/qsynth-0.3.2.ebuild b/media-sound/qsynth/qsynth-0.3.2.ebuild
new file mode 100644
index 000000000000..398cfec91a2c
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.3.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.3.2.ebuild,v 1.1 2007/12/20 12:14:43 flameeyes Exp $
+
+inherit qt4 eutils flag-o-matic
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="http://qsynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="debug jack alsa"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="$(qt4_min_version 4.2)
+ >=media-sound/fluidsynth-1.0.7a"
+
+pkg_setup() {
+ if use jack; then
+ if ! built_with_use media-sound/fluidsynth jack; then
+ eerror "To use Qsynth with JACK, you need to build media-sound/fluidsynth"
+ eerror "with the jack USE flag enabled."
+ die "Missing jack USE flag on media-sound/fluidsynth"
+ fi
+ einfo "Enabling default JACK output."
+ elif use alsa; then
+ if ! built_with_use media-sound/fluidsynth alsa; then
+ eerror "To use Qsynth with ALSA, you need to build media-sound/fluidsynth"
+ eerror "with the alsa USE flag enabled."
+ die "Missing alsa USE flag on media-sound/fluidsynth"
+ fi
+ einfo "Enabling non-default ALSA output."
+ else
+ if ! built_with_use media-sound/fluidsynth oss; then
+ eerror "If you don't want to use either JACK or ALSA on Qsynth"
+ eerror "you need to enable the oss USE flag on media-sound/fluidsynth"
+ die "Missing oss USE flag on media-sound/fluidsynth"
+ fi
+ einfo "Enabling non-default OSS output."
+ fi
+}
+
+src_compile() {
+ # Stupidly, qsynth's configure does *not* use pkg-config to
+ # discover the presence of Qt4, but uses fixed paths; as they
+ # don't really work that well for our case, let's just use this
+ # nasty hack and be done with it. *NOTE*: this hinders
+ # cross-compile.
+ append-flags -I/usr/include/qt4
+ append-ldflags -L/usr/$(get_libdir)/qt4
+
+ econf \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm -rf "${D}/usr/share/applications/qsynth.desktop"
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}