summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2005-07-10 21:21:09 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2005-07-10 21:21:09 +0000
commit99862c3fcf41d41c9e6d619642031b43452dfb16 (patch)
tree17fada2cccf3cf1fd07f598a6cf965e37eeecc7d /media-sound/qsampler
parentQA: Use die between || and the text 'emake failed' (diff)
downloadgentoo-2-99862c3fcf41d41c9e6d619642031b43452dfb16.tar.gz
gentoo-2-99862c3fcf41d41c9e6d619642031b43452dfb16.tar.bz2
gentoo-2-99862c3fcf41d41c9e6d619642031b43452dfb16.zip
version bump
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-sound/qsampler')
-rw-r--r--media-sound/qsampler/ChangeLog7
-rw-r--r--media-sound/qsampler/Manifest4
-rw-r--r--media-sound/qsampler/files/digest-qsampler-0.1.21
-rw-r--r--media-sound/qsampler/qsampler-0.1.2.ebuild47
4 files changed, 57 insertions, 2 deletions
diff --git a/media-sound/qsampler/ChangeLog b/media-sound/qsampler/ChangeLog
index 93efc96be8dd..ad4adf9ab2b2 100644
--- a/media-sound/qsampler/ChangeLog
+++ b/media-sound/qsampler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qsampler
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsampler/ChangeLog,v 1.1 2005/05/29 23:35:00 fvdpol Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsampler/ChangeLog,v 1.2 2005/07/10 21:21:09 fvdpol Exp $
+
+*qsampler-0.1.2 (10 Jul 2005)
+
+ 10 Jul 2005; Frank van de Pol <fvdpol@gentoo.org> +qsampler-0.1.2.ebuild:
+ version bump
30 May 2005; Frank van de Pol <fvdpol@gentoo.org> :
New ebuild for qsampler, a graphical frontend to LinuxSampler
diff --git a/media-sound/qsampler/Manifest b/media-sound/qsampler/Manifest
index 605028abda60..d84abb4b8ac8 100644
--- a/media-sound/qsampler/Manifest
+++ b/media-sound/qsampler/Manifest
@@ -1,4 +1,6 @@
-MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 82a5a31afb61f68aea23bf529e8b4a40 qsampler-0.1.0.ebuild 1296
+MD5 28777b8bdecc6d959de75a8fbb05da67 qsampler-0.1.2.ebuild 1308
MD5 fbb19ecbd66ea3c6b398e774d2dcd330 ChangeLog 332
+MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 6f68d6ba7868d9a1267c051b31ac3011 files/digest-qsampler-0.1.0 66
+MD5 5e7db067c4ed83e8e7db11b327a67d56 files/digest-qsampler-0.1.2 66
diff --git a/media-sound/qsampler/files/digest-qsampler-0.1.2 b/media-sound/qsampler/files/digest-qsampler-0.1.2
new file mode 100644
index 000000000000..3b9e8b43c1b0
--- /dev/null
+++ b/media-sound/qsampler/files/digest-qsampler-0.1.2
@@ -0,0 +1 @@
+MD5 f919ba6382858953405da4dd1c6d89b6 qsampler-0.1.2.tar.gz 123919
diff --git a/media-sound/qsampler/qsampler-0.1.2.ebuild b/media-sound/qsampler/qsampler-0.1.2.ebuild
new file mode 100644
index 000000000000..26fd039cd5c4
--- /dev/null
+++ b/media-sound/qsampler/qsampler-0.1.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsampler/qsampler-0.1.2.ebuild,v 1.1 2005/07/10 21:21:09 fvdpol Exp $
+
+inherit kde eutils
+
+DESCRIPTION="QSampler is a graphical frontent to the LinuxSampler engine."
+HOMEPAGE="http://www.linuxsampler.org/"
+SRC_URI="http://download.linuxsampler.org/packages/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="virtual/libc
+ >=x11-libs/qt-3.1.1
+ >=media-libs/liblscp-0.3.0
+ >=media-libs/libgig-2.0.1
+ >=media-sound/linuxsampler-0.3.2
+ media-libs/alsa-lib"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf || die "./configure failed"
+
+
+ ### borrowed from kde.eclass #
+ #
+ # fix the sandbox errors "can't writ to .kde or .qt" problems.
+ # this is a fake homedir that is writeable under the sandbox,
+ # so that the build process can do anything it wants with it.
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc AUTHORS ChangeLog INSTALL README
+}