summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-12-17 14:21:59 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-12-17 14:21:59 +0000
commit41172fec773aafabe85027e82011b3f6d8c218da (patch)
tree2abd66a5b6b6a1a229fd9913b823069a61e48fcb /media-sound/qjackctl
parentStable on alpha, bug #337638 (diff)
downloadgentoo-2-41172fec773aafabe85027e82011b3f6d8c218da.tar.gz
gentoo-2-41172fec773aafabe85027e82011b3f6d8c218da.tar.bz2
gentoo-2-41172fec773aafabe85027e82011b3f6d8c218da.zip
version bump
(Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qjackctl')
-rw-r--r--media-sound/qjackctl/ChangeLog7
-rw-r--r--media-sound/qjackctl/qjackctl-0.3.7.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-sound/qjackctl/ChangeLog b/media-sound/qjackctl/ChangeLog
index ba9172be8b3b..9e5f376b52bf 100644
--- a/media-sound/qjackctl/ChangeLog
+++ b/media-sound/qjackctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qjackctl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.64 2010/03/09 23:33:43 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.65 2010/12/17 14:21:59 aballier Exp $
+
+*qjackctl-0.3.7 (17 Dec 2010)
+
+ 17 Dec 2010; Alexis Ballier <aballier@gentoo.org> +qjackctl-0.3.7.ebuild:
+ version bump
*qjackctl-0.3.6 (09 Mar 2010)
diff --git a/media-sound/qjackctl/qjackctl-0.3.7.ebuild b/media-sound/qjackctl/qjackctl-0.3.7.ebuild
new file mode 100644
index 000000000000..6cd849ddb258
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.3.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.3.7.ebuild,v 1.1 2010/12/17 14:21:59 aballier Exp $
+
+EAPI=2
+
+inherit qt4
+
+DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections."
+HOMEPAGE="http://qjackctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="alsa dbus debug portaudio"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ dbus? ( x11-libs/qt-dbus )
+ portaudio? ( media-libs/portaudio )
+ >=media-sound/jack-audio-connection-kit-0.109.2"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable alsa alsa-seq) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable portaudio)
+
+ # Emulate what the Makefile does, so that we can get the correct
+ # compiler used.
+ eqmake4 ${PN}.pro -o ${PN}.mak || die "eqmake4 failed"
+}
+
+src_compile() {
+ emake -f ${PN}.mak || die "emake failed"
+ lupdate ${PN}.pro || die "lupdate failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO AUTHORS TRANSLATORS
+}