summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-09-13 05:00:35 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-09-13 05:00:35 +0000
commit09ac30079b950b14d3b9b2cf424effb53f5df52e (patch)
tree17d98860c36091c3f53afd992620bb95fa8f5326 /media-sound/qjackctl/qjackctl-0.2.11.ebuild
parentfix SRC_URI for bug #63848; tidy (Manifest recommit) (diff)
downloadgentoo-2-09ac30079b950b14d3b9b2cf424effb53f5df52e.tar.gz
gentoo-2-09ac30079b950b14d3b9b2cf424effb53f5df52e.tar.bz2
gentoo-2-09ac30079b950b14d3b9b2cf424effb53f5df52e.zip
qjackctl-0.2.11.ebuild
Diffstat (limited to 'media-sound/qjackctl/qjackctl-0.2.11.ebuild')
-rw-r--r--media-sound/qjackctl/qjackctl-0.2.11.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/qjackctl/qjackctl-0.2.11.ebuild b/media-sound/qjackctl/qjackctl-0.2.11.ebuild
new file mode 100644
index 000000000000..0d6c0e236885
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.2.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.2.11.ebuild,v 1.1 2004/09/13 05:00:35 eradicator Exp $
+
+IUSE=""
+
+DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections."
+HOMEPAGE="http://qjackctl.sf.net/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ~ppc"
+
+DEPEND="virtual/libc
+ >=x11-libs/qt-3.1.1
+ media-sound/jack-audio-connection-kit"
+
+src_compile() {
+ econf || die
+
+ ### borrowed from kde.eclass #
+ #
+ # fix the sandbox errors "can't writ to .kde or .qt" problems.
+ # this is a fake homedir that is writeable under the sandbox,
+ # so that the build process can do anything it wants with it.
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+
+ emake || die
+}
+
+src_install() {
+ einstall || die "make install failed"
+}