summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-08 15:38:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-08 15:38:32 +0000
commit6ff078fbb3e9b22f9e96bc21c9a4b8e8879a7d7e (patch)
tree0161ae47423ee46550ae55034f61e5fe9ffdbaf8 /media-sound/peercast
parentold (diff)
downloadgentoo-2-6ff078fbb3e9b22f9e96bc21c9a4b8e8879a7d7e.tar.gz
gentoo-2-6ff078fbb3e9b22f9e96bc21c9a4b8e8879a7d7e.tar.bz2
gentoo-2-6ff078fbb3e9b22f9e96bc21c9a4b8e8879a7d7e.zip
Fix hardcoded g++ which was used for linking wrt #221945
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/peercast')
-rw-r--r--media-sound/peercast/ChangeLog8
-rw-r--r--media-sound/peercast/peercast-0.1218-r1.ebuild27
2 files changed, 19 insertions, 16 deletions
diff --git a/media-sound/peercast/ChangeLog b/media-sound/peercast/ChangeLog
index 1a61242a76fb..3c495a3b016c 100644
--- a/media-sound/peercast/ChangeLog
+++ b/media-sound/peercast/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/peercast
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/peercast/ChangeLog,v 1.19 2008/07/07 20:59:25 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/peercast/ChangeLog,v 1.20 2009/05/08 15:38:32 ssuominen Exp $
+
+ 08 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ peercast-0.1218-r1.ebuild:
+ Fix hardcoded g++ which was used for linking wrt #221945
07 Jul 2008; Markus Meier <maekke@gentoo.org> peercast-0.1218-r1.ebuild:
amd64/x86 stable, bug #220281
diff --git a/media-sound/peercast/peercast-0.1218-r1.ebuild b/media-sound/peercast/peercast-0.1218-r1.ebuild
index 2ef838633721..33f94c72fd82 100644
--- a/media-sound/peercast/peercast-0.1218-r1.ebuild
+++ b/media-sound/peercast/peercast-0.1218-r1.ebuild
@@ -1,35 +1,34 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/peercast/peercast-0.1218-r1.ebuild,v 1.2 2008/07/07 20:59:25 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/peercast/peercast-0.1218-r1.ebuild,v 1.3 2009/05/08 15:38:32 ssuominen Exp $
inherit eutils toolchain-funcs flag-o-matic base
-IUSE=""
-
-S=${WORKDIR}
-
DESCRIPTION="A client and server for Peercast P2P-radio network"
HOMEPAGE="http://www.peercast.org"
-
SRC_URI="http://www.peercast.org/src/${P}-src.tgz"
LICENSE="GPL-2"
-
SLOT="0"
KEYWORDS="amd64 x86"
+IUSE=""
-DEPEND=""
RDEPEND=""
-PATCHES=( "${FILESDIR}/${P}-CVE-2008-2040.patch"
- "${FILESDIR}/${PN}-0.1216-makefile.patch"
- "${FILESDIR}/${PN}-0.1216-amd64.patch" )
+DEPEND=""
+
+S=${WORKDIR}
+
+PATCHES=( "${FILESDIR}/${P}-CVE-2008-2040.patch"
+ "${FILESDIR}/${PN}-0.1216-makefile.patch"
+ "${FILESDIR}/${PN}-0.1216-amd64.patch" )
src_compile() {
append-ldflags -pthread
cd "${S}"/ui/linux
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" AR="$(tc-getAR)" \
- LDFLAGS="${LDFLAGS}" || die "emake failed"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" LDFLAGS="${LDFLAGS}" \
+ LD="$(tc-getCXX)" || die "emake failed"
}
src_install() {