summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-14 19:00:06 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-14 19:00:06 +0000
commit2b3a00a1dfd2c206573f9dfd0650d970f465e7b4 (patch)
tree65f8450e9df88de5760d89b87a7735c5885f88ad /media-sound/pd
parentNew package. Fixes #2749 (diff)
downloadgentoo-2-2b3a00a1dfd2c206573f9dfd0650d970f465e7b4.tar.gz
gentoo-2-2b3a00a1dfd2c206573f9dfd0650d970f465e7b4.tar.bz2
gentoo-2-2b3a00a1dfd2c206573f9dfd0650d970f465e7b4.zip
New package. Fixes #2987
Diffstat (limited to 'media-sound/pd')
-rw-r--r--media-sound/pd/ChangeLog13
-rw-r--r--media-sound/pd/files/digest-pd-0.35_pre241
-rw-r--r--media-sound/pd/files/pd-0.35-test24-gentoo.patch40
-rw-r--r--media-sound/pd/pd-0.35_pre24.ebuild56
4 files changed, 110 insertions, 0 deletions
diff --git a/media-sound/pd/ChangeLog b/media-sound/pd/ChangeLog
new file mode 100644
index 000000000000..5a34f494c3a1
--- /dev/null
+++ b/media-sound/pd/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-sound/pd
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pd/ChangeLog,v 1.1 2002/06/14 19:00:06 rphillips Exp $
+
+*pd-0.35_pre24 (14 June 2002)
+
+ 14 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/media-sound/pd/files/digest-pd-0.35_pre24 b/media-sound/pd/files/digest-pd-0.35_pre24
new file mode 100644
index 000000000000..2159f1296864
--- /dev/null
+++ b/media-sound/pd/files/digest-pd-0.35_pre24
@@ -0,0 +1 @@
+MD5 5e16595c97ffd7e3ccb5296031a4e4c6 pd-0.35-test24.linux.tar.gz 1331557
diff --git a/media-sound/pd/files/pd-0.35-test24-gentoo.patch b/media-sound/pd/files/pd-0.35-test24-gentoo.patch
new file mode 100644
index 000000000000..d35143418a2b
--- /dev/null
+++ b/media-sound/pd/files/pd-0.35-test24-gentoo.patch
@@ -0,0 +1,40 @@
+diff -ur pd-0.35-test24.orig/src/makefile.in pd-0.35-test24/src/makefile.in
+--- pd-0.35-test24.orig/src/makefile.in Fri May 24 19:08:40 2002
++++ pd-0.35-test24/src/makefile.in Tue Jun 4 10:44:00 2002
+@@ -12,6 +12,8 @@
+ INSTALL_PREFIX = @prefix@
+ GFLAGS = -DINSTALL_PREFIX=\"$(INSTALL_PREFIX)\"
+
++MANDIR = @mandir@
++
+ # ALSA compilation
+
+ SOUND_ALSA = @alsa@
+@@ -164,6 +166,7 @@
+ cd ../extra/pique;make @EXTERNTARGET@
+
+ INSTDIR = $(DESTDIR)/$(INSTALL_PREFIX)
++MANINSTDIR = $(DESTDIR)/$(MANDIR)
+ install:
+ install -d $(INSTDIR)/lib/pd/bin
+ install $(BIN_DIR)/$(GUINAME) $(INSTDIR)/lib/pd/bin/$(GUINAME)
+@@ -179,12 +182,13 @@
+ cp -r ../doc $(INSTDIR)/lib/pd/
+ install -d $(INSTDIR)/include
+ install -m644 m_pd.h $(INSTDIR)/include/m_pd.h
+- gzip < ../man/pd.1 > $(INSTDIR)/man/man1/pd.1.gz
+- chmod 644 $(INSTDIR)/man/man1/pd.1.gz
+- gzip < ../man/pdsend.1 > $(INSTDIR)/man/man1/pdsend.1.gz
+- chmod 644 $(INSTDIR)/man/man1/pdsend.1.gz
+- gzip < ../man/pdreceive.1 > $(INSTDIR)/man/man1/pdreceive.1.gz
+- chmod 644 $(INSTDIR)/man/man1/pdreceive.1.gz
++ install -d $(MANINSTDIR)/man1
++ gzip < ../man/pd.1 > $(MANINSTDIR)/man1/pd.1.gz
++ chmod 644 $(MANINSTDIR)/man1/pd.1.gz
++ gzip < ../man/pdsend.1 > $(MANINSTDIR)/man1/pdsend.1.gz
++ chmod 644 $(MANINSTDIR)/man1/pdsend.1.gz
++ gzip < ../man/pdreceive.1 > $(MANINSTDIR)/man1/pdreceive.1.gz
++ chmod 644 $(MANINSTDIR)/man1/pdreceive.1.gz
+
+ local-clean:
+ -rm -f ../obj/* $(BIN_DIR)/pd $(BIN_DIR)/$(GUINAME) $(BIN_DIR)/pdsend \
diff --git a/media-sound/pd/pd-0.35_pre24.ebuild b/media-sound/pd/pd-0.35_pre24.ebuild
new file mode 100644
index 000000000000..29ca12b176ff
--- /dev/null
+++ b/media-sound/pd/pd-0.35_pre24.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.6 2002/05/07 03:58:19 drobbins Exp
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
+# if you omit this line.
+
+# Miller Puckette uses nonstandard versioning scheme that we have to crunch
+PD_VER=`echo ${PV} | sed 's:_pre:-test:'`
+S=${WORKDIR}/${PN}-${PD_VER}
+DESCRIPTION="real-time music and multimedia environment"
+SRC_URI="http://www-crca.ucsd.edu/~msp/Software/${PN}-${PD_VER}.linux.tar.gz"
+HOMEPAGE="http://www-crca.ucsd.edu/~msp/software.html"
+LICENSE=""
+
+#
+# need to do something with alsa here:
+# pd can be configured to use alsa-0.5x or alsa-0.9x,
+# but i don't know how to determine which one is installed
+# automagicly
+#
+DEPEND=">=dev-lang/tcl-8.3.3
+ >=dev-lang/tk-8.3.3"
+
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+ patch -p1 < ${FILESDIR}/${PN}-${PD_VER}-gentoo.patch || die
+ cd src || die
+ autoconf || die
+}
+
+src_compile() {
+
+ cd src
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ cd src
+ make DESTDIR=${D} install || die
+ #make \
+ # prefix=${D}/usr \
+ # mandir=${D}/usr/share/man \
+ # infodir=${D}/usr/share/info \
+ # install || die
+}