summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-02-16 08:53:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-02-16 08:53:10 +0000
commit6cc869ca8625553ab520260d8abd193e0f0d8d40 (patch)
tree678e25e4ab725449fcd21334d9e7ec0ff6879377 /media-sound/opmixer/opmixer-0.75.ebuild
parentMake pkgconfig only a build-time dependency. (diff)
downloadgentoo-2-6cc869ca8625553ab520260d8abd193e0f0d8d40.tar.gz
gentoo-2-6cc869ca8625553ab520260d8abd193e0f0d8d40.tar.bz2
gentoo-2-6cc869ca8625553ab520260d8abd193e0f0d8d40.zip
Shorten description, and fix sed to use inline replace.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'media-sound/opmixer/opmixer-0.75.ebuild')
-rw-r--r--media-sound/opmixer/opmixer-0.75.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/media-sound/opmixer/opmixer-0.75.ebuild b/media-sound/opmixer/opmixer-0.75.ebuild
index eb4311baeedd..6fc61caed958 100644
--- a/media-sound/opmixer/opmixer-0.75.ebuild
+++ b/media-sound/opmixer/opmixer-0.75.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/opmixer/opmixer-0.75.ebuild,v 1.17 2005/09/04 11:03:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/opmixer/opmixer-0.75.ebuild,v 1.18 2006/02/16 08:53:10 flameeyes Exp $
inherit eutils
@@ -8,7 +8,7 @@ IUSE=""
MY_P=${P/opm/opM}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="An oss mixer written in c++ using the gtkmm gui-toolkit. Supports saving, loading and muting of volumes for channels and autoloading via a consoleapp"
+DESCRIPTION="OSS mixer written in C++ with GTKmm GUI."
HOMEPAGE="http://optronic.sourceforge.net/"
SRC_URI="http://optronic.sourceforge.net/files/${MY_P}.tar.bz2"
@@ -31,9 +31,8 @@ src_compile() {
#gcc3.2 fix for #8760
cd ${S}/src
- cp volset.cc volset.cc.old
- sed -e 's/ endl/ std::endl/' \
- volset.cc.old > volset.cc
+ sed -i -e 's/ endl/ std::endl/' \
+ volset.cc
emake || die "make failed"
}