summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-09-02 22:42:35 +0000
committerChris White <chriswhite@gentoo.org>2004-09-02 22:42:35 +0000
commit12042a59718c8eed0da1ab64c313dab9cd725194 (patch)
tree2eb170348bea5c03d6a3940f5f1314602dc508ee /media-sound/mplay/mplay-0.68.ebuild
parentppc stable profile update (Manifest recommit) (diff)
downloadgentoo-2-12042a59718c8eed0da1ab64c313dab9cd725194.tar.gz
gentoo-2-12042a59718c8eed0da1ab64c313dab9cd725194.tar.bz2
gentoo-2-12042a59718c8eed0da1ab64c313dab9cd725194.zip
Initial import to the tree. Closes 47600.
Diffstat (limited to 'media-sound/mplay/mplay-0.68.ebuild')
-rw-r--r--media-sound/mplay/mplay-0.68.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/mplay/mplay-0.68.ebuild b/media-sound/mplay/mplay-0.68.ebuild
new file mode 100644
index 000000000000..d605cdc7a281
--- /dev/null
+++ b/media-sound/mplay/mplay-0.68.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mplay/mplay-0.68.ebuild,v 1.1 2004/09/02 22:42:35 chriswhite Exp $
+
+inherit perl-module
+
+AMIX_V="0.7"
+AMIX_D="${WORKDIR}/Audio-Mixer-${AMIX_V}"
+
+PP_V="0.07"
+PP_D="${WORKDIR}/Ogg-Vorbis-Header-PurePerl-${PP_V}"
+
+DESCRIPTION="A Curses front-end for mplayer"
+HOMEPAGE="http://mplay.sourceforge.net"
+SRC_URI="mirror://sourceforge/mplay/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-perl/TermReadKey
+ dev-perl/MP3-Info
+ dev-perl/Term-ANSIScreen
+ dev-perl/Time-HiRes
+ media-video/mplayer"
+
+src_unpack() {
+ unpack ${A}
+
+ #build the Audio-Mixer dep
+ cd ${S}/src
+ tar xfz Audio-Mixer-${AMIX_V}.tar.gz -C ${WORKDIR}
+ tar xfz Ogg-Vorbis-Header-PurePerl-${PP_V}.tar.gz -C ${WORKDIR}
+
+ cd ${S}
+ sed 's:/usr/local:/usr:g' -i mplay || die "Unable fix the /usr/local path issues."
+}
+
+src_compile() {
+ cd ${AMIX_D}
+ perl-module_src_prep
+ perl-module_src_compile
+
+ cd ${PP_D}
+ perl-module_src_prep
+ perl-module_src_compile
+}
+
+src_install() {
+ dodir /usr/share/mplay /usr/bin
+
+ dobin mplay
+
+ insinto /usr/share/mplay
+ doins help_en help_de
+
+ dodoc README
+
+ cd ${AMIX_D}
+ #make install
+ perl-module_src_install
+
+ cd ${PP_D}
+ #make install
+ perl-module_src_install
+}
+
+pkg_postinst() {
+ einfo "Please note, gnome terminal does not like this program"
+ einfo "too much. xterm,kterm, and konsole can use it ok."
+}