summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-11-18 21:52:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-11-18 21:52:08 +0000
commit80083e08880bc27791ed4b7abf51ba4dbc3485fb (patch)
tree60bc70c51fa38d2878ff0406c0ad83175d4d49a7 /media-sound/kid3/kid3-0.6.ebuild
parentAdd cxx USE flag for libpcre. (diff)
downloadgentoo-2-80083e08880bc27791ed4b7abf51ba4dbc3485fb.tar.gz
gentoo-2-80083e08880bc27791ed4b7abf51ba4dbc3485fb.tar.bz2
gentoo-2-80083e08880bc27791ed4b7abf51ba4dbc3485fb.zip
add a check for flac cxx use flag, FLAC++ is needed here
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-sound/kid3/kid3-0.6.ebuild')
-rw-r--r--media-sound/kid3/kid3-0.6.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/media-sound/kid3/kid3-0.6.ebuild b/media-sound/kid3/kid3-0.6.ebuild
index 2342ca649a1b..a0ad5ea0f542 100644
--- a/media-sound/kid3/kid3-0.6.ebuild
+++ b/media-sound/kid3/kid3-0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.6.ebuild,v 1.4 2006/07/25 08:02:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.6.ebuild,v 1.5 2007/11/18 21:52:08 aballier Exp $
inherit kde
@@ -19,6 +19,16 @@ DEPEND=">=media-libs/id3lib-3.8.3
need-kde 3
+pkg_setup() {
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
+ kde_pkg_setup
+}
+
# Support for the KDE libraries is optional,
# but the configure step that detects them
# cannot be avoided. So KDE support is forced on.