summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-14 06:53:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-14 06:53:07 +0000
commit9663ed1c90e7b7c64bf4e7d955ceaffe06b62639 (patch)
tree905f0c0aede3154c99cbf01e9d535b4af3f5f4d6 /media-sound/kguitar
parentstable x86, bug 268533 (diff)
downloadgentoo-2-9663ed1c90e7b7c64bf4e7d955ceaffe06b62639.tar.gz
gentoo-2-9663ed1c90e7b7c64bf4e7d955ceaffe06b62639.tar.bz2
gentoo-2-9663ed1c90e7b7c64bf4e7d955ceaffe06b62639.zip
Remove configure and let kde.eclass handle it.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/kguitar')
-rw-r--r--media-sound/kguitar/ChangeLog6
-rw-r--r--media-sound/kguitar/kguitar-0.5-r1.ebuild18
-rw-r--r--media-sound/kguitar/kguitar-0.5.ebuild28
3 files changed, 16 insertions, 36 deletions
diff --git a/media-sound/kguitar/ChangeLog b/media-sound/kguitar/ChangeLog
index e6b521e2f1f8..3a0c24c20630 100644
--- a/media-sound/kguitar/ChangeLog
+++ b/media-sound/kguitar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/kguitar
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kguitar/ChangeLog,v 1.8 2009/02/13 20:34:18 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kguitar/ChangeLog,v 1.9 2009/05/14 06:53:07 ssuominen Exp $
+
+ 14 May 2009; Samuli Suominen <ssuominen@gentoo.org> -kguitar-0.5.ebuild,
+ kguitar-0.5-r1.ebuild:
+ Remove configure and let kde.eclass handle it.
*kguitar-0.5-r1 (13 Feb 2009)
diff --git a/media-sound/kguitar/kguitar-0.5-r1.ebuild b/media-sound/kguitar/kguitar-0.5-r1.ebuild
index 8263ee2a0d31..99434f4fc8c8 100644
--- a/media-sound/kguitar/kguitar-0.5-r1.ebuild
+++ b/media-sound/kguitar/kguitar-0.5-r1.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kguitar/kguitar-0.5-r1.ebuild,v 1.1 2009/02/13 20:34:18 carlo Exp $
-
-ARTS_REQUIRED="never"
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kguitar/kguitar-0.5-r1.ebuild,v 1.2 2009/05/14 06:53:07 ssuominen Exp $
+ARTS_REQUIRED=never
inherit kde
DESCRIPTION="An efficient and easy-to-use environment for a guitarist."
HOMEPAGE="http://kguitar.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-# hard-dep on tse3, without it causes Settings->Configure KGuitar to crash. (eldad 15 April 2006)
-DEPEND=">=media-libs/tse3-0.2.3"
-RDEPEND="${DEPEND}"
+RDEPEND="media-libs/tse3"
+DEPEND="${RDEPEND}"
+
need-kde 3.5
PATCHES=(
@@ -25,6 +24,11 @@ PATCHES=(
"${FILESDIR}"/kguitar-0.5-desktop-file.diff
)
+src_unpack() {
+ kde_src_unpack
+ rm -f "${S}"/configure
+}
+
src_compile() {
local myconf="--with-tse3"
kde_src_compile
diff --git a/media-sound/kguitar/kguitar-0.5.ebuild b/media-sound/kguitar/kguitar-0.5.ebuild
deleted file mode 100644
index bff14784433a..000000000000
--- a/media-sound/kguitar/kguitar-0.5.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kguitar/kguitar-0.5.ebuild,v 1.6 2008/06/09 11:28:33 flameeyes Exp $
-
-inherit kde
-
-DESCRIPTION="An efficient and easy-to-use environment for a guitarist"
-HOMEPAGE="http://kguitar.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-SLOT="0"
-
-IUSE=""
-
-# hard-dep on tse3, without it causes Settings->Configure KGuitar to crash. (eldad 15 April 2006)
-DEPEND=">=media-libs/tse3-0.2.3"
-need-kde 3
-
-PATCHES=(
- "${FILESDIR}"/${P}+gcc-4.3.patch
-)
-
-src_compile() {
- myconf="--with-tse3"
- kde_src_compile
-}