summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-07-05 22:37:52 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-07-05 22:37:52 +0000
commit14f84b574dc34885981c0d8dd6dec90c16ab78f0 (patch)
tree1988748b3ce0ee874e4cd31a600d358edf67ef85 /media-sound/gnomad
parentAdjust deps. (diff)
downloadgentoo-2-14f84b574dc34885981c0d8dd6dec90c16ab78f0.tar.gz
gentoo-2-14f84b574dc34885981c0d8dd6dec90c16ab78f0.tar.bz2
gentoo-2-14f84b574dc34885981c0d8dd6dec90c16ab78f0.zip
Rev bump with patch for libmtp-0.3.0 API, bug #230864.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'media-sound/gnomad')
-rw-r--r--media-sound/gnomad/ChangeLog9
-rw-r--r--media-sound/gnomad/files/gnomad-2.9.1-libmtp-0.3.0-API.patch49
-rw-r--r--media-sound/gnomad/gnomad-2.9.1-r1.ebuild48
-rw-r--r--media-sound/gnomad/gnomad-2.9.1.ebuild4
4 files changed, 107 insertions, 3 deletions
diff --git a/media-sound/gnomad/ChangeLog b/media-sound/gnomad/ChangeLog
index b69fa8302f98..4b7512b8f682 100644
--- a/media-sound/gnomad/ChangeLog
+++ b/media-sound/gnomad/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/gnomad
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomad/ChangeLog,v 1.32 2008/06/22 15:20:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomad/ChangeLog,v 1.33 2008/07/05 22:37:51 loki_val Exp $
+
+*gnomad-2.9.1-r1 (05 Jul 2008)
+
+ 05 Jul 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/gnomad-2.9.1-libmtp-0.3.0-API.patch, gnomad-2.9.1.ebuild,
+ +gnomad-2.9.1-r1.ebuild:
+ Rev bump with patch for libmtp-0.3.0 API, bug #230864.
22 Jun 2008; Markus Meier <maekke@gentoo.org> gnomad-2.9.1.ebuild:
amd64/x86 stable, bug #227437
diff --git a/media-sound/gnomad/files/gnomad-2.9.1-libmtp-0.3.0-API.patch b/media-sound/gnomad/files/gnomad-2.9.1-libmtp-0.3.0-API.patch
new file mode 100644
index 000000000000..48ba5d5fc85b
--- /dev/null
+++ b/media-sound/gnomad/files/gnomad-2.9.1-libmtp-0.3.0-API.patch
@@ -0,0 +1,49 @@
+--- gnomad-2.9.1.orig/src/jukebox.c 2008/03/25 23:52:29 1.122
++++ gnomad-2.9.1/src/jukebox.c 2008/06/26 23:52:41 1.123
+@@ -2177,11 +2177,14 @@
+ trackmeta->duration = length * 1000;
+ trackmeta->filesize = get_64bit_file_size(tmpfname);
+ trackmeta->filetype = filetype_d->filetype;
++ // Hardcode parent (folder) to 0 (== root directory)
++ trackmeta->parent_id = 0;
++ // Hardcode storage to primary
++ trackmeta->storage_id = 0;
+ // TODO: Discarding return value as for now
+ // g_print("Transferring MTP track...\n");
+- // Hardcode parent (folder) to 0 (== root directory)
+ ret = LIBMTP_Send_Track_From_File(mtpdevice, tmpfname, trackmeta,
+- mtp_progress, NULL, 0);
++ mtp_progress, NULL);
+ if (ret != 0) {
+ g_print("Error sending file \"%s\" to MTP device!\n", tmpfname);
+ LIBMTP_Dump_Errorstack(mtpdevice);
+@@ -2348,7 +2351,7 @@
+ filemeta->filesize = (uint64_t) hdmeta->size;
+ filemeta->filetype = filetype_d->filetype;
+ filemeta->parent_id = mtp_current_filter_id;
+- if (LIBMTP_Send_File_From_File(mtpdevice, tmpfname, filemeta, mtp_progress, NULL, mtp_current_filter_id) != 0) {
++ if (LIBMTP_Send_File_From_File(mtpdevice, tmpfname, filemeta, mtp_progress, NULL) != 0) {
+ LIBMTP_destroy_file_t(filemeta);
+ g_free(tmpfname);
+ g_print("Error sending file \"%s\" to MTP device!\n", tmpfname);
+@@ -2746,8 +2749,10 @@
+
+ pl = LIBMTP_new_playlist_t();
+ pl->name = g_strdup(plname);
++ pl->parent_id = 0;
++ pl->storage_id = 0;
+ // This will create the new playlist in the default folder
+- if (LIBMTP_Create_New_Playlist(mtpdevice, pl, 0) != 0) {
++ if (LIBMTP_Create_New_Playlist(mtpdevice, pl) != 0) {
+ create_error_dialog(_("Could not create playlist"));
+ return 0;
+ }
+@@ -3609,7 +3614,7 @@
+
+ #ifdef HAVE_LIBMTP
+ if (use_mtp) {
+- int ret=LIBMTP_Create_Folder(mtpdevice,foldername,mtp_current_filter_id);
++ int ret=LIBMTP_Create_Folder(mtpdevice,foldername,mtp_current_filter_id,0);
+ mtp_initialize_folders();
+ rebuild_datafile_list(folder);
+ return;
diff --git a/media-sound/gnomad/gnomad-2.9.1-r1.ebuild b/media-sound/gnomad/gnomad-2.9.1-r1.ebuild
new file mode 100644
index 000000000000..68c741ff1890
--- /dev/null
+++ b/media-sound/gnomad/gnomad-2.9.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomad/gnomad-2.9.1-r1.ebuild,v 1.1 2008/07/05 22:37:51 loki_val Exp $
+
+GCONF_DEBUG=no
+
+inherit eutils flag-o-matic gnome2
+
+MY_PN=${PN}2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A GNOME2 frontend for Creative Players (Zen, JukeBox, etc ...)"
+HOMEPAGE="http://gnomad2.sourceforge.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+#-sparc: 2.4.4: Application crashes on startup (Gnome crash detection)
+KEYWORDS="~amd64 ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/hal
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
+ >=media-libs/libnjb-2.2.4
+ >=media-libs/libmtp-0.3.0
+ >=media-libs/taglib-1.4-r1
+ >=media-libs/libid3tag-0.15.1b"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}"/${P}-desktop-entry.patch
+ epatch "${FILESDIR}"/${P}-libmtp-0.3.0-API.patch
+}
+
+src_compile() {
+ strip-flags
+ replace-flags -O3 -O2
+ gnome2_src_compile
+}
diff --git a/media-sound/gnomad/gnomad-2.9.1.ebuild b/media-sound/gnomad/gnomad-2.9.1.ebuild
index 1a46954b6c9d..a870b3c46d2d 100644
--- a/media-sound/gnomad/gnomad-2.9.1.ebuild
+++ b/media-sound/gnomad/gnomad-2.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomad/gnomad-2.9.1.ebuild,v 1.3 2008/06/22 15:20:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomad/gnomad-2.9.1.ebuild,v 1.4 2008/07/05 22:37:51 loki_val Exp $
GCONF_DEBUG=no
@@ -24,7 +24,7 @@ RDEPEND="sys-apps/hal
>=dev-libs/glib-2.6
>=x11-libs/gtk+-2.6
>=media-libs/libnjb-2.2.4
- >=media-libs/libmtp-0.1.3
+ <=media-libs/libmtp-0.3.0
>=media-libs/taglib-1.4-r1
>=media-libs/libid3tag-0.15.1b"
DEPEND="${RDEPEND}