summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-06-19 12:27:38 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-06-19 12:27:38 +0000
commita8ad38030efa536ac16808581377503b1228badc (patch)
treebceedc83fb6e8a939429d548d52b34081e681ed1 /media-sound/gmpc/gmpc-0.15.1.ebuild
parentFixed tracd init script, closing bug #179197. (diff)
downloadgentoo-2-a8ad38030efa536ac16808581377503b1228badc.tar.gz
gentoo-2-a8ad38030efa536ac16808581377503b1228badc.tar.bz2
gentoo-2-a8ad38030efa536ac16808581377503b1228badc.zip
Version bump.
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-sound/gmpc/gmpc-0.15.1.ebuild')
-rw-r--r--media-sound/gmpc/gmpc-0.15.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/gmpc/gmpc-0.15.1.ebuild b/media-sound/gmpc/gmpc-0.15.1.ebuild
new file mode 100644
index 000000000000..d13ac9504755
--- /dev/null
+++ b/media-sound/gmpc/gmpc-0.15.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/gmpc-0.15.1.ebuild,v 1.1 2007/06/19 12:27:38 ticho Exp $
+
+IUSE="gnome session"
+
+DESCRIPTION="A Gnome client for the Music Player Daemon."
+HOMEPAGE="http://sarine.nl/gmpc"
+SRC_URI="http://download.sarine.nl/${P}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ >=dev-libs/glib-2.10
+ >=gnome-base/libglade-2.3
+ gnome? ( >=gnome-base/gnome-vfs-2.6 )
+ session? ( x11-libs/libSM )
+ dev-perl/XML-Parser
+ >=media-libs/libmpd-0.14.0
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_enable session sm) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+}
+
+DOCS="AUTHORS ChangeLog NEWS README"
+