summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-02-25 19:07:48 +0000
committerSamuli Suominen <drac@gentoo.org>2007-02-25 19:07:48 +0000
commitf20dc52f009b15e94b5ab1d76db5676f34739ec3 (patch)
tree02e40bfa59203e49356d06e8ce6250e006ec5e7b /media-sound/exaile
parentminorsyn (diff)
downloadgentoo-2-f20dc52f009b15e94b5ab1d76db5676f34739ec3.tar.gz
gentoo-2-f20dc52f009b15e94b5ab1d76db5676f34739ec3.tar.bz2
gentoo-2-f20dc52f009b15e94b5ab1d76db5676f34739ec3.zip
Fix a regression from 0.2.8 which effected unicode filenames. Thanks to #gentoo.fi on IRCnet network for reporting.
(Portage version: 2.1.2-r11)
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/ChangeLog8
-rw-r--r--media-sound/exaile/exaile-0.2.9_beta1-r1.ebuild74
-rw-r--r--media-sound/exaile/files/digest-exaile-0.2.9_beta1-r13
-rw-r--r--media-sound/exaile/files/exaile-0.2.9_beta1-unicode.patch77
4 files changed, 161 insertions, 1 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index d06e78bfd870..0ce7e0e47996 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/exaile
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.9 2007/02/25 12:24:48 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.10 2007/02/25 19:07:48 drac Exp $
+
+*exaile-0.2.9_beta1-r1 (25 Feb 2007)
+
+ 25 Feb 2007; Samuli Suominen <drac@gentoo.org>
+ +files/exaile-0.2.9_beta1-unicode.patch, +exaile-0.2.9_beta1-r1.ebuild:
+ Fix a regression from 0.2.8 which effected unicode filenames.
25 Feb 2007; Samuli Suominen <drac@gentoo.org> exaile-0.2.9_beta1.ebuild:
Remove USE fam and gamin dep because it's not used.
diff --git a/media-sound/exaile/exaile-0.2.9_beta1-r1.ebuild b/media-sound/exaile/exaile-0.2.9_beta1-r1.ebuild
new file mode 100644
index 000000000000..7ecb1bf5e67c
--- /dev/null
+++ b/media-sound/exaile/exaile-0.2.9_beta1-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.9_beta1-r1.ebuild,v 1.1 2007/02/25 19:07:48 drac Exp $
+
+inherit eutils python toolchain-funcs
+
+MY_P=${PN}_${PV} ; MY_P=${MY_P/_beta1/b}
+
+DESCRIPTION="a media player aiming to be similar to KDE's AmaroK, but for GTK"
+HOMEPAGE="http://www.exaile.org/"
+SRC_URI="http://www.exaile.org/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aac alsa cdaudio flac gnome ipod libnotify libsexy mad musepack ogg
+ oss serpentine streamripper vorbis"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=dev-python/pygtk-2.8.6
+ >=dev-python/pysqlite-2
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-good-0.10
+ >=media-plugins/gst-plugins-gnomevfs-0.10
+ >=dev-python/gst-python-0.10
+ >=media-libs/mutagen-1.6
+ dev-python/elementtree
+ dev-python/dbus-python
+ alsa? ( >=media-plugins/gst-plugins-alsa-0.10 )
+ oss? ( >=media-plugins/gst-plugins-oss-0.10 )
+ mad? ( >=media-plugins/gst-plugins-mad-0.10 )
+ ogg? ( >=media-plugins/gst-plugins-ogg-0.10 )
+ vorbis? ( >=media-plugins/gst-plugins-vorbis-0.10 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.10 )
+ aac? ( >=media-plugins/gst-plugins-faad-0.10 )
+ libnotify? ( dev-python/notify-python )
+ libsexy? ( dev-python/sexy-python )
+ musepack? ( >=media-plugins/gst-plugins-musepack-0.10 )
+ gnome? ( dev-python/gnome-python-extras
+ media-plugins/gst-plugins-gconf )
+ ipod? ( >=media-libs/libgpod-0.3.2-r1
+ >=media-plugins/gst-plugins-faad-0.10 )
+ cdaudio? ( media-plugins/gst-plugins-cdparanoia
+ dev-python/cddb-py )
+ serpentine? ( app-cdr/serpentine )
+ streamripper? ( media-sound/streamripper )
+ gnome-base/librsvg"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use ipod && ! built_with_use media-libs/libgpod python ; then
+ eerror "libgpod has to be built with python support"
+ die "libgpod python use-flag not set"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.2.8-strip.patch
+ epatch "${FILESDIR}"/${P}-unicode.patch
+ python_version
+ sed -i -e "s:python2.4:python${PYVER}:" mmkeys/Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/media-sound/exaile/files/digest-exaile-0.2.9_beta1-r1 b/media-sound/exaile/files/digest-exaile-0.2.9_beta1-r1
new file mode 100644
index 000000000000..2bae28bad51b
--- /dev/null
+++ b/media-sound/exaile/files/digest-exaile-0.2.9_beta1-r1
@@ -0,0 +1,3 @@
+MD5 145418e89b621df838b9936effcda703 exaile_0.2.9b.tar.gz 789660
+RMD160 e26d4fbb6c265026d71c80d6754deacbed57da01 exaile_0.2.9b.tar.gz 789660
+SHA256 e21eb72f5048755137117c1e720bee8a3eaf7aaf707c90e5e8308ee56f2e8059 exaile_0.2.9b.tar.gz 789660
diff --git a/media-sound/exaile/files/exaile-0.2.9_beta1-unicode.patch b/media-sound/exaile/files/exaile-0.2.9_beta1-unicode.patch
new file mode 100644
index 000000000000..89acf190b923
--- /dev/null
+++ b/media-sound/exaile/files/exaile-0.2.9_beta1-unicode.patch
@@ -0,0 +1,77 @@
+Index: xl/media/__init__.py
+===================================================================
+--- xl/media/__init__.py (revision 2146)
++++ xl/media/__init__.py (working copy)
+@@ -117,7 +117,7 @@
+
+ # This would be more nicely written using conditional expressions
+ # but that is Python 2.5 only
+- if type(title) is unicode:
++ if type(title) is unicode:
+ self._title = title
+ else:
+ self._title = unicode(title, encoding)
+Index: xl/player.py
+===================================================================
+--- xl/player.py (revision 2146)
++++ xl/player.py (working copy)
+@@ -302,11 +302,11 @@
+ self.on_sync_message))
+
+ if '://' not in uri:
+- if not os.path.isfile(uri):
++ if not os.path.isfile(uri.encode('latin1')):
+ raise Exception('Specified file does not exist')
+
+ uri = 'file://%s' % uri
+- self.playbin.set_property('uri', uri)
++ self.playbin.set_property('uri', uri.encode('latin1'))
+
+ self.playbin.set_state(gst.STATE_PLAYING)
+
+Index: xl/panels.py
+===================================================================
+--- xl/panels.py (revision 2146)
++++ xl/panels.py (working copy)
+@@ -378,8 +378,8 @@
+ loc = ["device_%s://%s" % (driver_name,
+ urllib.quote(l.loc)) for l in loc]
+ else:
+- loc = [urllib.quote(str(l.loc)) for l in loc]
+-
++ loc = [urllib.quote(l.loc.encode('latin1')) for l in loc]
++
+ selection.set_uris(loc)
+
+ def append_recursive(self, iter, add):
+@@ -2721,7 +2721,7 @@
+ """
+
+ songs = self.get_selected_songs()
+- uris = [song.loc for song in songs]
++ uris = [urllib.quote(song.loc.encode('latin1')) for song in songs]
+
+ sel.set_uris(uris)
+
+Index: xl/trackslist.py
+===================================================================
+--- xl/trackslist.py (revision 2146)
++++ xl/trackslist.py (working copy)
+@@ -153,7 +153,7 @@
+ # first, check to see if they dropped a folder
+ copy = loc[:]
+ for l in copy:
+- l = urllib.unquote(l)
++ l = urllib.unquote_plus(l)
+ if os.path.isdir(l.replace("file://", "")):
+ # in this case, it is a folder
+ for root, dirs, files in os.walk(l.replace("file://", '')):
+@@ -174,7 +174,7 @@
+
+ for l in loc:
+ l = l.replace("file://", "")
+- l = urllib.unquote(l)
++ l = urllib.unquote_plus(l)
+ m = re.search(r'^device_(\w+)://', l)
+ if m:
+ song = self.exaile.device_panel.get_song(l)