summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-10-18 17:26:02 +0000
committerSamuli Suominen <drac@gentoo.org>2007-10-18 17:26:02 +0000
commit9f80640e3d900b57d46e5cd3be6f963b307250df (patch)
tree28b0218ac2699d2aceab392875b613d5a180fcac /media-sound/exaile
parentWeekly version bump <http://my.opera.com/desktopteam/blog/2007/10/18/a-snapsh... (diff)
downloadgentoo-2-9f80640e3d900b57d46e5cd3be6f963b307250df.tar.gz
gentoo-2-9f80640e3d900b57d46e5cd3be6f963b307250df.tar.bz2
gentoo-2-9f80640e3d900b57d46e5cd3be6f963b307250df.zip
Version bump to final release.
(Portage version: 2.1.3.14)
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/ChangeLog7
-rw-r--r--media-sound/exaile/exaile-0.2.11.ebuild (renamed from media-sound/exaile/exaile-0.2.11_beta.ebuild)53
-rw-r--r--media-sound/exaile/files/digest-exaile-0.2.113
-rw-r--r--media-sound/exaile/files/digest-exaile-0.2.11_beta3
4 files changed, 30 insertions, 36 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index ae15c6228721..e2a34e420ba3 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/exaile
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.28 2007/09/23 16:07:20 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.29 2007/10/18 17:26:02 drac Exp $
+
+*exaile-0.2.11 (18 Oct 2007)
+
+ 18 Oct 2007; Samuli Suominen <drac@gentoo.org> +exaile-0.2.11.ebuild:
+ Version bump to final release.
23 Sep 2007; Samuli Suominen <drac@gentoo.org> exaile-0.2.11_beta.ebuild:
Add USE equalizer for gst-plugins-bad.
diff --git a/media-sound/exaile/exaile-0.2.11_beta.ebuild b/media-sound/exaile/exaile-0.2.11.ebuild
index 3ba9531c3d3a..783450c9c9dc 100644
--- a/media-sound/exaile/exaile-0.2.11_beta.ebuild
+++ b/media-sound/exaile/exaile-0.2.11.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.11_beta.ebuild,v 1.2 2007/09/23 16:07:20 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.11.ebuild,v 1.1 2007/10/18 17:26:02 drac Exp $
inherit eutils fdo-mime multilib python
-GVER="0.10"
+GVER=0.10
-MY_P=${PN}_${PV/_beta/b}
+MY_P=${PN}_${PV}
DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
HOMEPAGE="http://www.exaile.org"
@@ -15,20 +15,19 @@ SRC_URI="http://www.exaile.org/files/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="aac alsa cdparanoia equalizer flac gnome ipod libnotify libsexy mad musepack ogg
- oss vorbis"
+IUSE="aac alsa cdparanoia equalizer flac gnome ipod libnotify libsexy
+ mad musepack nls ogg oss vorbis"
-RDEPEND=">=dev-python/pygtk-2.8.6
- || ( >=dev-lang/python-2.5 >=dev-python/pysqlite-2.3.4-r1 )
+RDEPEND="dev-python/dbus-python
>=media-libs/mutagen-1.6
+ >=dev-python/pygtk-2.10
+ || ( >=dev-lang/python-2.5 >=dev-python/pysqlite-2.3.4-r1 )
|| ( >=dev-lang/python-2.5 dev-python/elementtree )
- dev-python/dbus-python
libnotify? ( dev-python/notify-python )
libsexy? ( dev-python/sexy-python )
gnome? ( >=dev-python/gnome-python-extras-2.14.2-r1
>=media-plugins/gst-plugins-gconf-${GVER}
>=media-plugins/gst-plugins-gnomevfs-${GVER} )
- >=media-libs/gstreamer-${GVER}
>=media-libs/gst-plugins-good-${GVER}
equalizer? ( >=media-libs/gst-plugins-bad-0.10.5 )
>=dev-python/gst-python-${GVER}
@@ -44,41 +43,31 @@ RDEPEND=">=dev-python/pygtk-2.8.6
dev-python/cddb-py )
ipod? ( >=media-libs/libgpod-0.4
>=media-plugins/gst-plugins-faad-${GVER} )"
-DEPEND=""
-
-S="${WORKDIR}/${MY_P}"
+DEPEND="nls? ( dev-util/intltool sys-devel/gettext )"
pkg_setup() {
- if use ipod && ! built_with_use media-libs/libgpod python ; then
- eerror "libgpod has to be built with python support"
- die "libgpod python use-flag not set"
+ local fail_a="Re-emerge media-libs/libgpod with USE python."
+ local fail_b="Re-emerge dev-lang/python with USE sqlite."
+
+ if use ipod && ! built_with_use media-libs/libgpod python; then
+ eerror "${fail_a}"
+ die "${fail_a}"
fi
if ! has_version ">=dev-python/pysqlite-2.3.4-r1"; then
if ! built_with_use ">=dev-lang/python-2.5" sqlite; then
- eerror "You need to compile dev-lang/python with USE sqlite, or"
- eerror "install >=dev-python/pysqlite-2.3.4-r1."
- die "python 2.5 or up with sqlite support or pysqlite 2.3.5 or up required."
- fi
- fi
-
- if use gnome; then
- if ! built_with_use dev-python/gnome-python-extras xulrunner; then
- if ! built_with_use dev-python/gnome-python-extras firefox; then
- if ! built_with_use dev-python/gnome-python-extras seamonkey; then
- ewarn "In order to enable extra features provided by gtkmozembed,"
- ewarn "you have to re-emerge gnome-python-extras with"
- ewarn "xulrunner, firefox or seamonkey USE flag."
- epause
- fi
- fi
+ eerror "${fail_b}"
+ die "${fail_b}"
fi
fi
}
src_compile() {
emake mmkeys.so || die "emake mmkeys.so failed."
- emake translations || die "emake translations failed."
+
+ if use nls; then
+ emake translations || die "emake translations failed."
+ fi
}
src_install() {
diff --git a/media-sound/exaile/files/digest-exaile-0.2.11 b/media-sound/exaile/files/digest-exaile-0.2.11
new file mode 100644
index 000000000000..92ac2f5b2c94
--- /dev/null
+++ b/media-sound/exaile/files/digest-exaile-0.2.11
@@ -0,0 +1,3 @@
+MD5 3dd3aa70f28f92aea496c5191cb5ce64 exaile_0.2.11.tar.gz 6241496
+RMD160 4e68de57bf2ad9d11b99f7e1d193d742bd0b61dc exaile_0.2.11.tar.gz 6241496
+SHA256 ca5decfc78a9a3dbd0beaac85e6f35057ea28b7a1159656f344d9ec376855dd0 exaile_0.2.11.tar.gz 6241496
diff --git a/media-sound/exaile/files/digest-exaile-0.2.11_beta b/media-sound/exaile/files/digest-exaile-0.2.11_beta
deleted file mode 100644
index 20ef193a4dfc..000000000000
--- a/media-sound/exaile/files/digest-exaile-0.2.11_beta
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 5baf65bf40df68218c9aa7887bc807ca exaile_0.2.11b.tar.gz 651764
-RMD160 edc4c609afa4ee1e86231590a63ab82326d8f424 exaile_0.2.11b.tar.gz 651764
-SHA256 7acd651002c49b6301ee83af479029aa1267f79705b9347c66e6eb043e861119 exaile_0.2.11b.tar.gz 651764