summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-03-07 12:08:34 +0000
committerMarinus Schraal <foser@gentoo.org>2004-03-07 12:08:34 +0000
commitdf8bb5faf08188668831206a8b37ea5db4819bfa (patch)
tree817bc3dabeef03d7406dc09b6190ca630edc91f5 /media-sound/esound
parentAdded "before netmount" to the initialization script so that network filesyst... (diff)
downloadgentoo-2-df8bb5faf08188668831206a8b37ea5db4819bfa.tar.gz
gentoo-2-df8bb5faf08188668831206a8b37ea5db4819bfa.tar.bz2
gentoo-2-df8bb5faf08188668831206a8b37ea5db4819bfa.zip
new release
Diffstat (limited to 'media-sound/esound')
-rw-r--r--media-sound/esound/esound-0.2.33.ebuild (renamed from media-sound/esound/esound-0.2.31.ebuild)47
-rw-r--r--media-sound/esound/files/digest-esound-0.2.311
-rw-r--r--media-sound/esound/files/digest-esound-0.2.331
3 files changed, 23 insertions, 26 deletions
diff --git a/media-sound/esound/esound-0.2.31.ebuild b/media-sound/esound/esound-0.2.33.ebuild
index 9e981ded32bd..3feb491b4b08 100644
--- a/media-sound/esound/esound-0.2.31.ebuild
+++ b/media-sound/esound/esound-0.2.33.ebuild
@@ -1,40 +1,47 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.31.ebuild,v 1.5 2004/03/01 05:37:13 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.33.ebuild,v 1.1 2004/03/07 12:08:34 foser Exp $
-IUSE="tcpd alsa"
-
-inherit libtool gnome.org
+inherit libtool gnome.org eutils
DESCRIPTION="The Enlightened Sound Daemon"
-
HOMEPAGE="http://www.tux.org/~ricdude/EsounD.html"
-SLOT="0"
+
LICENSE="GPL-2 LGPL-2"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~amd64"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
+IUSE="tcpd alsa ipv6"
DEPEND=">=media-libs/audiofile-0.1.5
alsa? ( >=media-libs/alsa-lib-0.5.10b )
tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
-src_compile() {
- elibtoolize
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.2.32-amd64.patch
+
+}
- local myconf=""
- use tcpd && myconf="${myconf} --with-libwrap" \
- || myconf="${myconf} --without-libwrap"
+src_compile() {
- use alsa && myconf="${myconf} --enable-alsa" \
- || myconf="${myconf} --enable-alsa=no"
+ elibtoolize
econf \
+ `use_with tcpd libwrap` \
+ `use_enable alsa` \
+ `use_enable ipv6` \
--sysconfdir=/etc/esd \
- ${myconf} || die
+ || die
make || die
+
}
src_install() {
+
einstall \
sysconfdir=${D}/etc/esd \
|| die
@@ -55,13 +62,3 @@ src_install() {
doexe ${T}/esound
}
-
-pkg_postinst() {
- # rebuild init deps to include deps on esound
- /etc/init.d/depscan.sh
-}
-
-pkg_postrm() {
- # rebuild init deps to remove deps on esound
- /etc/init.d/depscan.sh
-}
diff --git a/media-sound/esound/files/digest-esound-0.2.31 b/media-sound/esound/files/digest-esound-0.2.31
deleted file mode 100644
index 7f9d67e7d36d..000000000000
--- a/media-sound/esound/files/digest-esound-0.2.31
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5b8349f7dd58349e626e1701f2a420af esound-0.2.31.tar.bz2 386552
diff --git a/media-sound/esound/files/digest-esound-0.2.33 b/media-sound/esound/files/digest-esound-0.2.33
new file mode 100644
index 000000000000..9b857d3dc89d
--- /dev/null
+++ b/media-sound/esound/files/digest-esound-0.2.33
@@ -0,0 +1 @@
+MD5 a23262b09f82497deccf7df4b871115d esound-0.2.33.tar.bz2 347932