summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-09 10:26:59 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-09 10:26:59 +0000
commit92aa49df5fbb94f611714048bc4f5764eb790368 (patch)
tree8733810875a5a5e23fac4fb5667964a5ef22d824 /media-sound/esound
parent*** empty log message *** (diff)
downloadgentoo-2-92aa49df5fbb94f611714048bc4f5764eb790368.tar.gz
gentoo-2-92aa49df5fbb94f611714048bc4f5764eb790368.tar.bz2
gentoo-2-92aa49df5fbb94f611714048bc4f5764eb790368.zip
*** empty log message ***
Diffstat (limited to 'media-sound/esound')
-rw-r--r--media-sound/esound/esound-0.2.22.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/esound/esound-0.2.22.ebuild b/media-sound/esound/esound-0.2.22.ebuild
new file mode 100644
index 000000000000..92284cf7b5b6
--- /dev/null
+++ b/media-sound/esound/esound-0.2.22.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.22.ebuild,v 1.1 2001/03/09 10:26:59 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="esound"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/esound/${A}
+ ftp://download.sourceforge.net/pub/mirrors/gnome/stable/sources/esound/${A}"
+HOMEPAGE="http://www.tux.org/~ricdude/EsounD.html"
+
+DEPEND="virtual/glibc
+ >=media-libs/alsa-lib-0.5.9
+ >=media-libs/audiofile-0.1.9
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+
+RDEPEND="virtual/glibc
+ >=media-libs/alsa-lib-0.5.9
+ >=media-libs/audiofile-0.1.9"
+
+src_compile() {
+
+ local myconf
+ if [ "`use tcpd`" ]
+ then
+ myconf="--with-libwrap"
+ else
+ myconf="--without-libwrap"
+ fi
+ try ./configure --host=${CHOST} --prefix=/usr \
+ --sysconfdir=/etc/esd $myconf
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr sysconfdir=${D}/etc/esd install
+ dodoc AUTHORS COPYING* ChangeLog README TODO
+ dodoc NEWS TIPS
+ dodoc docs/esound.ps
+ docinto html
+ dodoc docs/html/*.html docs/html/*.css
+ docinto html/stylesheet-images
+ dodoc docs/html/stylesheet-images/*.gif
+}
+
+
+
+
+
+