summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Brabec <utx@gentoo.org>2003-05-29 22:37:07 +0000
committerStanislav Brabec <utx@gentoo.org>2003-05-29 22:37:07 +0000
commitadac38abd4bf7a04105843204b82e1a0fcf70bef (patch)
tree347ea5ec9ac110e94377e799ec7f5cc3c44e968b /media-sound/esound/esound-0.2.29-r1.ebuild
parentALSA fix, added init scripts (diff)
downloadgentoo-2-adac38abd4bf7a04105843204b82e1a0fcf70bef.tar.gz
gentoo-2-adac38abd4bf7a04105843204b82e1a0fcf70bef.tar.bz2
gentoo-2-adac38abd4bf7a04105843204b82e1a0fcf70bef.zip
ALSA fix, added init scripts
Diffstat (limited to 'media-sound/esound/esound-0.2.29-r1.ebuild')
-rw-r--r--media-sound/esound/esound-0.2.29-r1.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/esound/esound-0.2.29-r1.ebuild b/media-sound/esound/esound-0.2.29-r1.ebuild
new file mode 100644
index 000000000000..0ead81b4b06c
--- /dev/null
+++ b/media-sound/esound/esound-0.2.29-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.29-r1.ebuild,v 1.1 2003/05/29 22:36:51 utx Exp $
+
+IUSE="tcpd alsa"
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The Enlightened Sound Daemon"
+SRC_URI="mirror://gnome/2.0.1/sources/${PN}/${P}.tar.bz2"
+
+HOMEPAGE="http://www.tux.org/~ricdude/EsounD.html"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc ppc alpha"
+
+DEPEND=" >=media-libs/audiofile-0.1.9
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/esound-0.2.29-alsa-period.diff
+}
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use tcpd && myconf="${myconf} --with-libwrap" \
+ || myconf="${myconf} --without-libwrap"
+
+ use alsa && myconf="${myconf} --enable-alsa" \
+ || myconf="${myconf} --enable-alsa=no"
+
+ econf \
+ --sysconfdir=/etc/esd \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ einstall \
+ sysconfdir=${D}/etc/esd \
+ || die
+
+ dodoc AUTHORS COPYING* ChangeLog README TODO NEWS TIPS
+ dodoc docs/esound.ps
+
+ dohtml -r docs/html
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/esound.conf.d esound
+
+ exeinto /etc/init.d
+ use tcpd && extradepend=" portmap" \
+ || extradepend=""
+ sed "s/@extradepend@/$extradepend/" <${FILESDIR}/esound.init.d >${T}/esound
+ doexe ${T}/esound
+
+}
+
+pkg_postinst() {
+ # rebuild init deps to include deps on esound
+ /etc/init.d/depscan.sh
+}
+
+pkg_postrm() {
+ # rebuild init deps to remove deps on esound
+ /etc/init.d/depscan.sh
+}