summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2011-04-23 22:22:48 +0000
committerChristian Faulhammer <fauli@gentoo.org>2011-04-23 22:22:48 +0000
commit9924e3549b3d25f3168ed232010ef703c40b618c (patch)
tree41ebc03cecbc008c8ac5f9000a0feedeb81b11fe /media-sound/cmus
parentFix configure handling of variables as pointed out by Johannes Weißl via email (diff)
downloadgentoo-2-9924e3549b3d25f3168ed232010ef703c40b618c.tar.gz
gentoo-2-9924e3549b3d25f3168ed232010ef703c40b618c.tar.bz2
gentoo-2-9924e3549b3d25f3168ed232010ef703c40b618c.zip
Fix detection of mp4.h as reported by Johannes Weißl via email
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'media-sound/cmus')
-rw-r--r--media-sound/cmus/ChangeLog6
-rw-r--r--media-sound/cmus/cmus-2.3.4.ebuild11
-rw-r--r--media-sound/cmus/files/cmus-2.3.4-detect_mp4.h.patch36
3 files changed, 49 insertions, 4 deletions
diff --git a/media-sound/cmus/ChangeLog b/media-sound/cmus/ChangeLog
index f300da1c6367..8a92ea8acbdf 100644
--- a/media-sound/cmus/ChangeLog
+++ b/media-sound/cmus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/cmus
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cmus/ChangeLog,v 1.43 2011/04/23 22:09:02 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cmus/ChangeLog,v 1.44 2011/04/23 22:22:48 fauli Exp $
+
+ 23 Apr 2011; Christian Faulhammer <fauli@gentoo.org> cmus-2.3.4.ebuild,
+ +files/cmus-2.3.4-detect_mp4.h.patch:
+ Fix detection of mp4.h as reported by Johannes Weißl via email
23 Apr 2011; Christian Faulhammer <fauli@gentoo.org> cmus-2.3.4.ebuild:
Fix configure handling of variables as pointed out by Johannes Weißl via
diff --git a/media-sound/cmus/cmus-2.3.4.ebuild b/media-sound/cmus/cmus-2.3.4.ebuild
index db9ac5b20aa5..af6c5651bcea 100644
--- a/media-sound/cmus/cmus-2.3.4.ebuild
+++ b/media-sound/cmus/cmus-2.3.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cmus/cmus-2.3.4.ebuild,v 1.3 2011/04/23 22:09:02 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cmus/cmus-2.3.4.ebuild,v 1.4 2011/04/23 22:22:48 fauli Exp $
-EAPI=2
-inherit multilib
+EAPI=4
+inherit eutils multilib
MY_P=${PN}-v${PV}
@@ -44,6 +44,11 @@ my_config() {
myconf="${myconf} ${2}=${value}"
}
+src_prepare() {
+ # reported upstream
+ epatch "${FILESDIR}"/${P}-detect_mp4.h.patch
+}
+
src_configure() {
local debuglevel=1 myconf="CONFIG_ARTS=n CONFIG_SUN=n"
diff --git a/media-sound/cmus/files/cmus-2.3.4-detect_mp4.h.patch b/media-sound/cmus/files/cmus-2.3.4-detect_mp4.h.patch
new file mode 100644
index 000000000000..6d0d7228ef89
--- /dev/null
+++ b/media-sound/cmus/files/cmus-2.3.4-detect_mp4.h.patch
@@ -0,0 +1,36 @@
+From b397bbb328adf55a39ba0991d8d8dc8cab268c21 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Johannes=20Wei=C3=9Fl?= <jargon@molb.org>
+Date: Mon, 18 Apr 2011 02:26:37 +0200
+Subject: [PATCH] configure: fix detection of mp4.h
+
+mp4.h is just assumed to be there if mp4v2/mp4v2.h could not be found.
+This could be a fix for Gentoo Bug 323975 [1].
+
+[1] http://bugs.gentoo.org/show_bug.cgi?id=323975
+---
+ configure | 9 +++++++--
+ 1 files changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/configure b/configure
+index dee8b01..1ecad56 100755
+--- a/configure
++++ b/configure
+@@ -284,8 +284,13 @@ check_roar()
+
+ check_mp4()
+ {
+- check_header mp4v2/mp4v2.h
+- USE_MPEG4IP=$?
++ USE_MPEG4IP=1
++ if check_header mp4v2/mp4v2.h
++ then
++ USE_MPEG4IP=0
++ else
++ check_header mp4.h || return $?
++ fi
+ check_header neaacdec.h &&
+ check_library MP4 "" "-lmp4v2 -lfaad -lm"
+ return $?
+--
+1.7.4.4
+