summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-21 23:06:09 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-21 23:06:09 +0000
commitfc83bf31daf610331474dede207c788953cd1136 (patch)
treeec11ab4e357af46d7b268125d5a90e4cbc0ad42b /media-sound/cdparanoia
parentarm/s390/sh stable (diff)
downloadgentoo-2-fc83bf31daf610331474dede207c788953cd1136.tar.gz
gentoo-2-fc83bf31daf610331474dede207c788953cd1136.tar.bz2
gentoo-2-fc83bf31daf610331474dede207c788953cd1136.zip
Add new revision, removing the SG_IO patches, that caused bugs #133145, #133150 and #138894. As upstream is not dead as it could have seemed, better stick as much as possible with upstream sources (although the current ones are also quite a bit patched). When new alpha will be added, patches *have to be* sent upstream.
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'media-sound/cdparanoia')
-rw-r--r--media-sound/cdparanoia/ChangeLog12
-rw-r--r--media-sound/cdparanoia/cdparanoia-3.9.8-r5.ebuild77
-rw-r--r--media-sound/cdparanoia/files/digest-cdparanoia-3.9.8-r56
3 files changed, 94 insertions, 1 deletions
diff --git a/media-sound/cdparanoia/ChangeLog b/media-sound/cdparanoia/ChangeLog
index c65b43c993a6..cbc4b79972dd 100644
--- a/media-sound/cdparanoia/ChangeLog
+++ b/media-sound/cdparanoia/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-sound/cdparanoia
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cdparanoia/ChangeLog,v 1.47 2006/09/22 22:00:54 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cdparanoia/ChangeLog,v 1.48 2006/10/21 23:06:09 flameeyes Exp $
+
+*cdparanoia-3.9.8-r5 (21 Oct 2006)
+
+ 21 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +cdparanoia-3.9.8-r5.ebuild:
+ Add new revision, removing the SG_IO patches, that caused bugs #133145,
+ #133150 and #138894. As upstream is not dead as it could have seemed, better
+ stick as much as possible with upstream sources (although the current ones
+ are also quite a bit patched). When new alpha will be added, patches *have
+ to be* sent upstream.
22 Sep 2006; <ticho@gentoo.org> cdparanoia-3.9.8-r4.ebuild:
Fix parallel build, bug #136128.
diff --git a/media-sound/cdparanoia/cdparanoia-3.9.8-r5.ebuild b/media-sound/cdparanoia/cdparanoia-3.9.8-r5.ebuild
new file mode 100644
index 000000000000..5c3ca8445911
--- /dev/null
+++ b/media-sound/cdparanoia/cdparanoia-3.9.8-r5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cdparanoia/cdparanoia-3.9.8-r5.ebuild,v 1.1 2006/10/21 23:06:09 flameeyes Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="2.1"
+
+inherit eutils flag-o-matic libtool toolchain-funcs versionator autotools
+
+MY_P=${PN}-III-alpha$(get_version_component_range 2-3)
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="an advanced CDDA reader with error correction"
+HOMEPAGE="http://www.xiph.org/paranoia/"
+SRC_URI="http://www.xiph.org/paranoia/download/${MY_P}.src.tgz
+ mirror://gentoo/${P}-fbsd-2.patch.bz2"
+
+IUSE="kernel_linux"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # cdda_paranoia.h should include cdda_interface_h, else most configure
+ # scripts testing for support fails (gnome-vfs, etc).
+ epatch "${FILESDIR}/${P}-include-cdda_interface_h.patch"
+ epatch "${FILESDIR}/${P}-toc.patch"
+ epatch "${FILESDIR}/${P}-identify_crash.patch"
+ epatch "${FILESDIR}/${PV}-gcc34.patch"
+
+ # if libdir is specified, cdparanoia causes sandbox violations, and using
+ # einstall doesnt work around it. so lets patch in DESTDIR support
+ epatch "${FILESDIR}/${P}-use-destdir.patch"
+
+ epatch "${FILESDIR}/${P}-respectflags-pio.patch"
+
+ epatch "${DISTDIR}/${P}-fbsd-2.patch.bz2"
+ # Fix makefiles for parallel make
+ epatch "${FILESDIR}/${P}-parallel-fpic-fbsd.patch"
+
+ # Use directly the same exact patch as flex as it works
+ epatch "${FILESDIR}/flex-configure-LANG.patch"
+
+ # Let portage handle the stripping of binaries
+ sed -i -e "/strip cdparanoia/d" Makefile.in
+
+ # Fix Makefiles for parallel building. Bug #136128.
+ sed -i \
+ -e "s/^lib: $/lib: \$(OFILES)/" \
+ -e "s/^slib: $/slib: \$(OFILES)/" \
+ -e "/\$(MAKE) lessmessy$/d" \
+ interface/Makefile.in paranoia/Makefile.in
+
+ mv configure.guess config.guess
+ mv configure.sub config.sub
+ sed -i -e '/configure.\(guess\|sub\)/d' "${S}"/configure.in
+
+ eautoconf
+ elibtoolize
+}
+
+src_compile() {
+ tc-export CC AR RANLIB
+ append-flags -I"${S}/interface"
+
+ econf || die
+ emake OPT="${CFLAGS}" || die
+}
+
+src_install() {
+ dodir /usr/{bin,lib,include} /usr/share/man/man1
+ emake DESTDIR="${D}" install || die
+ dodoc FAQ.txt README
+}
diff --git a/media-sound/cdparanoia/files/digest-cdparanoia-3.9.8-r5 b/media-sound/cdparanoia/files/digest-cdparanoia-3.9.8-r5
new file mode 100644
index 000000000000..f0a0b9affdc0
--- /dev/null
+++ b/media-sound/cdparanoia/files/digest-cdparanoia-3.9.8-r5
@@ -0,0 +1,6 @@
+MD5 cf4ed5a2123a323b20d7442d17f00009 cdparanoia-3.9.8-fbsd-2.patch.bz2 7345
+RMD160 217902fa5f455b2388a3568420aaea2d1fd6e219 cdparanoia-3.9.8-fbsd-2.patch.bz2 7345
+SHA256 a3e09610ddb5630e9f4a951eb0d96f84fb80e320c8f9cc71fe312f839c7f198c cdparanoia-3.9.8-fbsd-2.patch.bz2 7345
+MD5 7218e778b5970a86c958e597f952f193 cdparanoia-III-alpha9.8.src.tgz 116591
+RMD160 d9225165f83b5386c58db263d6918a7006df1481 cdparanoia-III-alpha9.8.src.tgz 116591
+SHA256 1b79fae1aedc692f87d1344410f5c6b666961afccdc78bc5c4c257c450dfa008 cdparanoia-III-alpha9.8.src.tgz 116591