summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-03 19:37:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-03 19:37:08 +0000
commit12c7a5d7ae711baf94b046a530d5ce3f4eee9394 (patch)
tree96caf3f5976c723b8009b771e4829b89619cef71 /media-sound/bpmdetect
parentVersion bump (diff)
downloadgentoo-2-12c7a5d7ae711baf94b046a530d5ce3f4eee9394.tar.gz
gentoo-2-12c7a5d7ae711baf94b046a530d5ce3f4eee9394.tar.bz2
gentoo-2-12c7a5d7ae711baf94b046a530d5ce3f4eee9394.zip
Fix compile with GCC 4.4, and append correct fmodex library path in /opt wrt #252400.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/bpmdetect')
-rw-r--r--media-sound/bpmdetect/ChangeLog12
-rw-r--r--media-sound/bpmdetect/bpmdetect-0.6.1.ebuild24
-rw-r--r--media-sound/bpmdetect/files/bpmdetect-0.6.1-gcc44_and_fmodex_path.patch36
3 files changed, 58 insertions, 14 deletions
diff --git a/media-sound/bpmdetect/ChangeLog b/media-sound/bpmdetect/ChangeLog
index b184205b4d9c..7ef37a08ca57 100644
--- a/media-sound/bpmdetect/ChangeLog
+++ b/media-sound/bpmdetect/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for media-sound/bpmdetect
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/bpmdetect/ChangeLog,v 1.1 2008/12/21 17:00:36 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/bpmdetect/ChangeLog,v 1.2 2009/06/03 19:37:07 ssuominen Exp $
+
+ 03 Jun 2009; Samuli Suominen <ssuominen@gentoo.org>
+ bpmdetect-0.6.1.ebuild,
+ +files/bpmdetect-0.6.1-gcc44_and_fmodex_path.patch:
+ Fix compile with GCC 4.4, and append correct fmodex library path in /opt
+ wrt #252400.
*bpmdetect-0.6.1 (21 Dec 2008)
- 21 Dec 2008; <ssuominen@gentoo.org> +bpmdetect-0.6.1.ebuild:
+ 21 Dec 2008; Samuli Suominen <ssuominen@gentoo.org> +bpmdetect-0.6.1.ebuild:
Initial commit for bug 180878, thanks to Jürgen Prömer from
#gentoo-media, Freenode for helping out.
diff --git a/media-sound/bpmdetect/bpmdetect-0.6.1.ebuild b/media-sound/bpmdetect/bpmdetect-0.6.1.ebuild
index a0a3bc5c1efd..f9ad852b0373 100644
--- a/media-sound/bpmdetect/bpmdetect-0.6.1.ebuild
+++ b/media-sound/bpmdetect/bpmdetect-0.6.1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/bpmdetect/bpmdetect-0.6.1.ebuild,v 1.1 2008/12/21 17:00:36 ssuominen Exp $
-
-EAPI=1
+# $Header: /var/cvsroot/gentoo-x86/media-sound/bpmdetect/bpmdetect-0.6.1.ebuild,v 1.2 2009/06/03 19:37:07 ssuominen Exp $
+EAPI=2
inherit eutils multilib
DESCRIPTION="Automatic BPM detection utility"
@@ -12,31 +11,34 @@ SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="media-libs/taglib
media-libs/id3lib
- media-libs/fmod:1
+ >=media-libs/fmod-4.25.07-r1:1
x11-libs/qt-gui:4"
DEPEND="${RDEPEND}
+ sys-apps/sed
dev-util/scons
dev-util/pkgconfig"
S=${WORKDIR}/${PN}
-src_unpack() {
- unpack ${A}
- sed -i -e "s:-O2:${CXXFLAGS}:" "${S}"/src/SConscript || die "sed failed."
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44_and_fmodex_path.patch
+ sed -i -e "s:-O2:${CXXFLAGS}:" src/SConscript || die "sed failed"
}
+src_configure() { :; }
+
src_compile() {
export QTDIR="/usr/$(get_libdir)"
- scons prefix=/usr || die "scons failed."
+ scons prefix=/usr || die "scons failed"
}
src_install() {
- dobin build/${PN} || die "dobin failed."
+ dobin build/${PN} || die "dobin failed"
doicon src/${PN}-icon.png
domenu src/${PN}.desktop
dodoc authors readme todo
diff --git a/media-sound/bpmdetect/files/bpmdetect-0.6.1-gcc44_and_fmodex_path.patch b/media-sound/bpmdetect/files/bpmdetect-0.6.1-gcc44_and_fmodex_path.patch
new file mode 100644
index 000000000000..c29961645615
--- /dev/null
+++ b/media-sound/bpmdetect/files/bpmdetect-0.6.1-gcc44_and_fmodex_path.patch
@@ -0,0 +1,36 @@
+diff -ur bpmdetect.orig/src/main.cpp bpmdetect/src/main.cpp
+--- bpmdetect.orig/src/main.cpp 2008-05-01 12:50:18.000000000 +0300
++++ bpmdetect/src/main.cpp 2009-06-03 22:24:56.000000000 +0300
+@@ -20,6 +20,8 @@
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+
++#include <cstdio>
++
+ #ifndef NO_GUI
+ #ifdef USE_QT3
+ #include "dlgbpmdetect3.h"
+diff -ur bpmdetect.orig/src/SConscript bpmdetect/src/SConscript
+--- bpmdetect.orig/src/SConscript 2008-04-24 19:49:52.000000000 +0300
++++ bpmdetect/src/SConscript 2009-06-03 22:33:57.000000000 +0300
+@@ -234,7 +234,7 @@
+
+ env.Append(LIBS = ['id3', 'fmodex', 'z'])
+ env.Append(CPPPATH = ['.', '..', '../includes'])
+- env.Append(LIBPATH = ['.', '../libs'])
++ env.Append(LIBPATH = ['.', '../libs', '/opt/fmodex/api/lib'])
+ env['ISCONFIGURED']=1
+ # And finally save the options in the cache
+ opts.Save(cachefile, env)
+diff -ur bpmdetect.orig/src/track.cpp bpmdetect/src/track.cpp
+--- bpmdetect.orig/src/track.cpp 2008-04-25 22:33:18.000000000 +0300
++++ bpmdetect/src/track.cpp 2009-06-03 22:26:24.000000000 +0300
+@@ -20,6 +20,8 @@
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+
++#include <cstdio>
++
+ #include "track.h"
+ #include "trackfmod.h"
+ #include "BPMDetect.h"