summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-06-01 21:21:48 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-06-01 21:21:48 +0000
commite53629e46284ea83600ab1e61f68e26e7bc07a16 (patch)
tree33080da2d73251078f8bb368fd69ded248eef0ad /media-sound/beast
parentOld homepage no longer exists. RFC868 is the closest thing to a homepage left. (diff)
downloadgentoo-2-e53629e46284ea83600ab1e61f68e26e7bc07a16.tar.gz
gentoo-2-e53629e46284ea83600ab1e61f68e26e7bc07a16.tar.bz2
gentoo-2-e53629e46284ea83600ab1e61f68e26e7bc07a16.zip
Fix compilation with newer glib, bug #223291.
(Portage version: 2.1.5.2)
Diffstat (limited to 'media-sound/beast')
-rw-r--r--media-sound/beast/ChangeLog11
-rw-r--r--media-sound/beast/beast-0.7.1-r1.ebuild83
-rw-r--r--media-sound/beast/files/beast-0.7.1-configure.patch77
-rw-r--r--media-sound/beast/files/beast-0.7.1-glib.patch22
-rw-r--r--media-sound/beast/files/beast-0.7.1-noinstalltest.patch16
5 files changed, 207 insertions, 2 deletions
diff --git a/media-sound/beast/ChangeLog b/media-sound/beast/ChangeLog
index a0894c86579b..1869456da0f8 100644
--- a/media-sound/beast/ChangeLog
+++ b/media-sound/beast/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/beast
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/ChangeLog,v 1.30 2007/06/19 18:14:17 aballier Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/ChangeLog,v 1.31 2008/06/01 21:21:47 eva Exp $
+
+*beast-0.7.1-r1 (01 Jun 2008)
+
+ 01 Jun 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/beast-0.7.1-configure.patch, +files/beast-0.7.1-glib.patch,
+ files/beast-0.7.1-noinstalltest.patch, +beast-0.7.1-r1.ebuild:
+ Fix compilation with newer glib, bug #223291.
19 Jun 2007; Alexis Ballier <aballier@gentoo.org> -beast-0.6.4.ebuild,
-beast-0.6.5.ebuild, -beast-0.6.6.ebuild:
diff --git a/media-sound/beast/beast-0.7.1-r1.ebuild b/media-sound/beast/beast-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..79841c073e6c
--- /dev/null
+++ b/media-sound/beast/beast-0.7.1-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/beast-0.7.1-r1.ebuild,v 1.1 2008/06/01 21:21:47 eva Exp $
+
+inherit autotools eutils flag-o-matic fdo-mime
+
+IUSE="debug mad static"
+
+DESCRIPTION="BEAST - the Bedevilled Sound Engine"
+HOMEPAGE="http://beast.gtk.org"
+SRC_URI="ftp://beast.gtk.org/pub/beast/v${PV%.[0-9]}/${P}.tar.bz2
+ mirror://gentoo/${P}-guile-1.8.diff.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=x11-libs/gtk+-2.4.11
+ >=sys-libs/zlib-1.1.3
+ dev-scheme/guile
+ >=media-libs/libart_lgpl-2.3.8
+ >=gnome-base/libgnomecanvas-2.0
+ >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0
+ mad? ( media-sound/madplay )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/perl
+ media-libs/ladspa-cmt
+ media-libs/ladspa-sdk
+ >=dev-util/intltool-0.35"
+
+pkg_setup() {
+ if has_version =dev-scheme/guile-1.8*; then
+ local flags="deprecated"
+ built_with_use dev-scheme/guile ${flags} \
+ || die "guile must be built with \"${flags}\" use flags"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}/${P}-guile-1.8.diff"
+ epatch "${FILESDIR}/${P}-noinstalltest.patch"
+ epatch "${FILESDIR}/${P}-signalheader.patch"
+
+ # Remove G_DISABLE_DEPRECATED, bug #223291
+ epatch "${FILESDIR}/${P}-glib.patch"
+
+ epatch "${FILESDIR}/${P}-configure.patch"
+
+ eautoreconf
+ intltoolize --force || die "intltoolize failed"
+}
+
+src_compile() {
+ # avoid suid related security issues.
+ append-ldflags $(bindnow-flags)
+
+ #for some weird reasons there is no doxer in this release
+ econf $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ # dont install new mime files !
+ for i in subclasses XMLnamespaces aliases globs magic mime.cache\
+ audio/x-bsewave.xml audio/x-bse.xml; do
+ rm -f "${D}/usr/share/mime/${i}"
+ done
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
diff --git a/media-sound/beast/files/beast-0.7.1-configure.patch b/media-sound/beast/files/beast-0.7.1-configure.patch
new file mode 100644
index 000000000000..c22b92e0facf
--- /dev/null
+++ b/media-sound/beast/files/beast-0.7.1-configure.patch
@@ -0,0 +1,77 @@
+--- a/configure.in 2008-06-01 15:19:46.000000000 +0200
++++ b/configure.in 2008-06-01 15:27:45.000000000 +0200
+@@ -159,39 +159,33 @@
+ dnl # Define package requirements.
+ dnl #
+ dnl ## include acintltool.m4 to provide IT_PROG_INTLTOOL
+-builtin(include, acintltool.m4)dnl
+-AC_DEFUN([AC_I18N_REQUIREMENTS],
+-[
+- ALL_LINGUAS=`cat "$srcdir/po/LINGUAS" | grep -v '^#' | xargs echo -n `
+- AC_SUBST(ALL_LINGUAS)
+- AC_SUBST([CONFIG_STATUS_DEPENDENCIES], ['$(top_srcdir)/po/LINGUAS'])
+-
+- dnl # versioned BEAST gettext domain (po/)
+- BST_GETTEXT_DOMAIN=beast-v$BIN_VERSION # version without -rcZ
+- AC_SUBST(BST_GETTEXT_DOMAIN)
+- AC_DEFINE_UNQUOTED(BST_GETTEXT_DOMAIN, "$BST_GETTEXT_DOMAIN", [Versioned BEAST gettext domain])
+- GETTEXT_PACKAGE=$BST_GETTEXT_DOMAIN
+- AC_SUBST(GETTEXT_PACKAGE)
+-
+- dnl # locale directory for all domains
+- dnl # (AM_GLIB_DEFINE_LOCALEDIR() could do this if it would do AC_SUBST())
+- saved_prefix="$prefix"
+- saved_exec_prefix="$exec_prefix"
+- test "x$prefix" = xNONE && prefix=$ac_default_prefix
+- test "x$exec_prefix" = xNONE && exec_prefix=$prefix
+- if test "x$CATOBJEXT" = "x.mo" ; then
+- beastlocaledir=`eval echo "${libdir}/locale"`
+- else
+- beastlocaledir=`eval echo "${datadir}/locale"`
+- fi
+- exec_prefix="$saved_exec_prefix"
+- prefix="$saved_prefix"
+- AC_SUBST(beastlocaledir)
+-
+- dnl # do gettext checks and prepare for intltool
+- AM_GLIB_GNU_GETTEXT
+- IT_PROG_INTLTOOL
+-])
++IT_PROG_INTLTOOL([0.35.0])
++
++dnl # versioned BEAST gettext domain (po/)
++BST_GETTEXT_DOMAIN=beast-v$BIN_VERSION # version without -rcZ
++AC_SUBST(BST_GETTEXT_DOMAIN)
++AC_DEFINE_UNQUOTED(BST_GETTEXT_DOMAIN, "$BST_GETTEXT_DOMAIN", [Versioned BEAST gettext domain])
++GETTEXT_PACKAGE=$BST_GETTEXT_DOMAIN
++AC_SUBST(GETTEXT_PACKAGE)
++
++dnl # locale directory for all domains
++dnl # (AM_GLIB_DEFINE_LOCALEDIR() could do this if it would do AC_SUBST())
++saved_prefix="$prefix"
++saved_exec_prefix="$exec_prefix"
++test "x$prefix" = xNONE && prefix=$ac_default_prefix
++test "x$exec_prefix" = xNONE && exec_prefix=$prefix
++if test "x$CATOBJEXT" = "x.mo" ; then
++ beastlocaledir=`eval echo "${libdir}/locale"`
++else
++ beastlocaledir=`eval echo "${datadir}/locale"`
++fi
++exec_prefix="$saved_exec_prefix"
++prefix="$saved_prefix"
++AC_SUBST(beastlocaledir)
++
++dnl # do gettext checks and prepare for intltool
++AM_GLIB_GNU_GETTEXT
++
+ AC_DEFUN([AC_SFI_REQUIREMENTS],
+ [
+ dnl # check for GLib libs, libbirnet already provides gthread-2.0 and glib-2.0
+@@ -570,7 +564,6 @@
+ AC_BIRNET_REQUIREMENTS
+
+ # Check requirement sets
+-AC_I18N_REQUIREMENTS
+ AC_SFI_REQUIREMENTS
+ AC_BSE_REQUIREMENTS
+ AC_BSESCM_REQUIREMENTS
diff --git a/media-sound/beast/files/beast-0.7.1-glib.patch b/media-sound/beast/files/beast-0.7.1-glib.patch
new file mode 100644
index 000000000000..443c92b680a9
--- /dev/null
+++ b/media-sound/beast/files/beast-0.7.1-glib.patch
@@ -0,0 +1,22 @@
+--- beast-0.7.1.orig/bse/Makefile.am 2008-06-01 13:12:28.116708321 +0200
++++ beast-0.7.1/bse/Makefile.am 2008-06-01 13:12:40.000000000 +0200
+@@ -10,7 +10,7 @@
+ # need -I$(top_builddir) for <sfi/sficonfig.h>
+ # need -I$(srcdir) for "bseserver.h" in .genprc.c
+ # need -I. (builddir) for "bsecore.genidl.hh" in bsecore.cc
+-INCLUDES += -I$(top_srcdir) -I$(top_builddir) -I$(srcdir) -I. $(BSE_CFLAGS) -DG_DISABLE_DEPRECATED -DG_DISABLE_CONST_RETURNS
++INCLUDES += -I$(top_srcdir) -I$(top_builddir) -I$(srcdir) -I. $(BSE_CFLAGS) -DG_DISABLE_CONST_RETURNS
+ DEFS += $(strip \
+ $(patsubst %, -DG_LOG_DOMAIN=\"BSE\" -DBSE_COMPILATION, \
+ $(filter $(<F), $(bse_sources) $(bse_sources))) \
+--- beast-0.7.1.orig/bse/zintern/Makefile.am 2008-06-01 13:14:25.880028999 +0200
++++ beast-0.7.1/bse/zintern/Makefile.am 2008-06-01 13:14:38.000000000 +0200
+@@ -4,7 +4,7 @@
+ ## GNU Lesser General Public License version 2 or any later version.
+ include $(top_srcdir)/Makefile.decl
+
+-INCLUDES += -I$(top_srcdir) -I$(top_builddir) $(BSE_CFLAGS) -DG_DISABLE_DEPRECATED -DG_DISABLE_CONST_RETURNS
++INCLUDES += -I$(top_srcdir) -I$(top_builddir) $(BSE_CFLAGS) -DG_DISABLE_CONST_RETURNS
+
+ ZFILE_DEFS = $(strip \
+ wave-mono $(srcdir)/wave-mono.bse \
diff --git a/media-sound/beast/files/beast-0.7.1-noinstalltest.patch b/media-sound/beast/files/beast-0.7.1-noinstalltest.patch
index 7c0f65267dd6..524feb489717 100644
--- a/media-sound/beast/files/beast-0.7.1-noinstalltest.patch
+++ b/media-sound/beast/files/beast-0.7.1-noinstalltest.patch
@@ -14,3 +14,19 @@ Index: beast-0.7.1/shell/Makefile.in
done
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
+Index: beast-0.7.1/shell/Makefile.am
+===================================================================
+--- beast-0.7.1.orig/shell/Makefile.am
++++ beast-0.7.1/shell/Makefile.am
+@@ -859,10 +859,7 @@ check-before: check-installation
+ check-installation:
+ @for p in $(bin_PROGRAMS) ; do \
+ pp="$(DESTDIR)$(bindir)/$$p" ; \
+- echo "TEST: test -x \"$$pp\"" ; \
+- test -x "$$pp" || \
+- { echo "Failed to verify installation of executable: $$pp"; \
+- exit 1 ; } \
++ echo "TEST: test -x \"$$pp\" Test disabled" ; \
+ done
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.