summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-07-26 11:48:09 +0000
committerNick Hadaway <raker@gentoo.org>2003-07-26 11:48:09 +0000
commit054214eb7882efbec84c3475a88bd5e0fac862e5 (patch)
treeb505d030fafd1b7973d73d44cf01ce10e4d04026 /media-sound/beast
parentAdded mad, static, and debug USE variables. Other ebuild cleanups. (diff)
downloadgentoo-2-054214eb7882efbec84c3475a88bd5e0fac862e5.tar.gz
gentoo-2-054214eb7882efbec84c3475a88bd5e0fac862e5.tar.bz2
gentoo-2-054214eb7882efbec84c3475a88bd5e0fac862e5.zip
Added mad, static, and debug USE variables. Other ebuild cleanups.
Diffstat (limited to 'media-sound/beast')
-rw-r--r--media-sound/beast/ChangeLog10
-rw-r--r--media-sound/beast/Manifest4
-rw-r--r--media-sound/beast/beast-0.5.4.ebuild53
-rw-r--r--media-sound/beast/files/digest-beast-0.5.41
-rw-r--r--media-sound/beast/files/docs-reorg-0.5.4.patch28
5 files changed, 93 insertions, 3 deletions
diff --git a/media-sound/beast/ChangeLog b/media-sound/beast/ChangeLog
index 42cd69d59b20..2a91db0d9835 100644
--- a/media-sound/beast/ChangeLog
+++ b/media-sound/beast/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/beast
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/ChangeLog,v 1.8 2003/07/19 19:37:26 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/ChangeLog,v 1.9 2003/07/26 11:48:05 raker Exp $
+
+*beast-0.5.4 (26 Jul 2003)
+
+ 26 Jul 2003; Nick Hadaway <raker@gentoo.org> beast-0.5.4.ebuild,
+ files/docs-reorg-0.5.4 patch:
+ Version bump. Upstream fixes include bug fixes, a gui pretty-up,
+ and some other feature adds like a synthetic drum generator.
+ Added mad, debug, and static to USE. Other ebuild cleanups.
19 Jul 2003; Nick Hadaway <raker@gentoo.org>:
Reverted back to 0.5.3
diff --git a/media-sound/beast/Manifest b/media-sound/beast/Manifest
index 72ce885bbef4..a430e2762f3f 100644
--- a/media-sound/beast/Manifest
+++ b/media-sound/beast/Manifest
@@ -1,6 +1,6 @@
-MD5 4966df1a4ef3008e413f0de425d8dc45 beast-0.5.4.ebuild 1237
+MD5 e5cb6bc7ecab3fb617c81bb60091aad7 beast-0.5.4.ebuild 1235
MD5 b5d383f2bbbcfc876bbba5cdeae6629a beast-0.5.3.ebuild 877
-MD5 54f670d167e4324d233cbdae915d93f4 ChangeLog 1380
+MD5 36cd13f217c40c95fc4301c8538307ed ChangeLog 1380
MD5 b263ff7675308d90b75a170acae3f5ff metadata.xml 177
MD5 a4f7610677db92cac1eae45e489c4caa files/digest-beast-0.5.3 64
MD5 53bf4b555288cab59eb6f8bbb5940352 files/digest-beast-0.5.4 64
diff --git a/media-sound/beast/beast-0.5.4.ebuild b/media-sound/beast/beast-0.5.4.ebuild
new file mode 100644
index 000000000000..b55b235a9375
--- /dev/null
+++ b/media-sound/beast/beast-0.5.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/beast-0.5.4.ebuild,v 1.1 2003/07/26 11:48:05 raker Exp $
+
+IUSE="debug mad static"
+
+DESCRIPTION="BEAST - the Bedevilled Sound Engine"
+HOMEPAGE="http://beast.gtk.org"
+SRC_URI="ftp://beast.gtk.org/pub/beast/v${PV%.[0-9]}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~x86"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=x11-libs/gtk+-2.0.0
+ >=sys-libs/zlib-1.1.3
+ >=dev-util/guile-1.6
+ >=media-libs/libart_lgpl-2.3.8
+ >=gnome-base/libgnomecanvas-2.0
+ >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0
+ mad? ( media-sound/mad )"
+
+DEPEND="dev-util/pkgconfig
+ dev-lang/perl
+ media-libs/ladspa-cmt
+ media-libs/ladspa-sdk
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/docs-reorg-0.5.4.patch
+}
+
+src_compile() {
+ local myconf="--with-gnu-ld"
+
+ use debug || myconf="${myconf} --disable-debug"
+
+ use static || myconf="${myconf} --disable-static"
+
+ econf ${myconf} || die "configure failed"
+
+ emake || die "configure failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README TODO
+}
diff --git a/media-sound/beast/files/digest-beast-0.5.4 b/media-sound/beast/files/digest-beast-0.5.4
new file mode 100644
index 000000000000..0d4fd4d2a6a7
--- /dev/null
+++ b/media-sound/beast/files/digest-beast-0.5.4
@@ -0,0 +1 @@
+MD5 ca6db9d452b139f5a4a6fc6a8012dd6f beast-0.5.4.tar.gz 2581668
diff --git a/media-sound/beast/files/docs-reorg-0.5.4.patch b/media-sound/beast/files/docs-reorg-0.5.4.patch
new file mode 100644
index 000000000000..d395a45321f9
--- /dev/null
+++ b/media-sound/beast/files/docs-reorg-0.5.4.patch
@@ -0,0 +1,28 @@
+diff -urN beast-0.5.4/configure beast-0.5.4-modified/configure
+--- beast-0.5.4/configure 2003-07-21 07:49:11.000000000 -0500
++++ beast-0.5.4-modified/configure 2003-07-26 05:41:51.000000000 -0500
+@@ -7656,7 +7656,7 @@
+
+
+ # setup BSE install paths
+- bsesharedir=\${datadir}/beast/v$BSE_MAJOR_VERSION.$BSE_MINOR_VERSION.$BSE_MICRO_VERSION
++ bsesharedir=\${datadir}/doc/\${PN}-\${PVR}
+ bsescriptdir=$bsesharedir/scripts
+
+
+@@ -8053,11 +8053,11 @@
+
+
+ # BEAST resource paths
+- beastbasedir=\${datadir}/beast
+- beastdocsdir=$beastbasedir/v$BSE_MAJOR_VERSION.$BSE_MINOR_VERSION.$BSE_MICRO_VERSION/docs
+- beastimagesdir=$beastbasedir/v$BSE_MAJOR_VERSION.$BSE_MINOR_VERSION/images
++ beastbasedir=\${datadir}/doc/\${PN}-\${PVR}
++ beastdocsdir=$beastbasedir/docs
++ beastimagesdir=$beastbasedir/images
+ # beast-data package path
+- beastdatadir=$beastbasedir/data-v$BSE_MAJOR_VERSION.$BSE_MINOR_VERSION
++ beastdatadir=$beastbasedir/data
+ beastsampledatadir=$beastdatadir/samples
+
+