summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2006-06-05 20:22:52 +0000
committerDaniel Drake <dsd@gentoo.org>2006-06-05 20:22:52 +0000
commiteb0c16e3d41a9ccfd0cca199358d29f7ddf61723 (patch)
tree7414cd7afc3de065144f629102dfb27e6bc8ea07 /media-sound/banshee
parentAnother version bump, merging changes from baselayout svn (diff)
downloadgentoo-2-eb0c16e3d41a9ccfd0cca199358d29f7ddf61723.tar.gz
gentoo-2-eb0c16e3d41a9ccfd0cca199358d29f7ddf61723.tar.bz2
gentoo-2-eb0c16e3d41a9ccfd0cca199358d29f7ddf61723.zip
Fix import of m4a (AAC) files
(Portage version: 2.1_rc4-r2)
Diffstat (limited to 'media-sound/banshee')
-rw-r--r--media-sound/banshee/ChangeLog8
-rw-r--r--media-sound/banshee/banshee-0.10.10-r4.ebuild119
-rw-r--r--media-sound/banshee/files/banshee-0.10.10-mp4-mimetype.patch13
-rw-r--r--media-sound/banshee/files/digest-banshee-0.10.10-r43
4 files changed, 142 insertions, 1 deletions
diff --git a/media-sound/banshee/ChangeLog b/media-sound/banshee/ChangeLog
index 0ef6af3d0862..0389366ff0bd 100644
--- a/media-sound/banshee/ChangeLog
+++ b/media-sound/banshee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/banshee
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.30 2006/05/28 03:11:32 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.31 2006/06/05 20:22:52 dsd Exp $
+
+*banshee-0.10.10-r4 (05 Jun 2006)
+
+ 05 Jun 2006; Daniel Drake <dsd@gentoo.org>
+ +files/banshee-0.10.10-mp4-mimetype.patch, +banshee-0.10.10-r4.ebuild:
+ Fix import of m4a (AAC) files
*banshee-0.10.10-r3 (28 May 2006)
diff --git a/media-sound/banshee/banshee-0.10.10-r4.ebuild b/media-sound/banshee/banshee-0.10.10-r4.ebuild
new file mode 100644
index 000000000000..3e6c328e8bad
--- /dev/null
+++ b/media-sound/banshee/banshee-0.10.10-r4.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-0.10.10-r4.ebuild,v 1.1 2006/06/05 20:22:52 dsd Exp $
+
+inherit autotools eutils gnome2 mono
+
+DESCRIPTION="Banshee allows you to import CDs, sync your music collection, play
+music directly from an iPod, create playlists with songs from your library, and
+create audio and MP3 CDs from subsets of your library."
+HOMEPAGE="http://banshee-project.org"
+SRC_URI="http://banshee-project.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="aac doc daap ipod flac mad njb vorbis"
+
+RDEPEND=">=dev-lang/mono-1.1.13
+ >=dev-dotnet/gtk-sharp-2.8.0
+ >=dev-dotnet/gnomevfs-sharp-2.8.0
+ >=dev-dotnet/gconf-sharp-2.8.0
+ >=media-libs/gstreamer-0.10.0
+ >=media-libs/gst-plugins-base-0.10.0
+ >=media-libs/gst-plugins-good-0.10.0
+ >=media-libs/gst-plugins-ugly-0.10.0
+ >=media-plugins/gst-plugins-alsa-0.10.0
+ >=media-plugins/gst-plugins-gnomevfs-0.10.0
+ >=media-plugins/gst-plugins-gconf-0.10.0
+ encode? ( >=media-plugins/gst-plugins-lame-0.10.0 )
+ mad? ( >=media-plugins/gst-plugins-mad-0.10.0 )
+ vorbis? ( >=media-plugins/gst-plugins-ogg-0.10.0
+ >=media-plugins/gst-plugins-vorbis-0.10.0 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.10.0 )
+ aac? ( >=media-plugins/gst-plugins-faad-0.10.0
+ >=media-libs/faad2-2.0-r4 )
+ >=media-plugins/gst-plugins-cdparanoia-0.10.0
+ >=media-libs/musicbrainz-2.1.1
+ real? ( media-video/realplayer )
+ njb? ( >=dev-dotnet/njb-sharp-0.3.0 )
+ daap? ( >=net-dns/avahi-0.6.9 )
+ >=dev-libs/glib-2.0
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/libbonobo-2.0
+ >=gnome-base/gnome-desktop-2.0
+ ipod? ( >=dev-dotnet/ipod-sharp-0.5.15
+ >=media-plugins/gst-plugins-faac-0.10.0 )
+ >=sys-apps/hal-0.5.2
+ >=sys-apps/dbus-0.60
+ >=dev-db/sqlite-3
+ >=gnome-extra/nautilus-cd-burner-2.12"
+
+USE_DESTDIR=1
+DOCS="ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ if ! built_with_use sys-apps/dbus mono ; then
+ echo
+ eerror "In order to compile banshee, you need to have sys-apps/dbus emerged"
+ eerror "with 'mono' in your USE flags. Please add that flag, re-emerge"
+ eerror "dbus, and then emerge banshee."
+ die "sys-apps/dbus is missing the .NET binding."
+ fi
+
+ if use daap && ! built_with_use net-dns/avahi mono ; then
+ echo
+ eerror "In order to compile banshee with daap support"
+ eerror "you need to have net-dns/avahi emerged"
+ eerror "with 'mono' in your USE flags. Please add that flag, re-emerge"
+ eerror "avahi, and then emerge banshee."
+ die "net-dns/avahi is missing the .NET binding."
+ fi
+
+ if use daap; then
+ G2CONF="${G2CONF} --enable-avahi"
+ else
+ G2CONF="${G2CONF} --disable-daap"
+ fi
+
+ G2CONF="${G2CONF} --disable-xing \
+ --disable-helix \
+ --disable-docs \
+ --with-gstreamer-0-10 \
+ $( use_enable ipod) \
+ $( use_enable njb)"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-disableplugin.patch
+ epatch ${FILESDIR}/${P}-mp4-mimetype.patch
+ eautoreconf
+}
+
+src_compile() {
+ addpredict "/root/.gnome2"
+ addpredict "/root/.gconf"
+ addpredict "/root/.gconfd"
+ gnome2_src_configure
+ emake -j1 || "make failed"
+}
+
+src_install() {
+ gnome2_src_install
+ if ! use ipod; then
+ dodir /usr/$(get_libdir)/banshee/Banshee.Dap
+ fi
+}
+pkg_postinst() {
+ gnome2_pkg_postinst
+ einfo
+ einfo "In case you have an ipod please rebuild this package with USE=ipod"
+ einfo "If you have a audio player supported by libnjb please"
+ einfo "rebuild this package with USE=njb"
+ einfo
+ einfo "Banshee is build only with gstreamer 0.10.x support."
+ einfo
+}
diff --git a/media-sound/banshee/files/banshee-0.10.10-mp4-mimetype.patch b/media-sound/banshee/files/banshee-0.10.10-mp4-mimetype.patch
new file mode 100644
index 000000000000..efe2823e09ac
--- /dev/null
+++ b/media-sound/banshee/files/banshee-0.10.10-mp4-mimetype.patch
@@ -0,0 +1,13 @@
+Index: banshee-0.10.10/entagged-sharp/Mp4/Mp4FileReader.cs
+===================================================================
+--- banshee-0.10.10.orig/entagged-sharp/Mp4/Mp4FileReader.cs
++++ banshee-0.10.10/entagged-sharp/Mp4/Mp4FileReader.cs
+@@ -34,6 +34,8 @@ using Entagged.Audioformats.Mp4.Util;
+ namespace Entagged.Audioformats.Mp4
+ {
+ [SupportedMimeType ("audio/x-m4a")]
++ [SupportedMimeType ("audio/mp4")]
++ [SupportedMimeType ("audio/m4a")]
+ [SupportedMimeType ("entagged/m4a")]
+ [SupportedMimeType ("entagged/m4p")]
+ public class Mp4FileReader : AudioFileReader
diff --git a/media-sound/banshee/files/digest-banshee-0.10.10-r4 b/media-sound/banshee/files/digest-banshee-0.10.10-r4
new file mode 100644
index 000000000000..ccdb303ddc17
--- /dev/null
+++ b/media-sound/banshee/files/digest-banshee-0.10.10-r4
@@ -0,0 +1,3 @@
+MD5 cb553f5bc6dc14b7afa44349d025bbdc banshee-0.10.10.tar.gz 1283567
+RMD160 af60d5883d1fee43269bd173ada08138bc50a20a banshee-0.10.10.tar.gz 1283567
+SHA256 38fc1f388637e036808555d086276122f3d410f8469cbad8313d329a276fefd5 banshee-0.10.10.tar.gz 1283567