summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2005-12-07 18:41:49 +0000
committerLuis Medinas <metalgod@gentoo.org>2005-12-07 18:41:49 +0000
commitbb6974a929c4e1cf8c1fab5c17c81d426f3cec44 (patch)
tree4b1f117d389f49a8af0bc8fda8fc13dbc192759e /media-sound/banshee
parentAdded ipod use flag to work with the new release of banshee (diff)
downloadgentoo-2-bb6974a929c4e1cf8c1fab5c17c81d426f3cec44.tar.gz
gentoo-2-bb6974a929c4e1cf8c1fab5c17c81d426f3cec44.tar.bz2
gentoo-2-bb6974a929c4e1cf8c1fab5c17c81d426f3cec44.zip
Version bump. Thanks to John N. Laliberte <allanonJL@gentoo.org> for helping me with this release.
(Portage version: 2.0.53)
Diffstat (limited to 'media-sound/banshee')
-rw-r--r--media-sound/banshee/ChangeLog8
-rw-r--r--media-sound/banshee/banshee-0.10.ebuild70
-rw-r--r--media-sound/banshee/files/digest-banshee-0.101
3 files changed, 78 insertions, 1 deletions
diff --git a/media-sound/banshee/ChangeLog b/media-sound/banshee/ChangeLog
index 2c5e2fcfd59a..e7f2301167b4 100644
--- a/media-sound/banshee/ChangeLog
+++ b/media-sound/banshee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/banshee
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.2 2005/12/05 23:24:16 zaheerm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.3 2005/12/07 18:41:49 metalgod Exp $
+
+*banshee-0.10 (07 Dec 2005)
+
+ 07 Dec 2005; Luis Medinas <metalgod@gentoo.org> +banshee-0.10.ebuild:
+ Version bump. Thanks to John N. Laliberte <allanonJL@gentoo.org> for helping
+ me with this release.
05 Dec 2005; Zaheer Abbas Merali <zaheerm@gentoo.org>
banshee-0.9.12.ebuild:
diff --git a/media-sound/banshee/banshee-0.10.ebuild b/media-sound/banshee/banshee-0.10.ebuild
new file mode 100644
index 000000000000..5c573f493191
--- /dev/null
+++ b/media-sound/banshee/banshee-0.10.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-0.10.ebuild,v 1.1 2005/12/07 18:41:49 metalgod Exp $
+
+inherit eutils gnome2 mono
+
+DESCRIPTION="Banshee allows you to import CDs, sync your music collection, play
+music directly from an iPod, create playlists with songs from your library, and
+create audio and MP3 CDs from subsets of your library."
+HOMEPAGE="http://banshee-project.org"
+SRC_URI="http://banshee-project.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="aac doc ipod flac mad real vorbis"
+
+RDEPEND=">=dev-lang/mono-1.1.9.2
+ >=dev-dotnet/gtk-sharp-2.3.90
+ >=dev-dotnet/gnomevfs-sharp-1.9
+ >=dev-dotnet/gconf-sharp-2.3.90
+ =media-libs/gstreamer-0.8*
+ =media-libs/gst-plugins-0.8*
+ =media-plugins/gst-plugins-gnomevfs-0.8*
+ mad? ( =media-plugins/gst-plugins-mad-0.8* )
+ vorbis? ( =media-plugins/gst-plugins-ogg-0.8*
+ =media-plugins/gst-plugins-vorbis-0.8* )
+ flac? ( =media-plugins/gst-plugins-flac-0.8* )
+ aac? ( =media-plugins/gst-plugins-faad-0.8*
+ >=media-libs/faad2-2.0-r4 )
+ >=media-libs/musicbrainz-2.1.1
+ real? ( media-video/realplayer )
+ >=dev-libs/glib-2.0
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/libbonobo-2.0
+ >=gnome-base/gnome-desktop-2.0
+ >=dev-dotnet/ipod-sharp-0.5.12
+ >=sys-apps/hal-0.5.2
+ sys-apps/dbus
+ >=dev-db/sqlite-3
+ >=gnome-extra/nautilus-cd-burner-2.12"
+
+USE_DESTDIR=1
+DOCS="ChangeLog NEWS README"
+
+pkg_setup() {
+ if ! built_with_use sys-apps/dbus mono ; then
+ echo
+ eerror "In order to compile banshee, you need to have sys-apps/dbus emerged"
+ eerror "with 'mono' in your USE flags. Please add that flag, re-emerge"
+ eerror "dbus, and then emerge banshee."
+ die "sys-apps/dbus is missing the .NET binding."
+ fi
+ if use real; then
+ G2CONF="${G2CONF} --enable-helix --with-helix-libs=/opt/RealPlayer/"
+ fi
+ G2CONF="${G2CONF} --disable-xing \
+ --disable-njb \
+ $( use_enable ipod) \
+ $( use_enable doc docs)"
+}
+src_compile() {
+ addpredict "/root/.gconf/"
+ addpredict "/root/.gconfd"
+ gnome2_src_configure
+ emake -j1 || "make failed"
+}
+pkg_postinst() {
+ einfo "If you have an ipod please rebuild this package with USE=ipod"
+}
diff --git a/media-sound/banshee/files/digest-banshee-0.10 b/media-sound/banshee/files/digest-banshee-0.10
new file mode 100644
index 000000000000..d697d6fb01dc
--- /dev/null
+++ b/media-sound/banshee/files/digest-banshee-0.10
@@ -0,0 +1 @@
+MD5 e261391168c6e7bd545b800fa1a32cf9 banshee-0.10.tar.gz 1652268