summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-08-01 20:33:09 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-08-01 20:33:09 +0000
commit97dcc8e77e63eb8a8a0d261bd266dc769282618d (patch)
treea6575de8785743be891cd19184f7f89e15f18738 /media-sound/banshee
parentRemove mplayer-bin support, bug #233394 (diff)
downloadgentoo-2-97dcc8e77e63eb8a8a0d261bd266dc769282618d.tar.gz
gentoo-2-97dcc8e77e63eb8a8a0d261bd266dc769282618d.tar.bz2
gentoo-2-97dcc8e77e63eb8a8a0d261bd266dc769282618d.zip
bump to banshee 1.2
(Portage version: 2.2_rc5/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'media-sound/banshee')
-rw-r--r--media-sound/banshee/ChangeLog7
-rw-r--r--media-sound/banshee/banshee-1.2.0.ebuild96
2 files changed, 102 insertions, 1 deletions
diff --git a/media-sound/banshee/ChangeLog b/media-sound/banshee/ChangeLog
index 32576e92cd5f..c9711bcec9b4 100644
--- a/media-sound/banshee/ChangeLog
+++ b/media-sound/banshee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/banshee
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.66 2008/07/07 16:26:03 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.67 2008/08/01 20:33:09 loki_val Exp $
+
+*banshee-1.2.0 (01 Aug 2008)
+
+ 01 Aug 2008; Peter Alfredsen <loki_val@gentoo.org> +banshee-1.2.0.ebuild:
+ bump to banshee 1.2
07 Jul 2008; Samuli Suominen <drac@gentoo.org> banshee-1.0.0-r1.ebuild:
Update taglib-sharp dep. for bug #230465, thanks to corec.
diff --git a/media-sound/banshee/banshee-1.2.0.ebuild b/media-sound/banshee/banshee-1.2.0.ebuild
new file mode 100644
index 000000000000..c1646e219fad
--- /dev/null
+++ b/media-sound/banshee/banshee-1.2.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-1.2.0.ebuild,v 1.1 2008/08/01 20:33:09 loki_val Exp $
+
+EAPI=1
+
+inherit base gnome2 mono
+
+GVER=0.10.3
+
+DESCRIPTION="Import, organize, play, and share your music using a simple and powerful interface."
+HOMEPAGE="http://banshee-project.org"
+SRC_URI="http://download.banshee-project.org/${PN}/${PN}-1-${PV}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+aac +boo daap doc +encode +flac ipod +mad mtp +podcast test +vorbis"
+
+RDEPEND=">=dev-lang/mono-1.2.4
+ >=dev-dotnet/gtk-sharp-2.10
+ >=dev-dotnet/gconf-sharp-2.8
+ >=dev-dotnet/gnome-sharp-2.8
+ >=media-libs/gst-plugins-bad-${GVER}
+ >=media-libs/gst-plugins-good-${GVER}
+ >=media-libs/gst-plugins-ugly-${GVER}
+ >=media-plugins/gst-plugins-alsa-${GVER}
+ >=media-plugins/gst-plugins-gnomevfs-${GVER}
+ >=media-plugins/gst-plugins-gconf-${GVER}
+ || (
+ >=media-plugins/gst-plugins-cdparanoia-${GVER}
+ >=media-plugins/gst-plugins-cdio-${GVER}
+ )
+ media-libs/musicbrainz:1
+ >=dev-dotnet/dbus-glib-sharp-0.3
+ >=dev-dotnet/dbus-sharp-0.5
+ >=dev-dotnet/mono-addins-0.3.1
+ >=dev-dotnet/taglib-sharp-2.0.3
+ >=dev-db/sqlite-3.4
+ aac? (
+ >=media-plugins/gst-plugins-faad-${GVER}
+ )
+ boo? (
+ >=dev-lang/boo-0.8.1
+ )
+ daap? (
+ >=dev-dotnet/mono-zeroconf-0.7.3
+ )
+ doc? (
+ dev-util/monodoc
+ )
+ encode? (
+ >=media-plugins/gst-plugins-lame-${GVER}
+ >=media-plugins/gst-plugins-taglib-${GVER}
+ )
+ flac? (
+ >=media-plugins/gst-plugins-flac-${GVER}
+ )
+ ipod? (
+ >=dev-dotnet/ipod-sharp-0.8.0
+ )
+ mad? (
+ >=media-plugins/gst-plugins-mad-${GVER}
+ )
+ mtp? (
+ >=media-libs/libmtp-0.2.5-r1
+ )
+ vorbis? (
+ >=media-plugins/gst-plugins-ogg-${GVER}
+ >=media-plugins/gst-plugins-vorbis-${GVER}
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+S=${WORKDIR}/${PN}-1-${PV}
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable doc docs)
+ $(use_enable mtp)
+ $(use_enable daap)
+ $(use_enable ipod)
+ $(use_enable podcast)
+ $(use_enable test tests)"
+
+ MAKEOPTS="${MAKEOPTS} -j1"
+}
+
+src_unpack() {
+ base_src_unpack
+ gnome2_omf_fix
+ elibtoolize
+}