summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-21 19:55:23 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-21 19:55:23 +0000
commit8ec851a23020f02f2eb6630cd806876ad7287c43 (patch)
tree570cdfe074c0861081b9da95fdfc595fce86e28d /media-sound/awesfx
parenttypo (Manifest recommit) (diff)
downloadgentoo-2-8ec851a23020f02f2eb6630cd806876ad7287c43.tar.gz
gentoo-2-8ec851a23020f02f2eb6630cd806876ad7287c43.tar.bz2
gentoo-2-8ec851a23020f02f2eb6630cd806876ad7287c43.zip
Version bump closes bug #57503.
Diffstat (limited to 'media-sound/awesfx')
-rw-r--r--media-sound/awesfx/ChangeLog8
-rw-r--r--media-sound/awesfx/Manifest2
-rw-r--r--media-sound/awesfx/awesfx-0.5.0c.ebuild42
-rw-r--r--media-sound/awesfx/files/digest-awesfx-0.5.0c1
4 files changed, 52 insertions, 1 deletions
diff --git a/media-sound/awesfx/ChangeLog b/media-sound/awesfx/ChangeLog
index 88a8096f3690..23f4c9e31231 100644
--- a/media-sound/awesfx/ChangeLog
+++ b/media-sound/awesfx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/awesfx
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/ChangeLog,v 1.10 2004/07/01 07:48:46 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/ChangeLog,v 1.11 2004/07/21 19:55:23 eradicator Exp $
+
+*awesfx-0.5.0c (21 Jul 2004)
+
+ 21 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +awesfx-0.5.0c.ebuild:
+ Version bump closes bug #57503.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> awesfx-0.4.4.ebuild,
awesfx-0.5.0b.ebuild:
diff --git a/media-sound/awesfx/Manifest b/media-sound/awesfx/Manifest
index 3bde79147e8d..ab354ab172e5 100644
--- a/media-sound/awesfx/Manifest
+++ b/media-sound/awesfx/Manifest
@@ -2,7 +2,9 @@ MD5 e2a1674ea4874f0b9595e6ec8f134038 ChangeLog 1136
MD5 5157a692c94f35eabdde4513fd813ea6 awesfx-0.4.4.ebuild 1485
MD5 b32d7a292377152f131db8676889ea07 awesfx-0.5.0b.ebuild 1166
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
+MD5 b0767ec974b9595fa4af64d0576f6edf awesfx-0.5.0c.ebuild 1158
MD5 f2718083317de4e006954291d3da6f4e files/awesfx-0.5.0b-configure-noalsa.patch 7814
MD5 a2f1d07a053240ebc621d1834c928e6f files/awesfx-0.5.0b-makefile-noalsa.patch 3507
MD5 0510ed427cbce41e3cccf010d8a2b053 files/digest-awesfx-0.4.4 64
MD5 65393e10260fc71e0093e7337c7703c9 files/digest-awesfx-0.5.0b 65
+MD5 413587b49e630a9b899620cc979a5a5d files/digest-awesfx-0.5.0c 65
diff --git a/media-sound/awesfx/awesfx-0.5.0c.ebuild b/media-sound/awesfx/awesfx-0.5.0c.ebuild
new file mode 100644
index 000000000000..5f05823dc351
--- /dev/null
+++ b/media-sound/awesfx/awesfx-0.5.0c.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/awesfx-0.5.0c.ebuild,v 1.1 2004/07/21 19:55:23 eradicator Exp $
+
+IUSE="alsa"
+
+inherit eutils
+
+DESCRIPTION="AWE Utilities - sfxload"
+HOMEPAGE="http://www.alsa-project.org/~iwai/awedrv.html#Utils"
+SRC_URI=http://www.alsa-project.org/~iwai/${P}.tar.gz
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+DEPEND="virtual/libc
+ alsa? ( >=media-libs/alsa-lib-1.0.0 )"
+
+src_compile() {
+ if ! use alsa; then
+ einfo "Removing ALSA support!"
+ epatch ${FILESDIR}/${PN}-0.5.0b-configure-noalsa.patch
+ econf --with-sfpath=/usr/share/sfbank || die
+ epatch ${FILESDIR}/${PN}-0.5.0b-makefile-noalsa.patch
+ sed -i -e 's/'^LIBS.*-lasound.*$'/LIBS = -lm -ldl -lpthread/' Makefile
+ else
+ econf --with-sfpath=/usr/share/sfbank || die
+ fi
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL README SBKtoSF2.txt
+}
+
+pkg_postinst() {
+ einfo "Please copy your SoundFont files from the original CD-ROM"
+ einfo "shipped with your soundcard to"
+ einfo "/usr/share/sfbank"
+}
+
diff --git a/media-sound/awesfx/files/digest-awesfx-0.5.0c b/media-sound/awesfx/files/digest-awesfx-0.5.0c
new file mode 100644
index 000000000000..7feb2e7620eb
--- /dev/null
+++ b/media-sound/awesfx/files/digest-awesfx-0.5.0c
@@ -0,0 +1 @@
+MD5 b4f9192dc6357014215a3d06a99d40f2 awesfx-0.5.0c.tar.gz 372089