summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-06 22:14:07 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-06 22:14:07 +0000
commitd14933e62e7a71eaabe1b8262a1ebc95dccf8492 (patch)
tree579a09bc705058f5ef3943ece4759bc7537c5159 /media-sound/ario
parentversion bump (diff)
downloadgentoo-2-d14933e62e7a71eaabe1b8262a1ebc95dccf8492.tar.gz
gentoo-2-d14933e62e7a71eaabe1b8262a1ebc95dccf8492.tar.bz2
gentoo-2-d14933e62e7a71eaabe1b8262a1ebc95dccf8492.zip
Fixed as-needed, bug 232416 and 247814, thanks to a-v and idl0r on freenode
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc7-00167-g24920a7 x86_64)
Diffstat (limited to 'media-sound/ario')
-rw-r--r--media-sound/ario/ChangeLog7
-rw-r--r--media-sound/ario/ario-1.1.ebuild11
-rw-r--r--media-sound/ario/files/ario-1.1-as-needed.patch32
3 files changed, 47 insertions, 3 deletions
diff --git a/media-sound/ario/ChangeLog b/media-sound/ario/ChangeLog
index 63837b6a27d8..949cad9fa5fa 100644
--- a/media-sound/ario/ChangeLog
+++ b/media-sound/ario/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ario
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ChangeLog,v 1.5 2008/12/06 21:13:51 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ChangeLog,v 1.6 2008/12/06 22:14:07 angelos Exp $
+
+ 06 Dec 2008; Christoph Mende <angelos@gentoo.org>
+ +files/ario-1.1-as-needed.patch, ario-1.1.ebuild:
+ Fixed as-needed, bug 232416 and 247814, thanks to a-v and idl0r on
+ freenode
06 Dec 2008; Christoph Mende <angelos@gentoo.org> ario-1.1.ebuild:
Renamed USE=avahi to USE=zeroconf and added gnome2_icon_savelist
diff --git a/media-sound/ario/ario-1.1.ebuild b/media-sound/ario/ario-1.1.ebuild
index 27edb275ed52..9e3d5f5fa008 100644
--- a/media-sound/ario/ario-1.1.ebuild
+++ b/media-sound/ario/ario-1.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ario-1.1.ebuild,v 1.5 2008/12/06 21:13:51 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ario-1.1.ebuild,v 1.6 2008/12/06 22:14:07 angelos Exp $
EAPI=1
-inherit gnome2-utils
+inherit autotools eutils gnome2-utils
DESCRIPTION="a GTK2 MPD (Music Player Daemon) client inspired by Rythmbox"
HOMEPAGE="http://ario-player.sourceforge.net"
@@ -27,6 +27,13 @@ DEPEND="sys-devel/gettext
S="${WORKDIR}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
src_compile() {
econf \
$(use_enable zeroconf avahi) \
diff --git a/media-sound/ario/files/ario-1.1-as-needed.patch b/media-sound/ario/files/ario-1.1-as-needed.patch
new file mode 100644
index 000000000000..580697674c62
--- /dev/null
+++ b/media-sound/ario/files/ario-1.1-as-needed.patch
@@ -0,0 +1,32 @@
+diff -u -Nru a/configure.ac b/configure.ac
+--- a/configure.ac 2008-06-05 23:44:02.000000000 +0200
++++ b/configure.ac 2008-12-06 23:07:49.000000000 +0100
+@@ -26,6 +26,8 @@
+ AC_SUBST(DEPS_CFLAGS)
+ AC_SUBST(DEPS_LIBS)
+
++AM_PATH_LIBGCRYPT(1.4.0,,)
++
+ dnl i18n
+ GETTEXT_PACKAGE=Ario
+ AC_SUBST(GETTEXT_PACKAGE)
+diff -u -Nru a/src/Makefile.am b/src/Makefile.am
+--- a/src/Makefile.am 2008-05-17 20:02:37.000000000 +0200
++++ b/src/Makefile.am 2008-12-06 23:08:03.000000000 +0100
+@@ -132,12 +132,14 @@
+ endif
+
+ ario_LDADD = \
+- $(DEPS_LIBS)\
+- $(AVAHI_LIBS)
++ $(DEPS_LIBS) \
++ $(AVAHI_LIBS) \
++ $(LIBGCRYPT_LIBS)
+
+ AM_CPPFLAGS = \
+ $(DEPS_CFLAGS) \
+ $(AVAHI_CFLAGS) \
++ $(LIBGCRYPT_CFLAGS) \
+ -DLOCALE_DIR=\""$(pkgdatadir)/locale"\"\
+ -DPIXMAP_PATH=\""$(pkgdatadir)/ario/art/"\"\
+ -DDATA_PATH=\""$(pkgdatadir)/ario/data/"\"\