summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-12-17 18:38:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-12-17 18:38:27 +0000
commit2ca58627dc3576c817267a6932d13fbd80497d31 (patch)
tree57dd3c66ea8a1e2439c8e9f98846c5584342c694 /media-sound/amarok
parentamd64 stable (diff)
downloadgentoo-2-2ca58627dc3576c817267a6932d13fbd80497d31.tar.gz
gentoo-2-2ca58627dc3576c817267a6932d13fbd80497d31.tar.bz2
gentoo-2-2ca58627dc3576c817267a6932d13fbd80497d31.zip
Version bump.
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog7
-rw-r--r--media-sound/amarok/amarok-1.4.8.ebuild106
-rw-r--r--media-sound/amarok/files/digest-amarok-1.4.83
3 files changed, 115 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 905b2e1bc969..c0764e0f557a 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.248 2007/11/23 16:43:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.249 2007/12/17 18:38:27 flameeyes Exp $
+
+*amarok-1.4.8 (17 Dec 2007)
+
+ 17 Dec 2007; Diego Pettenò <flameeyes@gentoo.org> +amarok-1.4.8.ebuild:
+ Version bump.
23 Nov 2007; Diego Pettenò <flameeyes@gentoo.org> metadata.xml:
Add proper documentation of some of the possibly ambiguous USE flags.
diff --git a/media-sound/amarok/amarok-1.4.8.ebuild b/media-sound/amarok/amarok-1.4.8.ebuild
new file mode 100644
index 000000000000..0c2705330c2d
--- /dev/null
+++ b/media-sound/amarok/amarok-1.4.8.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.8.ebuild,v 1.1 2007/12/17 18:38:27 flameeyes Exp $
+
+LANGS="af ar az be bg bn br ca cs cy da de el en_GB eo es et eu fa fi
+fr ga gl he hi hu id is it ja km ko ku lo lt mk ms nb nds ne nl nn pa
+pl pt pt_BR ro ru rw se sk sl sq sr sr@Latn ss sv ta tg th tr uk uz
+zh_CN zh_TW"
+
+LANGS_DOC="da de es et fr it nl pl pt pt_BR ru sv"
+
+USE_KEG_PACKAGING=1
+
+inherit kde
+
+PKG_SUFFIX=""
+
+if [[ ${P/_pre} == ${P} ]]; then
+ MY_P="${P/_/-}"
+
+ if [[ ${P/_rc} == ${P} ]]; then
+ SRC_URI="mirror://kde/stable/amarok/${PV}/src/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${P/_/-}"
+ else
+ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${P/_rc*}"
+ fi
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+fi
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mp4 kde mysql amazon opengl postgres
+visualization ipod ifp real njb mtp musicbrainz daap
+python"
+# kde: enables compilation of the konqueror sidebar plugin
+
+RDEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ >=media-libs/xine-lib-1.1.2_pre20060328-r8
+ >=media-libs/taglib-1.4
+ mysql? ( >=virtual/mysql-4.0 )
+ postgres? ( dev-db/libpq )
+ opengl? ( virtual/opengl )
+ visualization? ( media-libs/libsdl
+ =media-plugins/libvisual-plugins-0.4* )
+ ipod? ( >=media-libs/libgpod-0.4.2 )
+ mp4? ( media-libs/libmp4v2 )
+ ifp? ( media-libs/libifp )
+ real? ( media-video/realplayer )
+ njb? ( >=media-libs/libnjb-2.2.4 )
+ mtp? ( >=media-libs/libmtp-0.1.1 )
+ musicbrainz? ( media-libs/tunepimp )
+ =dev-lang/ruby-1.8*"
+
+DEPEND="${RDEPEND}"
+
+RDEPEND="${RDEPEND}
+ app-arch/unzip
+ python? ( dev-python/PyQt )
+ daap? ( www-servers/mongrel )"
+
+need-kde 3.3
+
+src_compile() {
+ # Extra, unsupported engines are forcefully disabled.
+ local myconf="$(use_enable mysql) $(use_enable postgres postgresql)
+ $(use_with opengl) --without-xmms
+ $(use_with visualization libvisual)
+ $(use_enable amazon)
+ $(use_with ipod libgpod)
+ $(use_with mp4 mp4v2)
+ $(use_with ifp)
+ $(use_with real helix)
+ $(use_with njb libnjb)
+ $(use_with mtp libmtp)
+ $(use_with musicbrainz)
+ $(use_with daap)
+ --with-xine
+ --without-mas
+ --without-nmm"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ # As much as I respect Ian, I'd rather leave Amarok to use mongrel
+ # from Portage, for security and policy reasons.
+ rm -rf "${D}"/usr/share/apps/amarok/ruby_lib/rbconfig \
+ "${D}"/usr/share/apps/amarok/ruby_lib/mongrel* \
+ "${D}"/usr/share/apps/amarok/ruby_lib/rubygems* \
+ "${D}"/usr/share/apps/amarok/ruby_lib/gem* \
+ "${D}"/usr/$(get_libdir)/ruby_lib
+
+ if ! use python; then
+ rm -r "${D}"/usr/share/apps/amarok/scripts/webcontrol \
+ || die "Unable to remove webcontrol."
+ fi
+}
diff --git a/media-sound/amarok/files/digest-amarok-1.4.8 b/media-sound/amarok/files/digest-amarok-1.4.8
new file mode 100644
index 000000000000..2aab36ff9018
--- /dev/null
+++ b/media-sound/amarok/files/digest-amarok-1.4.8
@@ -0,0 +1,3 @@
+MD5 7f65c4a8f3f0ff9042a5b5dd21b36cc8 amarok-1.4.8.tar.bz2 12699378
+RMD160 b557f6f5f14c304ae82c8d5537263ecc1faa922e amarok-1.4.8.tar.bz2 12699378
+SHA256 12877e60dc5a362e37dc4c775cc809ce8e5a15c13211902f6a821f238a45aae5 amarok-1.4.8.tar.bz2 12699378