summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-09 17:33:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-09 17:33:43 +0000
commitd75424b0c9c9bd00e415483914ef6a5333ade4ea (patch)
tree3721087ddd7cfa3678e0e4c3ae15069ccddebdf5 /media-sound/alsaplayer
parentTypo (diff)
downloadgentoo-2-d75424b0c9c9bd00e415483914ef6a5333ade4ea.tar.gz
gentoo-2-d75424b0c9c9bd00e415483914ef6a5333ade4ea.tar.bz2
gentoo-2-d75424b0c9c9bd00e415483914ef6a5333ade4ea.zip
Force a decent behaviour with respect to C(XX)FLAGS.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'media-sound/alsaplayer')
-rw-r--r--media-sound/alsaplayer/ChangeLog6
-rw-r--r--media-sound/alsaplayer/alsaplayer-0.99.76-r3.ebuild12
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.76-cxxflags.patch95
3 files changed, 108 insertions, 5 deletions
diff --git a/media-sound/alsaplayer/ChangeLog b/media-sound/alsaplayer/ChangeLog
index 52235c6a7d97..26383b0b5148 100644
--- a/media-sound/alsaplayer/ChangeLog
+++ b/media-sound/alsaplayer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/alsaplayer
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/ChangeLog,v 1.47 2006/07/09 17:14:09 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/ChangeLog,v 1.48 2006/07/09 17:33:43 flameeyes Exp $
+
+ 09 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/alsaplayer-0.99.76-cxxflags.patch, alsaplayer-0.99.76-r3.ebuild:
+ Force a decent behaviour with respect to C(XX)FLAGS.
09 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
-alsaplayer-0.99.76.ebuild, -alsaplayer-0.99.76-r1.ebuild:
diff --git a/media-sound/alsaplayer/alsaplayer-0.99.76-r3.ebuild b/media-sound/alsaplayer/alsaplayer-0.99.76-r3.ebuild
index 852dd945c531..d4e4bd27061f 100644
--- a/media-sound/alsaplayer/alsaplayer-0.99.76-r3.ebuild
+++ b/media-sound/alsaplayer/alsaplayer-0.99.76-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/alsaplayer-0.99.76-r3.ebuild,v 1.4 2006/04/28 19:22:00 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/alsaplayer-0.99.76-r3.ebuild,v 1.5 2006/07/09 17:33:43 flameeyes Exp $
-inherit eutils
+inherit eutils autotools
DESCRIPTION="Media player primarily utilising ALSA"
HOMEPAGE="http://www.alsaplayer.org/"
@@ -40,6 +40,9 @@ src_unpack() {
fi
epatch "${FILESDIR}/${P}-join-null-thread.patch"
+ epatch "${FILESDIR}/${P}-cxxflags.patch"
+
+ eautoreconf
}
src_compile() {
@@ -69,13 +72,14 @@ src_compile() {
$(use_enable vorbis oggvorbis) \
${myconf} \
--disable-gtk \
- --disable-sgi --disable-dependency-tracking
+ --disable-sgi --disable-dependency-tracking \
+ || die "econf failed"
emake || die "make failed"
}
src_install() {
- make DESTDIR=${D} docdir=${D}/usr/share/doc/${PF} install \
+ emake DESTDIR="${D}" docdir="${D}/usr/share/doc/${PF}" install \
|| die "make install failed"
dodoc AUTHORS ChangeLog README TODO
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.76-cxxflags.patch b/media-sound/alsaplayer/files/alsaplayer-0.99.76-cxxflags.patch
new file mode 100644
index 000000000000..875b940e825f
--- /dev/null
+++ b/media-sound/alsaplayer/files/alsaplayer-0.99.76-cxxflags.patch
@@ -0,0 +1,95 @@
+Index: alsaplayer-0.99.76/configure.ac
+===================================================================
+--- alsaplayer-0.99.76.orig/configure.ac
++++ alsaplayer-0.99.76/configure.ac
+@@ -585,17 +585,6 @@ AM_CONDITIONAL(ARCH_686,test "$ARCH_TYPE
+ AM_CONDITIONAL(ARCH_PPC,test "$ARCH_TYPE" = "ppc")
+ AM_CONDITIONAL(ARCH_ULTRA,test "$ARCH_TYPE" = "sun4u")
+
+-AC_MSG_CHECKING(for gcc optimization flags)
+-old_cflags=$CFLAGS
+-CFLAGS="$CFLAGS -O2 -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
+-AC_TRY_COMPILE([#include <stdio.h>],
+-[ printf ("hello, world"); ],
+-[ EXTRA_OPT_CFLAGS="-O2 -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"],[ EXTRA_OPT_CFLAGS=""])
+-CFLAGS=$old_cflags
+-AC_MSG_RESULT([$EXTRA_OPT_CFLAGS])
+-
+-ARCH_CFLAGS="$EXTRA_OPT_CFLAGS $CFLAGS"
+-
+ if test "$ARCH_TYPE" = "i486" || test "$ARCH_TYPE" = "i586" || test "$ARCH_TYPE" = "i686"
+ then
+ AC_DEFINE(ARCH_X86, 1, [Define if on x86 platform])
+Index: alsaplayer-0.99.76/app/Makefile.am
+===================================================================
+--- alsaplayer-0.99.76.orig/app/Makefile.am
++++ alsaplayer-0.99.76/app/Makefile.am
+@@ -27,7 +27,6 @@ INCLUDES = -I$(top_srcdir)/alsaplayer -I
+
+ AM_CXXFLAGS = $(COMMON_FLAGS)
+
+-AM_CFLAGS = $(CXXFLAGS)
+
+ bin_PROGRAMS = alsaplayer
+
+Index: alsaplayer-0.99.76/input/mad/Makefile.am
+===================================================================
+--- alsaplayer-0.99.76.orig/input/mad/Makefile.am
++++ alsaplayer-0.99.76/input/mad/Makefile.am
+@@ -28,8 +28,6 @@ COMMON_CFLAGS = -I$(top_builddir) -I$(to
+
+ AM_CFLAGS = $(COMMON_CFLAGS)
+
+-AM_CXXFLAGS = $(CFLAGS)
+-
+ INCLUDES = -I$(ROOT_DIR)/app $(GLIB_CFLAGS)
+
+ libmad_in_la_SOURCES = $(mad_insources)
+Index: alsaplayer-0.99.76/interface/daemon/Makefile.am
+===================================================================
+--- alsaplayer-0.99.76.orig/interface/daemon/Makefile.am
++++ alsaplayer-0.99.76/interface/daemon/Makefile.am
+@@ -10,7 +10,6 @@ AM_CXXFLAGS = @DFLAGS@ $(COMMON_FLAGS) \
+ -D_REENTRANT -I$(top_builddir) -I$(top_srcdir)/alsaplayer \
+ -DADDON_DIR=\"$(ADDON_DIR)\"
+
+-AM_CFLAGS = $(CXXFLAGS)
+
+ libdir = $(ADDON_DIR)/interface
+
+Index: alsaplayer-0.99.76/interface/gtk/Makefile.am
+===================================================================
+--- alsaplayer-0.99.76.orig/interface/gtk/Makefile.am
++++ alsaplayer-0.99.76/interface/gtk/Makefile.am
+@@ -25,7 +25,6 @@ AM_CXXFLAGS = -I$(top_builddir) -I$(top_
+ @GLIB_CFLAGS@ @GTK_CFLAGS@ $(COMMON_FLAGS) \
+ -D_REENTRANT -DADDON_DIR=\"$(ADDON_DIR)\"
+
+-AM_CFLAGS = $(CXXFLAGS)
+
+ libdir = $(ADDON_DIR)/interface
+
+Index: alsaplayer-0.99.76/interface/text/Makefile.am
+===================================================================
+--- alsaplayer-0.99.76.orig/interface/text/Makefile.am
++++ alsaplayer-0.99.76/interface/text/Makefile.am
+@@ -10,7 +10,6 @@ AM_CXXFLAGS = @DFLAGS@ $(COMMON_FLAGS) \
+ -D_REENTRANT -I$(top_builddir) -I$(top_srcdir)/alsaplayer \
+ -DADDON_DIR=\"$(ADDON_DIR)\"
+
+-AM_CFLAGS = $(CXXFLAGS)
+
+ libdir = $(ADDON_DIR)/interface
+
+Index: alsaplayer-0.99.76/interface/xosd/Makefile.am
+===================================================================
+--- alsaplayer-0.99.76.orig/interface/xosd/Makefile.am
++++ alsaplayer-0.99.76/interface/xosd/Makefile.am
+@@ -22,7 +22,6 @@ AM_CXXFLAGS = @DFLAGS@ $(COMMON_FLAGS) \
+ -D_REENTRANT -I$(top_builddir) -I$(top_srcdir)/alsaplayer \
+ -DADDON_DIR=\"$(ADDON_DIR)\"
+
+-AM_CFLAGS = $(CXXFLAGS)
+
+ libdir = $(ADDON_DIR)/interface
+