summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-10-03 14:41:31 +0000
committerChristian Heim <phreak@gentoo.org>2007-10-03 14:41:31 +0000
commitc2c0afe87ab801364128ee6175dc866c95eebef0 (patch)
treed5a98e78666b1d71ec7d8da75dc2ccca0df19f1d /media-sound/alsa-utils
parentRe-add ~sparc wrt #189372 (diff)
downloadgentoo-2-c2c0afe87ab801364128ee6175dc866c95eebef0.tar.gz
gentoo-2-c2c0afe87ab801364128ee6175dc866c95eebef0.tar.bz2
gentoo-2-c2c0afe87ab801364128ee6175dc866c95eebef0.zip
Revision bump, removing the wrong call to modules-update, module-init-tools has been stable for a looong while.
(Portage version: 2.1.3.9)
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/ChangeLog10
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.14-r2.ebuild88
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.14-alsaconf-modules-update.patch18
-rw-r--r--media-sound/alsa-utils/files/digest-alsa-utils-1.0.14-r23
4 files changed, 118 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 56615b10ef4d..71f574cda163 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.216 2007/09/17 17:06:31 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.217 2007/10/03 14:41:30 phreak Exp $
+
+*alsa-utils-1.0.14-r2 (03 Oct 2007)
+
+ 03 Oct 2007; Christian Heim <phreak@gentoo.org>
+ +files/alsa-utils-1.0.14-alsaconf-modules-update.patch,
+ +alsa-utils-1.0.14-r2.ebuild:
+ Revision bump, removing the wrong call to modules-update, module-init-tools
+ has been stable for a looong while.
17 Sep 2007; Christian Heim <phreak@gentoo.org>
+files/alsa-utils-1.0.15_rc1-seq.patch, alsa-utils-1.0.15_rc1.ebuild:
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.14-r2.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.14-r2.ebuild
new file mode 100644
index 000000000000..ac0a14ab607d
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.14-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.14-r2.ebuild,v 1.1 2007/10/03 14:41:30 phreak Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit eutils autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls midi"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-1.0.14"
+RDEPEND="${DEPEND}
+ virtual/modutils
+ sys-apps/pciutils"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use midi && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build alsa-utils with midi support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.11_rc2-nls.patch"
+ epatch "${FILESDIR}/${PN}-1.0.11_rc5-alsaconf-redirect.patch"
+ epatch "${FILESDIR}/${P}-seq.patch"
+ epatch "${FILESDIR}/${P}-remove-debug-printing.patch"
+ epatch "${FILESDIR}"/${P}-alsaconf-modules-update.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable midi sequencer) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+
+ newinitd "${FILESDIR}/alsasound.initd" alsasound
+ newconfd "${FILESDIR}/alsasound.confd" alsasound
+ insinto /etc/modules.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ echo
+ elog "To take advantage of the init script, and automate the process of"
+ elog "loading and unloading the ALSA sound drivers as well as"
+ elog "storing and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog " # rc-update add alsasound boot"
+ echo
+}
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.14-alsaconf-modules-update.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.14-alsaconf-modules-update.patch
new file mode 100644
index 000000000000..a20f8918c6e7
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.14-alsaconf-modules-update.patch
@@ -0,0 +1,18 @@
+--- a/alsaconf/alsaconf.in
++++ b/alsaconf/alsaconf.in
+@@ -904,13 +904,8 @@ BEGIN { in_sound=0; }
+
+ farewell
+ clear
+- if [ "$distribution" = "gentoo" ]; then
+- xecho "Running modules-update..."
+- modules-update
+- elif [ "$distribution" = "debian" ]; then
+- xecho "Running update-modules..."
+- update-modules
+- fi
++ xecho "Running update-modules..."
++ update-modules
+ if [ -x $rcalsasound ] ; then
+ echo Loading driver...
+ $rcalsasound restart
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-1.0.14-r2 b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.14-r2
new file mode 100644
index 000000000000..53fead4703ee
--- /dev/null
+++ b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.14-r2
@@ -0,0 +1,3 @@
+MD5 6d3009c157ac6fc803696d6590a48366 alsa-utils-1.0.14.tar.bz2 1013872
+RMD160 e912588fc6ad223c7176847b8f99c80dd2ca7bb5 alsa-utils-1.0.14.tar.bz2 1013872
+SHA256 307d630f0ed15e7e92fa35dc0c961737fa9aed22bd7a4a6054a72f85145fa5cb alsa-utils-1.0.14.tar.bz2 1013872