summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-12-07 14:31:19 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-12-07 14:31:19 +0000
commitaf313c48e734d23c643bbdfb561b7110433f4fc8 (patch)
tree7e1e2383c31f0966fa3a55d5c407ceccc50c105b /media-radio
parentDo not filter duplicate CFLAGS (bug 411095). Thanks D.Dexter (diff)
downloadgentoo-2-af313c48e734d23c643bbdfb561b7110433f4fc8.tar.gz
gentoo-2-af313c48e734d23c643bbdfb561b7110433f4fc8.tar.bz2
gentoo-2-af313c48e734d23c643bbdfb561b7110433f4fc8.zip
Version bump
(Portage version: 2.1.11.33/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xastir/ChangeLog10
-rw-r--r--media-radio/xastir/files/xastir-2.0.4-fortify.diff144
-rw-r--r--media-radio/xastir/files/xastir-2.0.4-no-builtin-shapelib.diff58
-rw-r--r--media-radio/xastir/files/xastir-2.0.4-scripts.diff101
-rw-r--r--media-radio/xastir/xastir-2.0.4.ebuild79
5 files changed, 391 insertions, 1 deletions
diff --git a/media-radio/xastir/ChangeLog b/media-radio/xastir/ChangeLog
index 7b88bd9aee03..7a4464482c49 100644
--- a/media-radio/xastir/ChangeLog
+++ b/media-radio/xastir/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-radio/xastir
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/ChangeLog,v 1.29 2012/12/07 14:27:31 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/ChangeLog,v 1.30 2012/12/07 14:31:19 tomjbe Exp $
+
+*xastir-2.0.4 (07 Dec 2012)
+
+ 07 Dec 2012; Thomas Beierlein <tomjbe@gentoo.org> +xastir-2.0.4.ebuild,
+ +files/xastir-2.0.4-fortify.diff,
+ +files/xastir-2.0.4-no-builtin-shapelib.diff,
+ +files/xastir-2.0.4-scripts.diff:
+ Version bump
07 Dec 2012; Thomas Beierlein <tomjbe@gentoo.org> xastir-2.0.0-r2.ebuild,
+files/xastir-2.0.0-dont-filter-flags.diff:
diff --git a/media-radio/xastir/files/xastir-2.0.4-fortify.diff b/media-radio/xastir/files/xastir-2.0.4-fortify.diff
new file mode 100644
index 000000000000..e2c34b007475
--- /dev/null
+++ b/media-radio/xastir/files/xastir-2.0.4-fortify.diff
@@ -0,0 +1,144 @@
+--- src/rac_data.c.orig 2012-09-23 18:19:22.000000000 +0200
++++ src/rac_data.c 2012-11-29 21:00:53.000000000 +0100
+@@ -212,7 +212,8 @@
+ char char_offset[16];
+ char index[32];
+ int found = 0;
+- rac_record racdata;
++ char buffer[sizeof(rac_record)];
++ rac_record *racdata = (rac_record *)buffer;
+ /*char filler[8];*/
+ char amacall_path[MAX_VALUE];
+
+@@ -220,7 +221,7 @@
+
+
+ xastir_snprintf(index, sizeof(index)," ");
+- xastir_snprintf(racdata.callsign, sizeof(racdata.callsign)," ");
++ xastir_snprintf(racdata->callsign, sizeof(racdata->callsign)," ");
+
+ /* ==================================================================== */
+ /* Search thru the index, get the RBA */
+@@ -257,19 +258,19 @@
+ if (callsign[5] == '-')
+ (void)chomp(callsign,5);
+
+- while (!feof(fdb) && strncmp((char *)&racdata, callsign, 6) < 0)
++ while (!feof(fdb) && strncmp(buffer, callsign, 6) < 0)
+
+ //WE7U
+ // Problem here: We're sticking 8 bytes too many into racdata!
+- rc = fgets((char *)&racdata, sizeof(racdata), fdb);
++ rc = fgets(buffer, sizeof(buffer), fdb);
+
+ } else
+ fprintf(stderr,"Search:Could not open RAC data base: %s\n", get_data_base_dir("fcc/AMACALL.LST") );
+
+ /* || (callsign[5] == '-' && strncmp((char *)&racdata,callsign,5) < 0)) */
+- (void)chomp(racdata.callsign, 6);
++ (void)chomp(racdata->callsign, 6);
+
+- if (!strncmp((char *)racdata.callsign, callsign, 6)) {
++ if (!strncmp(racdata->callsign, callsign, 6)) {
+ found = 1;
+
+ // Some of these cause problems on 64-bit processors, so commented
+@@ -293,82 +294,82 @@
+ xastir_snprintf(data->callsign,
+ sizeof(data->callsign),
+ "%s",
+- racdata.callsign);
++ racdata->callsign);
+
+ xastir_snprintf(data->first_name,
+ sizeof(data->first_name),
+ "%s",
+- racdata.first_name);
++ racdata->first_name);
+
+ xastir_snprintf(data->last_name,
+ sizeof(data->last_name),
+ "%s",
+- racdata.last_name);
++ racdata->last_name);
+
+ xastir_snprintf(data->address,
+ sizeof(data->address),
+ "%s",
+- racdata.address);
++ racdata->address);
+
+ xastir_snprintf(data->city,
+ sizeof(data->city),
+ "%s",
+- racdata.city);
++ racdata->city);
+
+ xastir_snprintf(data->province,
+ sizeof(data->province),
+ "%s",
+- racdata.province);
++ racdata->province);
+
+ xastir_snprintf(data->postal_code,
+ sizeof(data->postal_code),
+ "%s",
+- racdata.postal_code);
++ racdata->postal_code);
+
+ xastir_snprintf(data->qual_a,
+ sizeof(data->qual_a),
+ "%s",
+- racdata.qual_a);
++ racdata->qual_a);
+
+ xastir_snprintf(data->qual_b,
+ sizeof(data->qual_b),
+ "%s",
+- racdata.qual_b);
++ racdata->qual_b);
+
+ xastir_snprintf(data->qual_c,
+ sizeof(data->qual_c),
+ "%s",
+- racdata.qual_c);
++ racdata->qual_c);
+
+ xastir_snprintf(data->qual_d,
+ sizeof(data->qual_d),
+ "%s",
+- racdata.qual_d);
++ racdata->qual_d);
+
+ xastir_snprintf(data->club_name,
+ sizeof(data->club_name),
+ "%s",
+- racdata.club_name);
++ racdata->club_name);
+
+ xastir_snprintf(data->club_address,
+ sizeof(data->club_address),
+ "%s",
+- racdata.club_address);
++ racdata->club_address);
+
+ xastir_snprintf(data->club_city,
+ sizeof(data->club_city),
+ "%s",
+- racdata.club_city);
++ racdata->club_city);
+
+ xastir_snprintf(data->club_province,
+ sizeof(data->club_province),
+ "%s",
+- racdata.club_province);
++ racdata->club_province);
+
+ xastir_snprintf(data->club_postal_code,
+ sizeof(data->club_postal_code),
+ "%s",
+- racdata.club_postal_code);
++ racdata->club_postal_code);
+
+ }
+ (void)fclose(fdb);
diff --git a/media-radio/xastir/files/xastir-2.0.4-no-builtin-shapelib.diff b/media-radio/xastir/files/xastir-2.0.4-no-builtin-shapelib.diff
new file mode 100644
index 000000000000..7aef072a5c39
--- /dev/null
+++ b/media-radio/xastir/files/xastir-2.0.4-no-builtin-shapelib.diff
@@ -0,0 +1,58 @@
+--- configure.ac.orig 2012-11-30 08:29:51.000000000 +0100
++++ configure.ac 2012-11-30 08:29:56.000000000 +0100
+@@ -368,27 +368,17 @@
+
+ # Check for Shapelib
+ use_shapelib=yes
+-force_internal_shapelib=no
+ shapelib_desired=yes
+ LIBSHP=""
+ SUBSHP=""
+ # This symbol will be blank if the proj library hasn't been found, and will
+ # have the three programs that need proj if it has
+ CONTSHP=""
+-AC_ARG_WITH(internal-shapelib,[ --with-internal-shapelib Force use of internal shapelib library.],force_internal_shapelib=$withval)
+ AC_ARG_WITH(shapelib,[ --without-shapelib Disable shapelib features.],shapelib_desired=$withval)
+ if test "${shapelib_desired}" = "no"; then
+ use_shapelib=no
+- force_internal_shapelib=no
+ fi
+-if test "${force_internal_shapelib}" = "yes"; then
+- AC_MSG_WARN([***************************************************************** ])
+- AC_MSG_WARN([Internal Shapelib library has been forced. ])
+- AC_MSG_WARN([***************************************************************** ])
+- # Temporary setting to get into if block below
+- use_shapelib=no
+-fi
+-if test "${shapelib_desired}" = "yes" -a "${force_internal_shapelib}" = "no"; then
++if test "${shapelib_desired}" = "yes" ; then
+ use_shapelib=no
+ AC_CHECK_HEADERS(shapefil.h libshp/shapefil.h, [AC_CHECK_LIB(shp, DBFOpen, use_shapelib=yes
+ LIBS="$LIBS -lshp"
+@@ -397,26 +387,6 @@
+ AC_DEFINE(HAVE_LIBSHP, , Define to 1 if you have the `shp' library (-lshp). )
+ break)])
+ fi
+-if test "${shapelib_desired}" = "yes" -a "${use_shapelib}" = "no"; then
+- AC_MSG_WARN([**************************************************************** ])
+- AC_MSG_WARN([Your system does not have shapelib installed. Using an internal ])
+- AC_MSG_WARN([version. This may lead to a larger filesize for the executable. ])
+- AC_MSG_WARN([Install shapelib on your system to eliminate this warning. ])
+- AC_MSG_WARN([**************************************************************** ])
+- LIBSHP="-Lshapelib -lshape"
+- CPPFLAGS="-I\$(top_srcdir)/src/shapelib $CPPFLAGS"
+- SUBSHP="shapelib"
+- use_shapelib=yes
+- force_internal_shapelib=yes
+- AC_DEFINE(HAVE_DBFGETFIELDINDEX, , Define to 1 if your `shp' library has DBFGetFieldIndex. )
+- AC_DEFINE(HAVE_LIBSHP, , Define to 1 if you have the `shp' library (-lshp). )
+- AC_DEFINE(HAVE_SHAPEFIL_H, , Define to 1 if you have the `shapefil.h' header. )
+-
+- if test $use_proj = "yes"
+- then
+- CONTSHP="shpcentrd shpproj shpdata shpwkb"
+- fi
+-fi
+ AC_SUBST(SUBSHP)
+ AC_SUBST(CONTSHP)
+ AC_SUBST(LIBSHP)
diff --git a/media-radio/xastir/files/xastir-2.0.4-scripts.diff b/media-radio/xastir/files/xastir-2.0.4-scripts.diff
new file mode 100644
index 000000000000..369295b07f8c
--- /dev/null
+++ b/media-radio/xastir/files/xastir-2.0.4-scripts.diff
@@ -0,0 +1,101 @@
+# patch scripts location (bug #407185). partially backported from upstream.
+--- xastir-2.0.0-orig/scripts/Makefile.am.orig 2012-11-27 05:41:23.000000000 +0100
++++ xastir-2.0.0/scripts/Makefile.am 2012-12-05 06:21:59.000000000 +0100
+@@ -12,9 +12,7 @@
+ get-fcc-rac.pl \
+ get-gnis \
+ get-pop \
+- get-maptools.sh \
+ get-NWSdata \
+- get_shapelib.sh \
+ gpx2shape \
+ icontable.pl \
+ inf2geo.pl \
+@@ -43,10 +41,8 @@
+ values \
+ values.pl \
+ waypoint-get.pl \
+- xastir-fixcfg.sh \
+- xastir-migrate.sh \
+ Xastir_tigerpoly.py
+
+ install-data-hook:
+ cd $(DESTDIR)$(scriptsdir) && \
+- chmod a+x *.sh *.pl *.py get-* gpx2* *.bash
++ chmod a+x *.pl *.py get-* gpx2* *.bash
+diff -Nur -u xastir-2.0.0.orig/scripts/coord-convert.pl xastir-2.0.0/scripts/coord-convert.pl
+--- xastir-2.0.0.orig/scripts/coord-convert.pl 2010-07-03 22:09:48.000000000 +0000
++++ xastir-2.0.0/scripts/coord-convert.pl 2012-03-07 15:46:01.000000000 +0000
+@@ -26,7 +26,7 @@
+ #
+
+
+-use lib "${prefix}/lib";
++use lib /usr/share/xastir/scripts;
+ use Coordinate; # WE7U's Coordinate.pm module
+
+
+diff -Nur -u xastir-2.0.0.orig/scripts/permutations.pl xastir-2.0.0/scripts/permutations.pl
+--- xastir-2.0.0.orig/scripts/permutations.pl 2010-07-03 22:09:48.000000000 +0000
++++ xastir-2.0.0/scripts/permutations.pl 2012-03-07 15:42:34.000000000 +0000
+@@ -34,7 +34,7 @@
+ #
+
+
+-use lib "/usr/local/lib";
++use lib "/usr/share/xastir/scripts";
+ use Coordinate; # WE7U's Coordinate.pm module
+
+
+diff -Nur -u xastir-2.0.0.orig/scripts/test_coord.pl xastir-2.0.0/scripts/test_coord.pl
+--- xastir-2.0.0.orig/scripts/test_coord.pl 2010-01-31 02:12:23.000000000 +0000
++++ xastir-2.0.0/scripts/test_coord.pl 2012-03-07 15:42:34.000000000 +0000
+@@ -33,7 +33,7 @@
+
+ #------------------------------------------------------------------------------------------------
+
+-use lib "/usr/local/lib";
++use lib "/usr/share/xastir/scripts";
+ use Coordinate; # Snag WE7U's Coordinate module
+
+
+diff -Nur -u xastir-2.0.0.orig/scripts/toporama250k.pl xastir-2.0.0/scripts/toporama250k.pl
+--- xastir-2.0.0.orig/scripts/toporama250k.pl 2010-01-31 02:12:23.000000000 +0000
++++ xastir-2.0.0/scripts/toporama250k.pl 2012-03-07 15:46:49.000000000 +0000
+@@ -28,14 +28,14 @@
+ # map files for the whole of Canada!
+ #
+ #
+-# - "cd /usr/local/share/xastir/maps"
++# - "cd /usr/share/xastir/maps"
+ #
+ # - Assure you have write privileges in the directory above either
+ # by becoming root using the "su" command, using "sudo", or
+ # temporarily changing ownership and/or privileges on the
+ # "maps" directory.
+ #
+-# - "/usr/local/lib/xastir/toporama250k.pl"
++# - "/usr/share/xastir/scripts/toporama250k.pl"
+ #
+ # - The script will create/populate this directory heirarchy:
+ # .../maps/toporama/images/
+diff -Nur -u xastir-2.0.0.orig/scripts/toporama50k.pl xastir-2.0.0/scripts/toporama50k.pl
+--- xastir-2.0.0.orig/scripts/toporama50k.pl 2010-01-31 02:12:23.000000000 +0000
++++ xastir-2.0.0/scripts/toporama50k.pl 2012-03-07 15:47:01.000000000 +0000
+@@ -27,14 +27,14 @@
+ # map files for the whole of Canada!
+ #
+ #
+-# - "cd /usr/local/share/xastir/maps"
++# - "cd /usr/share/xastir/maps"
+ #
+ # - Assure you have write privileges in the directory above either
+ # by becoming root using the "su" command, using "sudo", or
+ # temporarily changing ownership and/or privileges on the
+ # "maps" directory.
+ #
+-# - "/usr/local/lib/xastir/toporama50k.pl"
++# - "/usr/share/xastir/scripts/toporama50k.pl"
+ #
+ # - The script will create/populate this directory heirarchy:
+ # .../maps/toporama/images/
diff --git a/media-radio/xastir/xastir-2.0.4.ebuild b/media-radio/xastir/xastir-2.0.4.ebuild
new file mode 100644
index 000000000000..080cbd2eba50
--- /dev/null
+++ b/media-radio/xastir/xastir-2.0.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/xastir-2.0.4.ebuild,v 1.1 2012/12/07 14:31:19 tomjbe Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="X Amateur Station Tracking and Information Reporting"
+HOMEPAGE="http://xastir.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="festival gdal geotiff graphicsmagick"
+
+DEPEND=">=x11-libs/motif-2.3:0
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-apps/xfontsel
+ dev-libs/libpcre
+ net-misc/curl
+ sys-libs/db
+ sci-libs/shapelib
+ !graphicsmagick? ( media-gfx/imagemagick[-hdri,-q32] )
+ graphicsmagick? ( media-gfx/graphicsmagick[-q32] )
+ geotiff? ( sci-libs/proj
+ sci-libs/libgeotiff
+ media-libs/tiff )
+ gdal? ( sci-libs/gdal )
+ festival? ( app-accessibility/festival )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix script location (bug #407185)
+ epatch "${FILESDIR}"/${P}-scripts.diff
+
+ # fix __FORTIFY_SOURCE warning (bug #337365)
+ epatch "${FILESDIR}"/${P}-fortify.diff
+
+ # do not use builtin shapelib if sci-libs/shapelib is not installed
+ # instead build without shapelib support (bug #430704)
+ epatch "${FILESDIR}"/${P}-no-builtin-shapelib.diff
+
+ # do not filter duplicate flags (see bug 411095)
+ epatch "${FILESDIR}"/${PN}-2.0.0-dont-filter-flags.diff
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pcre \
+ --with-shapelib \
+ --with-dbfawk \
+ --without-ax25 \
+ --without-gpsman \
+ $(use_with !graphicsmagick imagemagick) \
+ $(use_with graphicsmagick) \
+ $(use_with geotiff libproj) \
+ $(use_with geotiff) \
+ $(use_with gdal) \
+ $(use_with festival)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+ dodoc AUTHORS ChangeLog FAQ README README.Contributing \
+ README.Getting-Started README.MAPS
+}
+
+pkg_postinst() {
+ elog "Kernel mode AX.25 and GPSman library not supported."
+ elog
+ elog "Remember you have to be root to add addditional scripts,"
+ elog "maps and other configuration data under /usr/share/xastir."
+}