summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-10-25 18:31:17 +0000
committerChristian Ruppert <idl0r@gentoo.org>2010-10-25 18:31:17 +0000
commit8e76457f211ea5b076abed5fd24cca74a0df4dae (patch)
tree927094e062d70f261b10240fa0403999a393f228 /media-plugins
parentFix building on ppc-macos by dropping -g from hardwired CFLAGS (diff)
downloadgentoo-2-8e76457f211ea5b076abed5fd24cca74a0df4dae.tar.gz
gentoo-2-8e76457f211ea5b076abed5fd24cca74a0df4dae.tar.bz2
gentoo-2-8e76457f211ea5b076abed5fd24cca74a0df4dae.zip
New useflags. Cleanup & QA fixes. Dependencies fixed. Respect CFLAGS/CXXFLAGS/LDFLAGS and fix linking with as-needed through the build-system patch.
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-xineliboutput/ChangeLog9
-rw-r--r--media-plugins/vdr-xineliboutput/files/vdr-xineliboutput-9999-build-system.patch201
-rw-r--r--media-plugins/vdr-xineliboutput/metadata.xml22
-rw-r--r--media-plugins/vdr-xineliboutput/vdr-xineliboutput-9999.ebuild204
4 files changed, 320 insertions, 116 deletions
diff --git a/media-plugins/vdr-xineliboutput/ChangeLog b/media-plugins/vdr-xineliboutput/ChangeLog
index 08ecef9ecbfe..cd7295b31bf1 100644
--- a/media-plugins/vdr-xineliboutput/ChangeLog
+++ b/media-plugins/vdr-xineliboutput/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/vdr-xineliboutput
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xineliboutput/ChangeLog,v 1.55 2010/10/05 13:35:22 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xineliboutput/ChangeLog,v 1.56 2010/10/25 18:31:17 idl0r Exp $
+
+ 25 Oct 2010; Christian Ruppert <idl0r@gentoo.org>
+ vdr-xineliboutput-9999.ebuild,
+ +files/vdr-xineliboutput-9999-build-system.patch, metadata.xml:
+ New useflags. Cleanup & QA fixes. Dependencies fixed. Respect
+ CFLAGS/CXXFLAGS/LDFLAGS and fix linking with as-needed through the
+ build-system patch.
*vdr-xineliboutput-1.0.5-r1 (05 Oct 2010)
diff --git a/media-plugins/vdr-xineliboutput/files/vdr-xineliboutput-9999-build-system.patch b/media-plugins/vdr-xineliboutput/files/vdr-xineliboutput-9999-build-system.patch
new file mode 100644
index 000000000000..3e0a0b01fc1d
--- /dev/null
+++ b/media-plugins/vdr-xineliboutput/files/vdr-xineliboutput-9999-build-system.patch
@@ -0,0 +1,201 @@
+Index: Makefile
+===================================================================
+RCS file: /cvsroot/xineliboutput/vdr-xineliboutput/Makefile,v
+retrieving revision 1.94
+diff -u -b -B -r1.94 Makefile
+--- Makefile 19 Oct 2010 11:53:31 -0000 1.94
++++ Makefile 21 Oct 2010 15:33:10 -0000
+@@ -127,9 +127,9 @@
+ ### The name of executable and libraries
+ ###
+
+-VDRPLUGIN = libvdr-$(PLUGIN).so
+-VDRPLUGIN_SXFE = lib$(PLUGIN)-sxfe.so
+-VDRPLUGIN_FBFE = lib$(PLUGIN)-fbfe.so
++VDRPLUGIN = libvdr-$(PLUGIN).so.$(APIVERSION)
++VDRPLUGIN_SXFE = lib$(PLUGIN)-sxfe.so.$(VERSION)
++VDRPLUGIN_FBFE = lib$(PLUGIN)-fbfe.so.$(VERSION)
+ VDRSXFE = vdr-sxfe
+ VDRFBFE = vdr-fbfe
+ XINEINPUTVDR = xineplug_inp_xvdr.so
+@@ -273,9 +273,9 @@
+ $(CC) $(CFLAGS) -c $(DEFINES) $(INCLUDES) $(CFLAGS_X11) $(OPTFLAGS) -o $@ $<
+
+ ### Internationalization (I18N):
+-
++ifeq ($(HAVE_I18N), yes)
+ PODIR = po
+-LOCALEDIR ?= $(VDRDIR)/locale
++LOCALEDIR ?= $(DESTDIR)$(VDRDIR)/locale
+ I18Npo = $(wildcard $(PODIR)/*.po)
+ I18Nmsgs = $(addprefix $(LOCALEDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
+ I18Npot = $(PODIR)/$(PLUGIN).pot
+@@ -293,6 +293,7 @@
+ $(I18Nmsgs): $(LOCALEDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
+ @mkdir -p $(dir $@)
+ cp $< $@
++endif
+
+ .PHONY: i18n
+ i18n: $(I18Nmsgs)
+@@ -311,7 +312,7 @@
+ install : XINELIBOUTPUT_INSTALL_MSG =
+
+ .PHONY: all
+-all: config $(TARGETS_VDR) frontends i18n
++all: config $(TARGETS_VDR) frontends
+
+ frontends: config $(TARGETS_FE) $(TARGETS_XINE)
+ $(XINELIBOUTPUT_INSTALL_MSG)
+@@ -327,50 +328,44 @@
+ #
+
+ $(VDRPLUGIN): $(OBJS) $(OBJS_MPG)
+- $(CXX) $(CXXFLAGS) $(LDFLAGS_SO) $(OBJS) $(OBJS_MPG) $(LIBS) $(LIBS_VDR) -o $@
+- @-rm -rf $(LIBDIR)/$@.$(APIVERSION)
+- @cp $@ $(LIBDIR)/$@.$(APIVERSION)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS_SO) $(LDFLAGS) $(OBJS) $(OBJS_MPG) $(LIBS) $(LIBS_VDR) -o $@
+
+ #
+ # vdr-sxfe
+ #
+
+ $(VDRPLUGIN_SXFE): $(OBJS_SXFE_SO)
+- $(CC) $(CFLAGS) $(LDFLAGS_SO) $(OBJS_SXFE_SO) $(LIBS_X11) $(LIBS_XINE) $(LIBS_JPEG) -o $@
+- @-rm -rf $(LIBDIR)/$(VDRPLUGIN_SXFE).$(VERSION)
+- @cp $@ $(LIBDIR)/$(VDRPLUGIN_SXFE).$(VERSION)
++ $(CC) $(CFLAGS) $(LDFLAGS_SO) $(LDFLAGS) $(OBJS_SXFE_SO) $(LIBS_X11) $(LIBS_XINE) $(LIBS_JPEG) -o $@
+ $(VDRSXFE): $(OBJS_SXFE)
+- $(CC) -g $(OBJS_SXFE) $(LIBS_X11) $(LIBS_XINE) $(LIBS_JPEG) $(LIBS_PTHREAD) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS_SXFE) $(LIBS_X11) $(LIBS_XINE) $(LIBS_JPEG) $(LIBS_PTHREAD) -o $@
+
+ #
+ # vdr-fbfe
+ #
+
+ $(VDRPLUGIN_FBFE): $(OBJS_FBFE_SO)
+- $(CC) $(CFLAGS) $(LDFLAGS_SO) $(OBJS_FBFE_SO) $(LIBS_XINE) $(LIBS_JPEG) -o $@
+- @-rm -rf $(LIBDIR)/$(VDRPLUGIN_FBFE).$(VERSION)
+- @cp $@ $(LIBDIR)/$(VDRPLUGIN_FBFE).$(VERSION)
++ $(CC) $(CFLAGS) $(LDFLAGS_SO) $(LDFLAGS) $(OBJS_FBFE_SO) $(LIBS_XINE) $(LIBS_JPEG) -o $@
+ $(VDRFBFE): $(OBJS_FBFE)
+- $(CC) -g $(OBJS_FBFE) $(LIBS_XINE) $(LIBS_JPEG) $(LIBS_PTHREAD) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS_FBFE) $(LIBS_XINE) $(LIBS_JPEG) $(LIBS_PTHREAD) -o $@
+
+ #
+ # xine plugins
+ #
+
+ $(XINEINPUTVDR): $(OBJS_XINEINPUTVDR)
+- $(CC) $(CFLAGS) $(LDFLAGS_SO) $(LIBS_XINE) $(LIBS_AVUTIL) $(LIBS_PTHREAD) -o $@ $(OBJS_XINEINPUTVDR)
++ $(CC) $(CFLAGS) $(LDFLAGS_SO) $(LDFLAGS) $(OBJS_XINEINPUTVDR) $(LIBS_XINE) $(LIBS_AVUTIL) $(LIBS_PTHREAD) -o $@
+ $(XINEPOSTAUTOCROP): xine_post_autocrop.o
+- $(CC) $(CFLAGS) $(LDFLAGS_SO) $(LIBS_XINE) -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS_SO) $(LDFLAGS) $< -o $@ $(LIBS_XINE)
+ $(XINEPOSTSWSCALE): xine_post_swscale.o
+- $(CC) $(CFLAGS) $(LDFLAGS_SO) $(LIBS_XINE) -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS_SO) $(LDFLAGS) $< -o $@ $(LIBS_XINE)
+ $(XINEPOSTAUDIOCHANNEL): xine_post_audiochannel.o
+- $(CC) $(CFLAGS) $(LDFLAGS_SO) $(LIBS_XINE) -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS_SO) $(LDFLAGS) $< -o $@ $(LIBS_XINE)
+
+ #
+ # install
+ #
+
+-install: all
++install: all i18n
+ ifeq ($(XINELIBOUTPUT_XINEPLUGIN), yes)
+ @mkdir -p $(DESTDIR)/$(XINEPLUGINDIR)/post
+ @echo Installing $(DESTDIR)/$(XINEPLUGINDIR)/$(XINEINPUTVDR)
+@@ -391,12 +386,30 @@
+ @mkdir -p $(DESTDIR)/$(BINDIR)
+ @-rm -rf $(DESTDIR)/$(BINDIR)/vdr-fbfe
+ @$(INSTALL) -m 0755 vdr-fbfe $(DESTDIR)/$(BINDIR)/vdr-fbfe
++ifeq ($(XINELIBOUTPUT_VDRPLUGIN), yes)
++ @echo Installing $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN_FBFE)
++ @mkdir -p $(DESTDIR)$(LIBDIR)
++ @-rm -rf $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN_FBFE)
++ @$(INSTALL) -m 0755 $(VDRPLUGIN_FBFE) $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN_FBFE)
++endif
+ endif
+ ifeq ($(XINELIBOUTPUT_X11), yes)
+ @echo Installing $(DESTDIR)/$(BINDIR)/vdr-sxfe
+ @mkdir -p $(DESTDIR)/$(BINDIR)
+ @-rm -rf $(DESTDIR)/$(BINDIR)/vdr-sxfe
+ @$(INSTALL) -m 0755 vdr-sxfe $(DESTDIR)/$(BINDIR)/vdr-sxfe
++ifeq ($(XINELIBOUTPUT_VDRPLUGIN), yes)
++ @echo Installing $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN_SXFE)
++ @mkdir -p $(DESTDIR)$(LIBDIR)
++ @-rm -rf $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN_SXFE)
++ @$(INSTALL) -m 0755 $(VDRPLUGIN_SXFE) $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN_SXFE)
++endif
++endif
++ifeq ($(XINELIBOUTPUT_VDRPLUGIN), yes)
++ @echo Installing $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN)
++ @mkdir -p $(DESTDIR)$(LIBDIR)
++ @-rm -rf $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN)
++ @$(INSTALL) -D -m 0755 $(VDRPLUGIN) $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN)
+ endif
+
+ dist: clean
+@@ -413,6 +426,7 @@
+ tools/*.o tools/*~ tools/*.flc xine/*.o xine/*~ \
+ xine/*.flc $(VDR_FBFE) $(VDR_SXFE) mpg2c black_720x576.c \
+ nosignal_720x576.c vdrlogo_720x576.c vdr-sxfe vdr-fbfe \
+- $(PODIR)/*.mo $(PODIR)/*.pot \
+ features.h config.mak configure.log
+-
++ifeq ($(HAVE_I18N), yes)
++ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
++endif
+Index: configure
+===================================================================
+RCS file: /cvsroot/xineliboutput/vdr-xineliboutput/configure,v
+retrieving revision 1.28
+diff -u -b -B -r1.28 configure
+--- configure 19 Oct 2010 11:59:20 -0000 1.28
++++ configure 21 Oct 2010 15:33:10 -0000
+@@ -231,11 +231,11 @@
+ xshm
+ xdpms
+ xinerama
+- xrandr
+ xrender
+ xshape
+ opengl
+ vdpau
++ i18n
+ "
+
+ # set defaults
+@@ -266,11 +266,11 @@
+ echo " --disable-xshm disable XShm support [no]"
+ echo " --disable-xdpms disable Xdpms support [no]"
+ echo " --disable-xinerama disable Xinerama support [no]"
+- echo " --disable-xrandr disable Xrandr support (video mode switching) [no]"
+ echo " --disable-xrender disable Xrender support (HUD OSD) [no]"
+ echo " --disable-xshape disable Xshape support (non-transparent HUD OSD without composite manager) [no]"
+ echo " --disable-opengl disable OpenGL support (transparent HUD OSD without composite manager) [no]"
+ echo " --disable-vdpau disable VDPAU support (X11) [no]"
++ echo " --disable-xrandr disable Xrandr support (video mode switching) [no]"
+ echo
+ echo " --debug debug configure script"
+ echo " --disable-pkgconfig do not use pkg-config"
+@@ -324,7 +324,7 @@
+
+ check_deps(){
+ disabled libxine && disable x11 fb libavutil libjpeg
+- disabled x11 && disable dbus-glib-1 xshm xrender xshape opengl xrandr xdpms xinerama vdpau
++ disabled x11 && disable dbus-glib-1 xshm xrender xshape opengl xdpms xinerama vdpau
+ disabled vdr && disable libextractor
+ disabled xrender && disable opengl
+ disabled xshape && disable opengl
+@@ -365,7 +365,6 @@
+ test_library X11 xshm "X11/extensions/XShm.h" "-lXext" "XShmQueryExtension(0)"
+ test_library X11 xrender "X11/extensions/Xrender.h" "-lXrender" "XRenderQueryFormats(0)"
+ test_library X11 xshape "X11/extensions/shape.h" "-lXext" "XShapeQueryExtension(0,0,0)"
+- test_library X11 xrandr "X11/extensions/Xrandr.h" "-lXrandr" "XRRGetScreenInfo(0,0)"
+ test_library X11 xdpms "X11/extensions/dpms.h" "-lXext" "DPMSDisable(0)"
+ test_library X11 xinerama "X11/extensions/Xinerama.h" "-lXinerama" "XineramaQueryScreens(0,0)"
+ test_library X11 opengl "GL/glx.h" "-lGL -lGLU -lglut" "glXQueryVersion(0,0,0)"
diff --git a/media-plugins/vdr-xineliboutput/metadata.xml b/media-plugins/vdr-xineliboutput/metadata.xml
index 94ce61857b87..8ef702f21b78 100644
--- a/media-plugins/vdr-xineliboutput/metadata.xml
+++ b/media-plugins/vdr-xineliboutput/metadata.xml
@@ -2,17 +2,23 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>media-tv</herd>
- <maintainer>
- <email>vdr@gentoo.org</email>
- <name>Gentoo VDR Project</name>
- </maintainer>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
<longdescription>
- Video Disk Recorder Xinelib PlugIn ( VDR )
+ Video Disk Recorder Xinelib PlugIn ( VDR )
</longdescription>
<use>
- <flag name='libextractor'>Use <pkg>media-libs/libextract</pkg> to gather
+ <flag name="libextractor">Use <pkg>media-libs/libextract</pkg> to gather
files' metadata in media-player</flag>
- <flag name='vdr'>Compile the vdr output plugin to use local or remote xine as output</flag>
- <flag name='xine'>Compile the xine input plugin for displaying vdr video and OSD</flag>
+ <flag name="vdpau">Enables VDPAU support (requires nVidia video cards)
+ to offload MPEG2/MPEG4/VC1/WMV CPU processing to video card</flag>
+ <flag name="vdr">Compile the vdr output plugin to use local or remote xine as output</flag>
+ <flag name="xine">Compile the xine input plugin for displaying vdr video and OSD</flag>
</use>
</pkgmetadata>
diff --git a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-9999.ebuild b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-9999.ebuild
index 1350823d1799..ed7f0defb097 100644
--- a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-9999.ebuild
+++ b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xineliboutput/vdr-xineliboutput-9999.ebuild,v 1.4 2010/09/22 13:12:24 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xineliboutput/vdr-xineliboutput-9999.ebuild,v 1.5 2010/10/25 18:31:17 idl0r Exp $
GENTOO_VDR_CONDITIONAL=yes
-EAPI="2"
+EAPI="3"
-inherit vdr-plugin eutils multilib versionator cvs
+inherit vdr-plugin cvs toolchain-funcs eutils
MY_PV=${PV#*_p}
MY_P=${PN}
@@ -15,147 +15,137 @@ DESCRIPTION="Video Disk Recorder Xinelib PlugIn"
HOMEPAGE="http://sourceforge.net/projects/xineliboutput/"
ECVS_SERVER="xineliboutput.cvs.sourceforge.net:/cvsroot/xineliboutput"
-ECVS_MODULE="vdr-xineliboutput"
+ECVS_MODULE="${PN}"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="+vdr +xine fbcon X libextractor xinerama"
+KEYWORDS=""
+IUSE="dbus fbcon jpeg libextractor nls +vdr vdpau +X +xine xinerama"
-# both vdr plugin or vdr-sxfe can use X11
-# still depends need some cleanup
COMMON_DEPEND="
- vdr? ( >=media-video/vdr-1.4.0 )
-
- xine? ( >=media-libs/xine-lib-1.1.1 )
-
- media-libs/jpeg
- libextractor? ( >=media-libs/libextractor-0.5.20 )
-
- X? (
- x11-libs/libX11
- x11-libs/libXv
- x11-libs/libXext
- x11-libs/libXrender
- xinerama? ( x11-libs/libXinerama )
+ vdr? (
+ >=media-video/vdr-1.6.0
+ libextractor? ( >=media-libs/libextractor-0.5.20 )
+ )
+
+ xine? (
+ || ( <media-libs/xine-lib-1.2 ( >=media-libs/xine-lib-1.2 media-video/ffmpeg ) )
+ fbcon? ( jpeg? ( media-libs/jpeg ) )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ xinerama? ( x11-libs/libXinerama )
+ dbus? ( dev-libs/dbus-glib dev-libs/glib:2 )
+ vdpau? ( x11-libs/libvdpau >=media-libs/xine-lib-1.2 )
+ jpeg? ( media-libs/jpeg )
+ )
)"
DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
sys-kernel/linux-headers
- X? (
- x11-proto/xextproto
- x11-proto/xf86vidmodeproto
- x11-proto/xproto
- x11-proto/renderproto
- xinerama? ( x11-proto/xineramaproto )
+ nls? ( sys-devel/gettext )
+ xine? (
+ X? (
+ x11-proto/xproto
+ x11-libs/libXxf86vm
+ )
)"
-
RDEPEND="${COMMON_DEPEND}"
S=${WORKDIR}/${MY_P}
-VDR_CONFD_FILE=${FILESDIR}/confd-1.0.0_pre6
+VDR_CONFD_FILE="${FILESDIR}/confd-1.0.0_pre6"
pkg_setup() {
- vdr-plugin_pkg_setup
-
if ! use vdr && ! use xine; then
- eerror "Compiling ${PN} with USE='-vdr -xine' is not possible."
- eerror "You either need at least one of these flags."
- #die "${PN} cannot be used with vdr support and xine support disabled!"
+ die "You either need at least one of these flags: vdr xine"
fi
-}
-use_onoff() {
- if use "$1"; then
- echo 1
- else
- echo 0
- fi
-}
+ vdr-plugin_pkg_setup
-use_onoff_xine() {
- if use xine && use "$1"; then
- echo 1
- else
- echo 0
+ if use xine; then
+ XINE_PLUGIN_DIR=$(xine-config --plugindir)
+ [ -z "${XINE_PLUGIN_DIR}" ] && die "Could not find xine plugin dir"
fi
}
src_prepare() {
- cvs_src_unpack
+ epatch "${FILESDIR}/${P}-build-system.patch"
+
vdr-plugin_src_prepare
- if use xine; then
- XINE_PLUGIN_DIR=$(xine-config --plugindir)
- if [[ ${XINE_PLUGIN_DIR} = "" ]]; then
- eerror "Could not find xine plugin dir"
- die "Could not find xine plugin dir"
- fi
+ sed -i -e 's:^\(LOCALEDIR\) .*:\1 = $(DESTDIR)/usr/share/vdr/locale:' \
+ -e "s:LIBDIR .*:LIBDIR = ${VDR_PLUGIN_DIR}:" \
+ Makefile || die
+}
+
+src_configure() {
+ local myconf
+
+ if has_version ">=media-libs/xine-lib-1.2"; then
+ myconf="${myconf} --enable-libavutil"
+ else
+ myconf="${myconf} --disable-libavutil"
fi
- # stop some automagic overwriting of the stuff we set
- sed -e '/XINELIBOUTPUT_VDRPLUGIN = 1/s/^/#/' \
- -e '/HAVE_EXTRACTOR_H = 1/s/^/#/' \
- -i Makefile
-
- cat >>Make.config <<-EOF
- XINELIBOUTPUT_XINEPLUGIN = $(use_onoff xine)
- XINELIBOUTPUT_VDRPLUGIN = $(use_onoff vdr)
-
- XINELIBOUTPUT_FB = $(use_onoff_xine fbcon)
- XINELIBOUTPUT_X11 = $(use_onoff_xine X)
-
- HAVE_XRENDER = 1
- HAVE_XDPMS = 1
- HAVE_EXTRACTOR_H = $(use_onoff libextractor)
- HAVE_XINERAMA = $(use_onoff xinerama)
- EOF
-
- # patching makefile to work with this
- # $ rm ${outdir}/file; cp file ${outdir}/file
- # work in the sandbox
- sed -i Makefile \
- -e 's:XINEPLUGINDIR.*=.*:XINEPLUGINDIR = '"${WORKDIR}/lib:" \
- -e 's:VDRINCDIR.*=.*:VDRINCDIR ?= /usr/include:'
- mkdir -p "${WORKDIR}/lib"
+ # No autotools based configure script
+ # There is no real opengl support, just the switch and some help text is
+ # left...
+ ./configure \
+ --cc=$(tc-getCC) \
+ --cxx=$(tc-getCXX) \
+ $(use_enable X x11) \
+ $(use_enable X xshm) \
+ $(use_enable X xdpms) \
+ $(use_enable X xshape) \
+ $(use_enable X xrender) \
+ $(use_enable fbcon fb) \
+ $(use_enable vdr) \
+ $(use_enable xine libxine) \
+ $(use_enable libextractor) \
+ $(use_enable jpeg libjpeg) \
+ $(use_enable xinerama) \
+ $(use_enable vdpau) \
+ $(use_enable dbus dbus-glib-1) \
+ $(use_enable nls i18n) \
+ ${myconf} \
+ --disable-opengl \
+ || die
}
-src_configure() { :; }
-
src_install() {
if use vdr; then
- # install vdr plugin
vdr-plugin_src_install
-
- # version number that the sources contain
- local SO_VERSION="$(grep 'static const char \*VERSION *=' xineliboutput.c |\
- cut -d'"' -f2)"
- echo SO_VERSION=$SO_VERSION
- insinto ${VDR_PLUGIN_DIR}
- if use fbcon; then
- doins libxineliboutput-fbfe.so.${SO_VERSION} || die "doins failed"
+ if use nls; then
+ emake DESTDIR="${D}" i18n || die
fi
- if use X; then
- doins libxineliboutput-sxfe.so.${SO_VERSION} || die "doins failed"
- fi
- fi
- if use xine; then
- # install xine-plugins
- insinto "${XINE_PLUGIN_DIR}"
- doins xineplug_inp_*.so
+ if use xine; then
+ insinto $XINE_PLUGIN_DIR
+ doins xineplug_inp_xvdr.so || die
- insinto "${XINE_PLUGIN_DIR}"/post
- doins xineplug_post_*.so
+ insinto $XINE_PLUGIN_DIR/post
+ doins xineplug_post_*.so || die
- # install xine-based frontends
- use fbcon && dobin vdr-fbfe
- use X && dobin vdr-sxfe
+ if use fbcon; then
+ dobin vdr-fbfe || die
- fi
-}
+ insinto $VDR_PLUGIN_DIR
+ doins libxineliboutput-fbfe.so.* || die
+ fi
+
+ if use X; then
+ dobin vdr-sxfe || die
-pkg_config() {
- einfo "emerge --config is not supported"
+ insinto $VDR_PLUGIN_DIR
+ doins libxineliboutput-sxfe.so.* || die
+ fi
+ fi
+ else
+ emake DESTDIR="${D}" install || die
+
+ dodoc HISTORY README
+ fi
}