summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-09-03 12:28:17 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-09-03 12:28:17 +0000
commit691a6d7dffc88e7c0ef733c28d28221bb61ff2f4 (patch)
treefe7d5cadd6a5ef5f928659dce678825ddb04703f /media-plugins
parentremove cstex, it does not exist anymore (diff)
downloadgentoo-2-691a6d7dffc88e7c0ef733c28d28221bb61ff2f4.tar.gz
gentoo-2-691a6d7dffc88e7c0ef733c28d28221bb61ff2f4.tar.bz2
gentoo-2-691a6d7dffc88e7c0ef733c28d28221bb61ff2f4.zip
Add libmtp-0.3.0 API support, patch from upstream bugzilla rebased. Fix configure being invoked with wrong options (flac->flacng, cdaudio-ng->cdaudio).
(Portage version: 2.2_rc8/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/audacious-plugins/ChangeLog10
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-1.5.1-r2.ebuild121
-rw-r--r--media-plugins/audacious-plugins/files/1.5.1-libmtp-0.3.0-API.patch45
3 files changed, 175 insertions, 1 deletions
diff --git a/media-plugins/audacious-plugins/ChangeLog b/media-plugins/audacious-plugins/ChangeLog
index 721294fa3371..19b44fb384da 100644
--- a/media-plugins/audacious-plugins/ChangeLog
+++ b/media-plugins/audacious-plugins/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/audacious-plugins
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.95 2008/08/01 16:56:15 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.96 2008/09/03 12:28:03 loki_val Exp $
+
+*audacious-plugins-1.5.1-r2 (03 Sep 2008)
+
+ 03 Sep 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/1.5.1-libmtp-0.3.0-API.patch, +audacious-plugins-1.5.1-r2.ebuild:
+ Add libmtp-0.3.0 API support, patch from upstream bugzilla rebased. Fix
+ configure being invoked with wrong options (flac->flacng,
+ cdaudio-ng->cdaudio).
01 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/media-plugins/audacious-plugins/audacious-plugins-1.5.1-r2.ebuild b/media-plugins/audacious-plugins/audacious-plugins-1.5.1-r2.ebuild
new file mode 100644
index 000000000000..7eb9c52bc7b5
--- /dev/null
+++ b/media-plugins/audacious-plugins/audacious-plugins-1.5.1-r2.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-1.5.1-r2.ebuild,v 1.1 2008/09/03 12:28:03 loki_val Exp $
+
+inherit eutils flag-o-matic autotools
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aac adplug alsa arts chardet esd flac gnome jack lirc modplug mp3 mtp musepack nls oss pulseaudio scrobbler sdl sid sndfile sse2 timidity tta vorbis wavpack wma"
+
+RDEPEND="app-arch/unzip
+ >=dev-libs/libcdio-0.79-r1
+ >=dev-libs/dbus-glib-0.60
+ dev-libs/libxml2
+ >=gnome-base/libglade-2.3.1
+ >=media-libs/libcddb-1.2.1
+ >=media-sound/audacious-1.5.1-r1
+ >=net-misc/neon-0.26.4
+ >=x11-libs/gtk+-2.10
+ adplug? ( >=dev-cpp/libbinio-1.4 )
+ alsa? ( >=media-libs/alsa-lib-1.0.16 )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.38-r1 )
+ flac? ( >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.2.1-r1 )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-sound/jack-audio-connection-kit )
+ lirc? ( app-misc/lirc )
+ mp3? ( media-libs/libmad )
+ mtp? ( media-libs/libmtp )
+ musepack? ( media-libs/libmpcdec media-libs/taglib )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
+ scrobbler? ( net-misc/curl
+ media-libs/musicbrainz )
+ sdl? ( >=media-libs/libsdl-1.2.5 )
+ sid? ( media-libs/libsidplay )
+ sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
+ timidity? ( media-sound/timidity++ )
+ tta? ( media-libs/libid3tag )
+ vorbis? ( >=media-libs/libvorbis-1.2.0
+ >=media-libs/libogg-1.1.3 )
+ wavpack? ( >=media-sound/wavpack-4.41.0 )
+ wma? ( >=media-libs/libmms-0.3 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+mp3_warning() {
+ if ! useq mp3 ; then
+ ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Bug 232418; patch by Ivan Iraci <ivanhoe@vfemail.net>
+ epatch "${FILESDIR}/${PV}-missing-include.patch"
+ # Bug 230995; patch by Linus Walleij
+ # http://bugzilla.atheme.org/show_bug.cgi?id=35
+ # Rebased from hg head to 1.5.1
+ epatch "${FILESDIR}/${PV}-libmtp-0.3.0-API.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ mp3_warning
+
+ econf \
+ --enable-cdaudio \
+ --enable-dbus \
+ --enable-neon \
+ --disable-projectm \
+ --disable-projectm-1.0 \
+ $(use_enable aac) \
+ $(use_enable adplug) \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable chardet) \
+ $(use_enable esd) \
+ $(use_enable flac flacng) \
+ $(use_enable jack) \
+ $(use_enable gnome gnomeshortcuts) \
+ $(use_enable lirc) \
+ $(use_enable mp3) \
+ $(use_enable modplug) \
+ $(use_enable musepack) \
+ $(use_enable mtp mtp_up) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable sdl paranormal) \
+ $(use_enable sid) \
+ $(use_enable sndfile) \
+ $(use_enable sse2) \
+ $(use_enable timidity) \
+ $(use_enable tta) \
+ $(use_enable vorbis) \
+ $(use_enable wavpack) \
+ $(use_enable wma) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ mp3_warning
+}
diff --git a/media-plugins/audacious-plugins/files/1.5.1-libmtp-0.3.0-API.patch b/media-plugins/audacious-plugins/files/1.5.1-libmtp-0.3.0-API.patch
new file mode 100644
index 000000000000..532026af8adb
--- /dev/null
+++ b/media-plugins/audacious-plugins/files/1.5.1-libmtp-0.3.0-API.patch
@@ -0,0 +1,45 @@
+diff -NrU5 audacious-plugins-1.5.1.orig/configure.ac audacious-plugins-1.5.1/configure.ac
+--- audacious-plugins-1.5.1.orig/configure.ac 2008-09-03 12:59:59.000000000 +0200
++++ audacious-plugins-1.5.1/configure.ac 2008-09-03 13:02:47.000000000 +0200
+@@ -1363,10 +1363,15 @@
+ if test "x$have_mtp_up" = "xyes"; then
+ have_mtp_up=yes
+ PKG_CHECK_MODULES(MTP, [libmtp >= 0.1.3], [GENERAL_PLUGINS="$GENERAL_PLUGINS mtp_up" ], [have_mtp_up="no"])
+ MTP_LIBS=`pkg-config --libs libmtp`
+ MTP_CFLAGS=`pkg-config --cflags libmtp`
++ dnl Check for libmtp 0.3.0+
++ PKG_CHECK_EXISTS( [libmtp >= 0.3.0], [libmtp_030_pkg=yes], [libmtp_030_pkg=no])
++ if test x"$libmtp_030_pkg" = "xyes" ; then
++ AC_DEFINE([HAVE_LIBMTP_030], 1, [indicates if at least libmtp 0.3.0 is installed])
++ fi
+ else
+ have_mtp_up=no
+ AC_MSG_RESULT([*** mtp upload plugin disabled by request ***])
+ fi
+ AC_SUBST(MTP_LIBS)
+diff -NrU5 audacious-plugins-1.5.1.orig/src/mtp_up/mtp.c audacious-plugins-1.5.1/src/mtp_up/mtp.c
+--- audacious-plugins-1.5.1.orig/src/mtp_up/mtp.c 2008-09-03 12:59:59.000000000 +0200
++++ audacious-plugins-1.5.1/src/mtp_up/mtp.c 2008-09-03 13:05:55.000000000 +0200
+@@ -190,16 +190,21 @@
+ tmp = g_strescape(from_path,NULL);
+ filename=g_filename_from_uri(tmp,NULL,NULL);
+
+ g_free(from_path);
+ g_free(tmp);
+- parent_id = mtp_device->default_music_folder;
+
+ #if DEBUG
+ g_print("Uploading track '%s'\n",filename);
+ #endif
++#ifdef HAVE_LIBMTP_030
++ gentrack->parent_id = mtp_device->default_music_folder;
++ ret = LIBMTP_Send_Track_From_File(mtp_device, filename , gentrack, NULL , NULL);
++#else
++ parent_id = mtp_device->default_music_folder;
+ ret = LIBMTP_Send_Track_From_File(mtp_device, filename , gentrack, NULL , NULL, parent_id);
++#endif
+ LIBMTP_destroy_track_t(gentrack);
+ if (ret == 0)
+ g_print("Track upload finished!\n");
+ else
+ {