summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-07 21:22:47 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-07 21:22:47 +0000
commitba6f5c265f14842832742926ace0e7f560f4f2cf (patch)
tree0a9f41a35c5554868afb5e97c86fb7da638f4179 /media-plugins/xmms-morestate
parentBump runtime snapshot to fix netrw problems with rsync-over-ssh (diff)
downloadgentoo-2-ba6f5c265f14842832742926ace0e7f560f4f2cf.tar.gz
gentoo-2-ba6f5c265f14842832742926ace0e7f560f4f2cf.tar.bz2
gentoo-2-ba6f5c265f14842832742926ace0e7f560f4f2cf.zip
Makefile patch for non-x86 platforms closes bug #54265.
Diffstat (limited to 'media-plugins/xmms-morestate')
-rw-r--r--media-plugins/xmms-morestate/ChangeLog6
-rw-r--r--media-plugins/xmms-morestate/files/xmms-morestate-1.2-Makefile.patch22
-rw-r--r--media-plugins/xmms-morestate/xmms-morestate-1.2.ebuild17
3 files changed, 40 insertions, 5 deletions
diff --git a/media-plugins/xmms-morestate/ChangeLog b/media-plugins/xmms-morestate/ChangeLog
index 8a99a933bc97..e17b383b2c31 100644
--- a/media-plugins/xmms-morestate/ChangeLog
+++ b/media-plugins/xmms-morestate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/xmms-morestate
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-morestate/ChangeLog,v 1.6 2004/06/24 23:43:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-morestate/ChangeLog,v 1.7 2004/07/07 21:22:47 eradicator Exp $
+
+ 07 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ xmms-morestate-1.2.ebuild:
+ Makefile patch for non-x86 platforms closes bug #54265.
17 Jun 2004; Jeremy Huddleston <eradicator@gentoo.org>
xmms-morestate-1.2.ebuild:
diff --git a/media-plugins/xmms-morestate/files/xmms-morestate-1.2-Makefile.patch b/media-plugins/xmms-morestate/files/xmms-morestate-1.2-Makefile.patch
new file mode 100644
index 000000000000..5238077f088a
--- /dev/null
+++ b/media-plugins/xmms-morestate/files/xmms-morestate-1.2-Makefile.patch
@@ -0,0 +1,22 @@
+diff -Naur xmms-morestate-1.2.orig/Makefile.am xmms-morestate-1.2/Makefile.am
+--- xmms-morestate-1.2.orig/Makefile.am 2003-01-29 00:09:00.000000000 -0800
++++ xmms-morestate-1.2/Makefile.am 2004-07-07 14:14:20.197617116 -0700
+@@ -1,5 +1,5 @@
+ bin_PROGRAMS = libmorestate.so
+ libmorestate_so_SOURCES = autoplay.c config.c win_config.c win_about.c misc.c
+ noinst_HEADERS = autoplay.h
+-AM_CFLAGS = -Wall -shared -mcpu=i386
++AM_CFLAGS = -Wall -shared -fPIC -DPIC
+ bindir = @libdir@
+diff -Naur xmms-morestate-1.2.orig/Makefile.in xmms-morestate-1.2/Makefile.in
+--- xmms-morestate-1.2.orig/Makefile.in 2003-08-20 02:12:05.000000000 -0700
++++ xmms-morestate-1.2/Makefile.in 2004-07-07 14:14:34.563223588 -0700
+@@ -106,7 +106,7 @@
+ bin_PROGRAMS = libmorestate.so
+ libmorestate_so_SOURCES = autoplay.c config.c win_config.c win_about.c misc.c
+ noinst_HEADERS = autoplay.h
+-AM_CFLAGS = -Wall -shared -mcpu=i386
++AM_CFLAGS = -Wall -shared -fPIC -DPIC
+ subdir = .
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/media-plugins/xmms-morestate/xmms-morestate-1.2.ebuild b/media-plugins/xmms-morestate/xmms-morestate-1.2.ebuild
index f7c94046ff87..b4b9e0e8a1b6 100644
--- a/media-plugins/xmms-morestate/xmms-morestate-1.2.ebuild
+++ b/media-plugins/xmms-morestate/xmms-morestate-1.2.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation; alexf <acid DOT punk AT gmx DOT net>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-morestate/xmms-morestate-1.2.ebuild,v 1.6 2004/06/24 23:43:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-morestate/xmms-morestate-1.2.ebuild,v 1.7 2004/07/07 21:22:47 eradicator Exp $
+
+IUSE=""
+
+inherit eutils
DESCRIPTION=" XMMS Morestate restores ESD volume, song time, and playing/paused status"
SRC_URI="mirror://sourceforge/xmms-morestate/${P}.tar.gz"
@@ -9,10 +13,15 @@ HOMEPAGE="http://xmms-morestate.sourceforge.net"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 amd64 ~ppc ~sparc"
-IUSE=""
+KEYWORDS="x86 amd64 ~ppc sparc"
+
+DEPEND="media-sound/xmms"
-DEPEND=">=media-sound/xmms-1.2.7"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-Makefile.patch
+}
src_install() {
make DESTDIR=${D} install || die "Install failed."