summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-07-14 16:43:34 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-07-14 16:43:34 +0000
commit4648c9085456d7293ddabe8af297656c0b5f87d4 (patch)
treefc5ab60e816164e1af587b01a762f7a07b1a337d /media-plugins/vdr-softdevice
parentRe-add ~alpha (diff)
downloadgentoo-2-4648c9085456d7293ddabe8af297656c0b5f87d4.tar.gz
gentoo-2-4648c9085456d7293ddabe8af297656c0b5f87d4.tar.bz2
gentoo-2-4648c9085456d7293ddabe8af297656c0b5f87d4.zip
Added new snapshot. Apply a patch against problem with shm video-out at first vdr start.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'media-plugins/vdr-softdevice')
-rw-r--r--media-plugins/vdr-softdevice/ChangeLog10
-rw-r--r--media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.4.0.200707113
-rw-r--r--media-plugins/vdr-softdevice/files/patches-0.4.0/series2
-rw-r--r--media-plugins/vdr-softdevice/files/patches-0.4.0/shm-init-setupStore.diff37
-rw-r--r--media-plugins/vdr-softdevice/vdr-softdevice-0.4.0.20070711.ebuild138
5 files changed, 188 insertions, 2 deletions
diff --git a/media-plugins/vdr-softdevice/ChangeLog b/media-plugins/vdr-softdevice/ChangeLog
index a4a6305a35d5..90c62226193e 100644
--- a/media-plugins/vdr-softdevice/ChangeLog
+++ b/media-plugins/vdr-softdevice/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/vdr-softdevice
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.42 2007/07/09 09:36:47 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.43 2007/07/14 16:43:34 zzam Exp $
+
+*vdr-softdevice-0.4.0.20070711 (14 Jul 2007)
+
+ 14 Jul 2007; Matthias Schwarzott <zzam@gentoo.org>
+ files/patches-0.4.0/series, +files/patches-0.4.0/shm-init-setupStore.diff,
+ +vdr-softdevice-0.4.0.20070711.ebuild:
+ Added new snapshot. Apply a patch against problem with shm video-out at
+ first vdr start.
09 Jul 2007; Matthias Schwarzott <zzam@gentoo.org>
files/patches-0.4.0/new-ffmpeg-extern-c.diff:
diff --git a/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.4.0.20070711 b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.4.0.20070711
new file mode 100644
index 000000000000..3eeecc3b1532
--- /dev/null
+++ b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.4.0.20070711
@@ -0,0 +1,3 @@
+MD5 79ea86ce835afb2a2814dda089a150cb vdr-softdevice-cvs-20070711.tar.bz2 152000
+RMD160 23be2f95bbb3e4d649a3ade799c443c579f80b84 vdr-softdevice-cvs-20070711.tar.bz2 152000
+SHA256 6c869ae0c86fe42a24f767c40f538d07f70806474d7851643870b3a778b68c1a vdr-softdevice-cvs-20070711.tar.bz2 152000
diff --git a/media-plugins/vdr-softdevice/files/patches-0.4.0/series b/media-plugins/vdr-softdevice/files/patches-0.4.0/series
index 3e52f157fc9e..2e3227d1b560 100644
--- a/media-plugins/vdr-softdevice/files/patches-0.4.0/series
+++ b/media-plugins/vdr-softdevice/files/patches-0.4.0/series
@@ -1,2 +1,2 @@
-new-ffmpeg-extern-c.diff
shm-fullscreen-parameter.diff
+shm-init-setupStore.diff
diff --git a/media-plugins/vdr-softdevice/files/patches-0.4.0/shm-init-setupStore.diff b/media-plugins/vdr-softdevice/files/patches-0.4.0/shm-init-setupStore.diff
new file mode 100644
index 000000000000..2ec7f2ab70b6
--- /dev/null
+++ b/media-plugins/vdr-softdevice/files/patches-0.4.0/shm-init-setupStore.diff
@@ -0,0 +1,37 @@
+Index: softdevice-cvs/setup-softdevice.h
+===================================================================
+--- softdevice-cvs.orig/setup-softdevice.h
++++ softdevice-cvs/setup-softdevice.h
+@@ -175,6 +175,8 @@ struct cSetupStore {
+ setSourceRectangleLocked;
+ char alsaDevice [ALSA_DEVICE_NAME_LENGTH];
+ char alsaAC3Device [ALSA_DEVICE_NAME_LENGTH];
++
++ int setupStoreShmid;
+ };
+
+ #define OSDMODE_PSEUDO 0
+Index: softdevice-cvs/softdevice.c
+===================================================================
+--- softdevice-cvs.orig/softdevice.c
++++ softdevice-cvs/softdevice.c
+@@ -850,6 +850,7 @@ cPluginSoftDevice::cPluginSoftDevice(voi
+ ctl=NULL;
+ };
+ setupStore->InitSetupStore();
++ setupStore->setupStoreShmid = setupStoreShmId;
+ #endif
+ }
+
+Index: softdevice-cvs/video-shm.c
+===================================================================
+--- softdevice-cvs.orig/video-shm.c
++++ softdevice-cvs/video-shm.c
+@@ -91,6 +91,7 @@ cShmVideoOut::cShmVideoOut(cSetupStore *
+ ctl->pict_shmid=-1;
+ ctl->osd_shmid=-1;
+ ctl->attached = 0;
++ ctl->setup_shmid = setupStore->setupStoreShmid;
+ };
+
+ if ( ctl->semid == -1 ) {
diff --git a/media-plugins/vdr-softdevice/vdr-softdevice-0.4.0.20070711.ebuild b/media-plugins/vdr-softdevice/vdr-softdevice-0.4.0.20070711.ebuild
new file mode 100644
index 000000000000..c63e0dcaed53
--- /dev/null
+++ b/media-plugins/vdr-softdevice/vdr-softdevice-0.4.0.20070711.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.4.0.20070711.ebuild,v 1.1 2007/07/14 16:43:34 zzam Exp $
+
+inherit vdr-plugin versionator
+
+DESCRIPTION="VDR Plugin: Software output-Device"
+HOMEPAGE="http://softdevice.berlios.de/"
+
+# Detect snapshots
+SNAP_V="$(get_version_component_range 4)"
+if [[ "$SNAP_V" ]]; then
+ MY_P="${PN}-cvs-${SNAP_V}"
+ S="${WORKDIR}/${MY_P#vdr-}"
+ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~zzam/distfiles/${MY_P}.tar.bz2"
+else
+ SRC_URI="mirror://berlios/${PN#vdr-}/${P}.tgz"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xv fbcon directfb mmx mmxext xinerama"
+
+RDEPEND=">=media-video/vdr-1.3.36
+ >=media-video/ffmpeg-0.4.9_pre1
+ directfb? (
+ dev-libs/DirectFB
+ dev-libs/DFB++
+ )
+ media-libs/alsa-lib
+ xv? ( || ( ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXv
+ xinerama? ( x11-libs/libXinerama )
+ )
+ virtual/x11
+ ) )"
+
+DEPEND="${RDEPEND}
+ xv? ( || ( ( x11-proto/xproto
+ x11-proto/xextproto
+ x11-libs/libXv
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ ) )
+ fbcon? ( sys-kernel/linux-headers )
+ dev-util/pkgconfig"
+# Make sure the assembler USE flags are unmasked on amd64
+# Remove this once default-linux/amd64/2006.1 is deprecated
+DEPEND="${DEPEND} amd64? ( >=sys-apps/portage-2.1.2 )"
+
+PATCHES="
+ ${FILESDIR}/patches-0.4.0/shm-fullscreen-parameter.diff
+ ${FILESDIR}/patches-0.4.0/shm-init-setupStore.diff"
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ if use !xv && use !fbcon && use !directfb; then
+ ewarn "You need to set at least one of these use-flags: xv fbcon directfb"
+ die "no output-method enabled"
+ fi
+
+ COMPILE_SHM=0
+ if has_version ">=media-video/vdr-1.3.0"; then
+ if use xv; then
+ COMPILE_SHM=1
+ else
+ elog "SHM does only support xv at the moment"
+ fi
+ else
+ elog "SHM not supported on vdr-1.2"
+ fi
+ case ${COMPILE_SHM} in
+ 0) elog "SHM support will not be compiled." ;;
+ 1) elog "SHM support will be compiled." ;;
+ esac
+
+ # Check for ffmpeg relying on libtheora without pkg-config-file
+ # Bug #142250
+ if built_with_use media-video/ffmpeg theora && \
+ has_version "<media-libs/libtheora/libtheora-1.0_alpha4"; then
+
+ eerror "This package will not work when using ffmpeg with"
+ eerror "USE=\"theora\" combined with media-libs/libtheora"
+ eerror "older than version 1.0_alpha4."
+ eerror "Please update to at least media-libs/libtheora-1.0_alpha4."
+ die "Please update to at least media-libs/libtheora-1.0_alpha4."
+ fi
+}
+
+src_compile() {
+ local MYOPTS=""
+ MYOPTS="${MYOPTS} --disable-vidix"
+ use xv || MYOPTS="${MYOPTS} --disable-xv"
+ use fbcon || MYOPTS="${MYOPTS} --disable-fb"
+ use directfb || MYOPTS="${MYOPTS} --disable-dfb"
+
+ use mmx || MYOPTS="${MYOPTS} --disable-mmx"
+ use mmxext || MYOPTS="${MYOPTS} --disable-mmx2"
+
+ if use !mmx && use !mmxext; then
+ ewarn "${PN}"' does not compile with USE="-mmx -mmxext".'
+ ewarn 'Please enable at least one of these two use-flags.'
+ die "${PN}"' does not compile with USE="-mmx -mmxext".'
+ fi
+
+ use xinerama || MYOPTS="${MYOPTS} --disable-xinerama"
+
+ [[ ${COMPILE_SHM} == 1 ]] || MYOPTS="${MYOPTS} --disable-shm"
+
+ cd ${S}
+ elog configure ${MYOPTS}
+ ./configure ${MYOPTS} || die "configure failed"
+
+ vdr-plugin_src_compile
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ cd ${S}
+
+ insinto "${VDR_PLUGIN_DIR}"
+ doins libsoftdevice-*.so.*
+
+ if [[ "${COMPILE_SHM}" = "1" ]]; then
+ exeinto "/usr/bin"
+ doexe ShmClient
+ fi
+
+ insinto /usr/include/vdr-softdevice
+ doins *.h
+}