summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-22 05:28:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-22 05:28:32 +0000
commit73e3f36b60772d72c635a7ccc9046867cffa738c (patch)
treef6b502b1e34fd308efa7d8adb7870f2a8bd1df0d /media-plugins/vdr-osdpip
parentfix build with latest ffmpeg, bug #278947 (diff)
downloadgentoo-2-73e3f36b60772d72c635a7ccc9046867cffa738c.tar.gz
gentoo-2-73e3f36b60772d72c635a7ccc9046867cffa738c.tar.bz2
gentoo-2-73e3f36b60772d72c635a7ccc9046867cffa738c.zip
fix build with latest ffmpeg
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/vdr-osdpip')
-rw-r--r--media-plugins/vdr-osdpip/ChangeLog8
-rw-r--r--media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.10-avutil50.patch45
-rw-r--r--media-plugins/vdr-osdpip/vdr-osdpip-0.0.10.ebuild5
3 files changed, 54 insertions, 4 deletions
diff --git a/media-plugins/vdr-osdpip/ChangeLog b/media-plugins/vdr-osdpip/ChangeLog
index 41c01ac5ced7..20ca079b9eaf 100644
--- a/media-plugins/vdr-osdpip/ChangeLog
+++ b/media-plugins/vdr-osdpip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-osdpip
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/ChangeLog,v 1.9 2008/12/17 06:28:21 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/ChangeLog,v 1.10 2009/09/22 05:28:32 aballier Exp $
+
+ 22 Sep 2009; Alexis Ballier <aballier@gentoo.org>
+ vdr-osdpip-0.0.10.ebuild, +files/vdr-osdpip-0.0.10-avutil50.patch:
+ fix build with latest ffmpeg
17 Dec 2008; <ssuominen@gentoo.org> vdr-osdpip-0.0.10.ebuild:
x86 stable, because current stable doesn't link against -lswscale.
diff --git a/media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.10-avutil50.patch b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.10-avutil50.patch
new file mode 100644
index 000000000000..822957030442
--- /dev/null
+++ b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.10-avutil50.patch
@@ -0,0 +1,45 @@
+Index: osdpip-0.0.10/decoder.c
+===================================================================
+--- osdpip-0.0.10.orig/decoder.c
++++ osdpip-0.0.10/decoder.c
+@@ -27,10 +27,10 @@ int cDecoder::Open()
+ }
+ m_PicDecoded = avcodec_alloc_frame();
+ m_PicResample = avcodec_alloc_frame();
+- m_BufferResample = new unsigned char[400 * 300 * 4]; // size for RGBA32
++ m_BufferResample = new unsigned char[400 * 300 * 4]; // size for RGB32
+ #ifndef USE_SWSCALE
+ m_PicConvert = avcodec_alloc_frame();
+- m_BufferConvert = new unsigned char[400 * 300 * 4]; // size for RGBA32
++ m_BufferConvert = new unsigned char[400 * 300 * 4]; // size for RGB32
+ #endif
+
+ return 0;
+@@ -82,14 +82,14 @@ int cDecoder::Resample(int width, int he
+ context = sws_getContext(m_Context->width - (OsdPipSetup.CropLeft + OsdPipSetup.CropRight),
+ m_Context->height - (OsdPipSetup.CropTop + OsdPipSetup.CropBottom),
+ PIX_FMT_YUV420P,
+- m_Width, m_Height, ConvertToRGB ? PIX_FMT_RGBA32 : PIX_FMT_YUV420P,
++ m_Width, m_Height, ConvertToRGB ? PIX_FMT_RGB32 : PIX_FMT_YUV420P,
+ SWS_LANCZOS, NULL, NULL, NULL);
+ if (!context) {
+ printf("Error initializing scale context.\n");
+ return -1;
+ }
+ avpicture_fill((AVPicture *) m_PicResample, m_BufferResample,
+- ConvertToRGB ? PIX_FMT_RGBA32 : PIX_FMT_YUV420P,
++ ConvertToRGB ? PIX_FMT_RGB32 : PIX_FMT_YUV420P,
+ m_Width, m_Height);
+ sws_scale(context, pic_crop.data, pic_crop.linesize,
+ 0, m_Context->height - (OsdPipSetup.CropTop + OsdPipSetup.CropBottom),
+@@ -121,8 +121,8 @@ int cDecoder::Resample(int width, int he
+ if (ConvertToRGB)
+ {
+ avpicture_fill((AVPicture *) m_PicConvert, m_BufferConvert,
+- PIX_FMT_RGBA32, m_Width, m_Height);
+- img_convert((AVPicture *) m_PicConvert, PIX_FMT_RGBA32,
++ PIX_FMT_RGB32, m_Width, m_Height);
++ img_convert((AVPicture *) m_PicConvert, PIX_FMT_RGB32,
+ (AVPicture *) m_PicResample, PIX_FMT_YUV420P,
+ m_Width, m_Height);
+ }
diff --git a/media-plugins/vdr-osdpip/vdr-osdpip-0.0.10.ebuild b/media-plugins/vdr-osdpip/vdr-osdpip-0.0.10.ebuild
index 21dcef85e025..eac8961c492b 100644
--- a/media-plugins/vdr-osdpip/vdr-osdpip-0.0.10.ebuild
+++ b/media-plugins/vdr-osdpip/vdr-osdpip-0.0.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 2003-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/vdr-osdpip-0.0.10.ebuild,v 1.2 2008/12/17 06:28:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/vdr-osdpip-0.0.10.ebuild,v 1.3 2009/09/22 05:28:32 aballier Exp $
inherit vdr-plugin
@@ -19,6 +19,7 @@ DEPEND=">=media-video/vdr-1.4.0
"
#PATCHES=("${FILESDIR}/${P}-vdr-1.5.0.diff")
+PATCHES=( "${FILESDIR}/${P}-avutil50.patch" )
src_unpack() {
vdr-plugin_src_unpack