summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-12-17 15:08:40 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-12-17 15:08:40 +0000
commit3ae745a30f07c952052094347872c578c26f0a97 (patch)
tree4e61c1c9991e39e5367981d958e385600acbe3ec /media-plugins/vdr-extb
parentupdated patch for confix to work with DESTDIR installs (diff)
downloadgentoo-2-3ae745a30f07c952052094347872c578c26f0a97.tar.gz
gentoo-2-3ae745a30f07c952052094347872c578c26f0a97.tar.bz2
gentoo-2-3ae745a30f07c952052094347872c578c26f0a97.zip
Fix compilation with gcc-4.3. Bug #251189.
(Portage version: 2.1.6.1/cvs/Linux 2.6.27-gentoo-r1 i686)
Diffstat (limited to 'media-plugins/vdr-extb')
-rw-r--r--media-plugins/vdr-extb/ChangeLog6
-rw-r--r--media-plugins/vdr-extb/files/vdr-extb-0.3.0-gcc4.3.diff12
-rw-r--r--media-plugins/vdr-extb/vdr-extb-0.3.0.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/media-plugins/vdr-extb/ChangeLog b/media-plugins/vdr-extb/ChangeLog
index f4d8b0a9186f..87954254bb00 100644
--- a/media-plugins/vdr-extb/ChangeLog
+++ b/media-plugins/vdr-extb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-extb
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-extb/ChangeLog,v 1.2 2008/03/30 12:29:21 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-extb/ChangeLog,v 1.3 2008/12/17 15:08:40 zzam Exp $
+
+ 17 Dec 2008; Matthias Schwarzott <zzam@gentoo.org>
+ +files/vdr-extb-0.3.0-gcc4.3.diff, vdr-extb-0.3.0.ebuild:
+ Fix compilation with gcc-4.3. Bug #251189.
30 Mar 2008; Joerg Bornkessel <hd_brummy@gentoo.org> -files/rc.irexec,
vdr-extb-0.2.9.ebuild, vdr-extb-0.3.0.ebuild:
diff --git a/media-plugins/vdr-extb/files/vdr-extb-0.3.0-gcc4.3.diff b/media-plugins/vdr-extb/files/vdr-extb-0.3.0-gcc4.3.diff
new file mode 100644
index 000000000000..0a514c42312f
--- /dev/null
+++ b/media-plugins/vdr-extb/files/vdr-extb-0.3.0-gcc4.3.diff
@@ -0,0 +1,12 @@
+diff -ru extb-0.3.0-orig/lirc.h extb-0.3.0/lirc.h
+--- extb-0.3.0-orig/lirc.h 2008-12-17 15:57:18.715406804 +0100
++++ extb-0.3.0/lirc.h 2008-12-17 16:04:31.962027257 +0100
+@@ -24,6 +24,8 @@
+
+ #include <vector>
+ #define __STL_CONFIG_H
++#include <stdlib.h>
++#include <string.h>
+ #include <vdr/thread.h>
+
+ ///////////////////////////////////////////////////////////////////////////////
diff --git a/media-plugins/vdr-extb/vdr-extb-0.3.0.ebuild b/media-plugins/vdr-extb/vdr-extb-0.3.0.ebuild
index f60f356bec1c..ee9239ae47ce 100644
--- a/media-plugins/vdr-extb/vdr-extb-0.3.0.ebuild
+++ b/media-plugins/vdr-extb/vdr-extb-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-extb/vdr-extb-0.3.0.ebuild,v 1.2 2008/03/30 12:29:21 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-extb/vdr-extb-0.3.0.ebuild,v 1.3 2008/12/17 15:08:40 zzam Exp $
inherit vdr-plugin
@@ -23,6 +23,7 @@ src_unpack() {
cd "${WORKDIR}"
epatch "${FILESDIR}/${PN}-0.2.9-gentoo.diff"
+ epatch "${FILESDIR}/${P}-gcc4.3.diff"
}
src_install() {